Unable to connect to the database:Could not connect to MySQL

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Unable to connect to the database:Could not connect to MySQL

    Hello tout le monde,

    Je débute avec Joomla et j'ai déjà un soucis à l'installation. J'ai bien installé tous les fichiers sur mon espace web. J'ai bien créé une base de données (je suis sur Dedibox). Je peux accéder à la base de donnée via PhpMyAdmin avec les nom et mot de passe fourni par mon hébergeur. Quand je me connecte sur mon site, j'arrive bien à la 1ère page d'activation de Joomla qui me demande de choisir ma langue, puis sur les pages suivantes l'acceptation de clauses et la page sur laquelle tout est coché en vert pour dire que c'est OK. Et c'est là que ça coince. Sur la page "Configuration de la base de données" je rentre scrupuleusement les mêmes codes que dans PhpMyAdmin et le nom de la base etc.. et sur la page suivante, je reçois le message suivant :

    Unable to connect to the database:Could not connect to MySQL

    Quelqu'un a une idée sur ce problème ? Merci d'avance pour votre aide. Olivier

  • #2
    Bienvenue !

    Il est probable que tu aies donné une mauvaise info concernant le nom du serveur de base, ou celui de la base, s'il est différent de celui de l'utilisateur.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Merci de ta réponse Robert, mais je ne crois pas m'être trompé. J'ai dû vérifier une bonne dizaine de fois. Le nom de la base de donnée qui m'est donnée par mon hébergeur est "afsb.skibob.fr", le nom de domaine étant "www.skibob.fr". Faut-il éventuellement entrer autre chose que le nom simple de la base de donnée ? En ajoutant un "http://" ou quelque chose avant ?

      Commentaire


      • #4
        Bonjour,
        je ne crois pas m'être trompé
        j'espère sincèrement que tu t'es trompé sinon tu as *vraiment* un problème...

        le nom de domaine étant "www.skibob.fr"
        Certes, mais ce qu'il faut renseigner c'est le nom du serveur de la base de donnée...
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Le nom de la base de donnée qui m'est donnée par mon hébergeur est "afsb.skibob.fr"
          Ce serait une première, les .,;: et espaces sont interdits dans les noms de bases de données, ainsi que dans les noms d etables ou champs.
          Pas de demande de support par MP.
          S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

          Commentaire


          • #6
            Envoyé par jisse03 Voir le message
            Ce serait une première, les .,;: et espaces sont interdits dans les noms de bases de données, ainsi que dans les noms d etables ou champs.
            Je me suis peut-être mal exprimé. Le nom du serveur est "afsb.skibob.fr".

            Je viens de supprimer la base de donnée et je recommence à zéro. La procédure que je suis est la suivante :
            1 - je décompresse localement dans un dossier sur mon PC le pack Joomla
            2 - j'envoie les dossiers via Filezilla dans le dossier "www" de mon site
            3 - je vais créer une base de données sur mon compte administrateur chez mon hébergeur
            4 - j'attends que la base de données soit effectivement "active" (c'est à dire pas marquée "en cours de création")
            5 - je connecte sur mon site web avec mon navigateur et en principe je suis simplement la procédure en remplissant correctement les champs avec les infos données par mon hébergeur.

            Est-ce que j'ai tout bon ? Si ça se trouve j'oublie un truc super important et je ne le sais pas. Quelqu'un peut me confirmer que ce que je fais est OK ?

            Commentaire


            • #7
              Re,
              Est-ce que j'ai tout bon ?
              Dit comme ça oui, sauf qu'il doit y avoir au moins un paramètre entre le nom de la base, le nom du serveur, le user et le mot de passe qui n'est pas correct...

              Vérifie aussi que tu n'inverses pas "nom de la base" et "nom du serveur"
              Schtroumpfe toi le Schtroumpf t'aidera.
              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

              Commentaire


              • #8
                Voilà ce que j'ai sur la page de mon hébergeur


                Et voilà ce que je tape dans l'installation de Joomla (mot de passe non apparant étant "reblochon1000". Comme je suis reparti de zéro j'ai changé le nom de la base.


                Je viens de tout recommencer et j'ai toujours le même problème. Si quelqu'un veut essayer avec mes codes depuis son PC il n'y a pas de problème. Je modifierais le mot de passe plus tard.
                Dernière édition par ze doctor à 22/09/2010, 12h22

                Commentaire


                • #9
                  Regardes le nom du serveur : afsb.skibob.fr

                  Cordialement,
                  Joël

                  Commentaire


                  • #10
                    Envoyé par jovdev Voir le message
                    Regardes le nom du serveur : afsb.skibob.fr
                    C'est ce que j'ai indiqué dans mon dernier message. En repartant de zéro, j'ai changé le nom de la base de "afsb" à "skibob" et du coup le nom du serveur est devenu "skibob.skibob.fr"

                    Commentaire


                    • #11
                      problème solutionné !!!

                      Ça y est, c'est solutionné. Le problème venait en fait de mon hébergeur. Pour info je suis chez Dedibox et j'ai utilisé l'IRC (le "chat") technique du site pour dialoguer avec les gens compétents. Après "x" questions et explications sur le problème rencontré, ils ont finalement constaté qu'il y avait une erreur sur les DNS et ils m'ont donné une solution provisoire (une adresse de base de données alternative) pour pouvoir installer Joomla et travailler dessus en attendant que les DNS soient réactivées.

                      Maintenant tout est OK et je peux enfin avancer. Merci à tous ceux qui sont venus me donner un coup de main ici. Vous êtes super.

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X