Erreur #1045 dans easyphp 5.3.3

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Erreur #1045 dans easyphp 5.3.3

    Bonjour,
    j'essaie d'installer en local Joomla, grâce à Easyphp 5.3.3 mais quand je me connecte a phpmyadmin pour créer ma base de données il me m'est cette erreur :

    Erreur :

    "MySQL a répondu: Documentation
    #1045 - Acc�s refus� pour l'utilisateur: 'root'@'@localhost' (mot de passe: NON)

    phpMyAdmin a tenté de se connecter au serveur MySQL, et le serveur a rejeté la connexion. Veuillez vérifier les valeurs de host, username et password dans votre configuration et vous assurer qu'elles correspondent aux informations fournies par l'administrateur du serveur MySQL."


    j'ai essayé pas mal de choses sans résultat
    quelqu'un aurait une idée pour pouvoir faire mes tests en local

    je suis sous windows 7 64 bits c'est important car xampp ne tourne pas correctement non plus

    merci de votre aide
    jpp

  • #2
    Apparemment une des grandes joies de easyphp, c'est de jouer avec le mot de passe mysql : une version exige un mot de passe, la suivante n'en veut pas, et ça semble changer selon les versions et la pression atmosphérique. Donc essaie avec et sans mot de passe.

    Commentaire


    • #3
      je suis sous windows 7 64 bits c'est important car xampp ne tourne pas correctement non plus
      Mais Wampeserver si et ne pose pas ce genre de problème. Ce forum grouille de sujet sur les problèmes sur Easyphp et consort.

      A+

      Commentaire


      • #4
        merci

        merci de vos reposes si rapides, j'ai réussi du premier coup a faire tourner mon serveur et à installer joomla grâce à wamp

        encore merci

        Commentaire


        • #5
          Bonjour, j'ai le même pb que jpp_aix. Mais la solution qui lui a été proposée ne me convient pas.

          J'ai un ordi neuf qui tourne sous windows 7 (64 bits).
          Je veux gérer mon site distant depuis ce nouvel ordi.

          Je vais faire du neuf en repartant de zéro après avoir jeté tout ce qui est vieux
          (autrement dit mon site en joomla 1.5.14 bâti sur mon ordi ancien
          qui tourne sous windows 98 et qui était équipé d'une ancienne version d'Easy PHP qui marchait bien).

          Donc, j'installe Easy PHP 5.3.3 sur mon nouvel ordi.
          Dans le répertoire www, je crée un sous-répertoire avec un nom qui me plaît.
          J'y place joomla 1.5.21 dézippé.

          Je me connecte à EasyPHP, la procédure d'installation de joommla commence bien, mais la phase "base de données" aboutit TOUJOURS à un écran blanc.

          Peut-être qu'il fallait créer un nom de base de données d'abord ? Je passe dans l'espace d'admin qui va bien. Ca ne marche pas mieux.
          Avec mot de passe ? Sans mot de passe ? Mot de passe = mysql ? Ou un de mon choix ? Rien ne marche. Il y a aussi ce piège du cache qui fait que le défaut a l'air de persister même quand on a modifié quelque chose.

          Bref, je décide d'essayer autre chose.

          Mov'amp n'existe plus depuis fin juillet (cf. le msg de J-Cl. Servais sur joomladraft.org) et le successeur promis n'est pas encore arrivé.

          Je n'ai pas de garantie que Xampp tourne et pour jp_aix, ça ne marche pas.

          Wamp (téléchargeable sur wampserver [pas wampeserver !]), je me demande s'il est assez récent et compatible avec windows 7 64 bits.

          Et surtout, il y a un besoin de sources fiables car McAfee me dit, quand je veux télécharger tel ou tel exécutable depuis sourceforge.net : logiciel potentiellement dangereux car présence possible de logiciels espions ou autres malveillants.
          Même chose parfois depuis 01.net. EasyPHP 5.3.3, j'en avais trouvé un sain sur clubic.com .

          Wampserver, il renvoie à sourceforge et le téléchargement de wamp, McAfee le déclare "à risques".
          Donc la solution adoptée par jp_aix., je n'en veux pas. Car je tiens à garder mon ordi neuf propre et sain longtemps.

          Quelqu'un aurait une autre solution ?


          POST-SCRIPTUM : uwamp développé par un Français et téléchargeable gratuitement depuis u..... .com (vous voyez ce que je veux dire ?) est sain et récent (mars 2010). Mais : même pb qu'avec Easy PHP 5.3.3. : page blanche au cours de la procédure d'installation de Joomla 1.5.21 en local, à l'étape "base de données".
          Dernière édition par Veit à 16/10/2010, 13h54

          Commentaire


          • #6
            Mais la solution qui lui a été proposée ne me convient pas.
            Pourquoi ?

            Donc, j'installe Easy PHP 5.3.3 sur mon nouvel ordi... J'ai un ordi neuf qui tourne sous windows 7 (64 bits).
            Erreur, car EasyPhp pose des problèmes sous cette environnement

            Wamp (téléchargeable sur wampserver [pas wampeserver !]), je me demande s'il est assez récent et compatible avec windows 7 64 bits.
            Il l'est

            McAfee me dit, quand je veux télécharger tel ou tel exécutable depuis sourceforge.net...
            Et bien continue de l'écouter sur ce genre de réactions et tu ne feras pas grand choses, tu auras sans doute besoin de Notepad++, et bien non car==>téléchargeable depuis la forge ? etc...

            Et puis Wampserver on le trouve ailleurs que sur la forge, un exemple parmi tant d'autres, n'oublies pas les moteurs de recherche ça sert, à moins que le "Dieu" McAfee parle trop.

            A+
            Dernière édition par zepelin57 à 16/10/2010, 14h21

            Commentaire


            • #7
              Bonjour,

              Et bien continue de l'écouter sur ce genre de réactions et tu ne feras pas grand choses, tu auras sans doute besoin de Notepad++, et bien non car==>téléchargeable depuis la forge ? etc...
              Bonjour,

              +1 avec zepelin

              J'ai testé tous les serveurs cités en architecture 64 bits

              Le seul qui fonctionne est wampserver (j'ai déjà essuyé les plâtres)

              Easyphp : tout le monde connait les problèmes actuels
              xampp : gère incorrectement les allocations mémoires en architecture 64B

              Cordialement,
              Joël

              Commentaire


              • #8
                Pb résolu

                Merci à Joël et à Zepelin de leur patience. Pb résolu.

                Il y a actuellement chez Clubic une version de Wampserver que McAfee ne marque pas au rouge. J'y ai installé Joomla dans un sous-répertoire à moi du répertoire www. Et la procédure d'installation s'est déroulée normalement.

                Quand j'aurai un moment, j'irai voir ce que permet U-wamp qui m'a l'air sympa.

                Mais pour le moment, je démarre avec Wampserver car je veux faire vite.

                Merci encore & bonne soirée.

                Xavier

                P.S. 1.
                Les gestionnaires de Wampserver, ils n'auraient pas intérêt à marquer compatible win 64 (en plus de compatible win 32 déjà marqué) ?

                P.S.2.
                Pourquoi la solution proposée ne me convenait pas ? La réponse à cette question était dans mon message : téléchargement depuis Sourceforge signalé potentiellement dangereux par McAfee. Pour d'autres utilitaires téléchargés ces jours-ci, j'avais trouvé d'autres sites proposant le même produit mais sans danger. Quoi de plus normal que veiller à ne pas abîmer son ordinateur neuf ?
                Dernière édition par Veit à 16/10/2010, 21h47

                Commentaire


                • #9
                  Bonsoir,

                  P.S. Les gestionnaires de Wampserver, ils n'auraient pas intérêt à marquer compatible win 64 (en plus de compatible win 32 déjà marqué) ?
                  Ce n'est pas une application win 64, mais contrairement à xampp il s'appuie correctement sur les lib32

                  Il y a actuellement chez Clubic une version de Wampserver que McAfee ne marque pas au rouge. J'y ai installé Joomla dans un sous-répertoire à moi du répertoire www. Et la procédure d'installation s'est déroulée normalement.
                  Cette fois, pour des raisons de sécurité, il est préférable de passer directement par la véritable version officiele

                  McAfee ne marque pas au rouge
                  Parce qu'il ne la connais pas. En fait, il s'agit uniquement d'une alerte qui précise qu'il ne s'agit pas d'un serveur de production

                  Cordialement,
                  Joël

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X