Problème à la 4ème étape (BD) de l'installation de Jommla v1.5

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème à la 4ème étape (BD) de l'installation de Jommla v1.5

    Bonjour,

    Je suis en train d'installer la v1.5.22 de Joomla pour la 1ère fois.
    A la 4ème étape de l'installation (base de données), j'ai le message d'erreur suivant :

    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM CHARACTER SET `utf8`' at line 29 SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(30) NOT NULL default 'banner', `name` varchar(255) NOT NULL default '', `alias` varchar(255) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(50) default NULL, `custombannercode` text, `catid` INTEGER UNSIGNED NOT NULL DEFAULT 0, `description` TEXT NOT NULL DEFAULT '', `sticky` TINYINT(1) UNSIGNED NOT NULL DEFAULT 0, `ordering` INTEGER NOT NULL DEFAULT 0, `publish_up` datetime NOT NULL default '0000-00-00 00:00:00', `publish_down` datetime NOT NULL default '0000-00-00 00:00:00', `tags` TEXT NOT NULL DEFAULT '', `params` TEXT NOT NULL DEFAULT '', PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`), INDEX `idx_banner_catid`(`catid`) ) TYPE=MyISAM CHARACTER SET `utf8`

    Même en retirant "CHARACTER SET `utf8`" dans le script "joomla.sql", même problème !

    Quelqu'un pourrait m'aider SVP ?
    Merci par avance
    Dernière édition par amohcine à 26/12/2010, 14h29

  • #2
    Re : Problème à la 4ème étape (BD) de l'installation de Jommla v1.5

    Après avoir bien galérer là-dessus, j'ai finalement pu trouver la solution de mon problème !

    Il fallait tout simplement remplacer l'expression "TYPE=MyISAM" par "ENGINE=MyISAM" partout dans les deux scripts "joomla.sql" et "joomla_backward.sql" !

    Je poste la solution au cas où quelqu'un rencontre le même problème.

    Commentaire


    • #3
      Re : Problème à la 4ème étape (BD) de l'installation de Jommla v1.5

      Merci de passer ton post en [Réglé]

      http://forum.joomla.fr/announcement.php?f=125

      Commentaire


      • #4
        Re : Problème à la 4ème étape (BD) de l'installation de Jommla v1.5

        Bonjour,

        J'ai la même erreur:

        You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM CHARACTER SET `utf8`' at line 29 SQL=CREATE TABLE `tab_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(30) NOT NULL default 'banner', `name` varchar(255) NOT NULL default '', `alias` varchar(255) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(50) default NULL, `custombannercode` text, `catid` INTEGER UNSIGNED NOT NULL DEFAULT 0, `description` TEXT NOT NULL DEFAULT '', `sticky` TINYINT(1) UNSIGNED NOT NULL DEFAULT 0, `ordering` INTEGER NOT NULL DEFAULT 0, `publish_up` datetime NOT NULL default '0000-00-00 00:00:00', `publish_down` datetime NOT NULL default '0000-00-00 00:00:00', `tags` TEXT NOT NULL DEFAULT '', `params` TEXT NOT NULL DEFAULT '', PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`), INDEX `idx_banner_catid`(`catid`) ) TYPE=MyISAM CHARACTER SET `utf8`


        Je suis plus que débutante, je n'y connais rien. Pourriez-vous me dire où il faut aller exactement cliquer et quoi faire? Merci beaucoup d'avance.

        Salutations
        Mel

        Commentaire


        • #5
          Re : Problème à la 4ème étape (BD) de l'installation de Jommla v1.5

          Envoyé par amohcine Voir le message
          Après avoir bien galérer là-dessus, j'ai finalement pu trouver la solution de mon problème !

          Il fallait tout simplement remplacer l'expression "TYPE=MyISAM" par "ENGINE=MyISAM" partout dans les deux scripts "joomla.sql" et "joomla_backward.sql" !

          Je poste la solution au cas où quelqu'un rencontre le même problème.
          Bonjour,

          J'ai exactement le même problème.

          Concrètement et précisément, quelle est la procédure à suivre pour "remplacer l'expression "TYPE=MyISAM" par "ENGINE=MyISAM" partout dans les deux scripts "joomla.sql" et "joomla_backward.sql" ?

          Merci.

          Commentaire


          • #6
            Re : Problème à la 4ème étape (BD) de l'installation de Jommla v1.5

            Bonjour,
            la solution du remplacement est une demi solution. L'erreur est provoquée par une version trop récente (5.5) de MySQL. LE remplacement traitera le cas de l'installation de Joomla, mais pas le problème risque de se poser à nouveau à chauqe installation de composant.
            Il vaut mieux opter pour un MySQL plus conciliant (5.1)
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire


            • #7
              Re : Problème à la 4ème étape (BD) de l'installation de Jommla v1.5

              Les grands esprits se rencontrent. C'est justement ce que je viens de faire après une première analyse d'une solution trop pointue à mon gout proposée ici (en anglais)

              http://briask.com/blog/2011/01/25/jo...torage-engine/

              Merci d'avoir confirmé mon intuition ! Donc pour ceux qui rencontrent le même problème, comme indiqué par Grand Schtroumpf, il suffit de rajouter une version antérieure de MySQL (5.1.x), en procédant comme suit (ne pas supprimer Wampserver):
              1. Avec le bouton gauche de la souris, cliquer sur l'icone wampserver située en bas a droite de l'écran.
              2. Dans le menu qui apparaît, pointer sur MySQL, sur Version, puis cliquer sur Get More.... Cette opération ouvre la page Web du site Wampserver, à partir de laquelle vous allez pouvoir télécharger le module Wampserver pour MySQL 5.1.

              3. Dans cette page, cliquer sur MySQL 5.1.36 (c'est le module que j'ai choisi en ce qui me concerne), puis enregistrer le fichier dans un répertoire de votre disque dur (par exemple, dans le dossier ou vous aviez initialement installé le programme d'installation Wampserver, histoire de les mettre ensemble).

              4. Accéder à ce dossier, puis double-cliquer sur le fichier du module (WampServer2-MYSQL5136.exe).

              Après je ne me souviens plus si Wampserver redémarre tout seul ou pas , mais je pars du principe que vous savez comment faire.

              Donc, dans Wampserver, il ne reste plus qu'à choisir la version 5.1.36 : pointer sur MySQL, sur Version, puis cliquer sur 5.1.36.

              Et voilà!

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X