Passage 1.5.21 à 1.5.25 perte des sous-menus

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Passage 1.5.21 à 1.5.25 perte des sous-menus

    Bonjour,
    Suite à un passage de mon site de la version 1.5.21 à 1.5.25, j'ai des problèmes avec l'affichage des sous-menus.
    Plus aucun d'entre eux ne s'affichent. J'ai vérifié qu'ils étaient bien publiés, avec le bon menu parent. Qu'ils soient public ou enregistré ne change rien.
    Quelqu'un aurait-il une piste car je ne vois même pas où regarder?
    merci

    site:www.cgtnantesmetropole.fr
    Jooma 1.5.25
    PHP 5.2.17
    Hébergeur:OVH
    Le pb est indépendant des navigateurs

  • #2
    Re : Passage 1.5.21 à 1.5.25 perte des sous-menus

    Bonjour,
    Je ne sais pas si c'est ça mais va dans gestion des modules, trouve celui qui correspond à ton menu, ouvre le et à droite dans paramétrés, tu as "style de menu en liste" et en dessous "toujours afficher les sous menus" il doit être sur oui.
    Le bonheur pour une abeille ou un dauphin est d'exister, pour l'homme, de le savoir et de s'en émerveiller. (J-Y COUSTEAU) A méditer!

    Commentaire


    • #3
      Re : Passage 1.5.21 à 1.5.25 perte des sous-menus

      Merci, mais cela ne correspond pas à ce que je souhaite.
      Si je mets cette option à "oui", mes sous-menu s'affichent en permanence, or ce n'est pas comme cela que cela fonctionnait:
      J'avais:

      eltmenu1
      eltmenu2
      eltmenu3

      Et quans je clique sur eltmenu1 , j'avais alors:
      eltmenu1
      eltmenu11
      eltmenu12
      eltmenu2
      eltmenu3

      Et ce sont les 2 sous-elément de menu qui ne s'affichent plus.

      Commentaire


      • #4
        Re : Passage 1.5.21 à 1.5.25 perte des sous-menus

        En regardant avec Firebug, je m'aperçois que la gestion de "id=current" n'a pas l'air bonne.
        Quand je clique sur eltmenu2, c'est toujours l'eltmenu1 qui est current, donc logiquement le s2 sous-menu n'apparaissent pas .

        bizarre, bizarre...

        Je viens de remettre ma sauvegarde de la 1.5.21 et tout remarche. Donc pour l'instant je ne cherche pas plus loin vu que je suis en train de tester la 1.8 (ou la 2.5 si j'ai bien compris) et que je compte faire une grosse bascule dans les mois qui viennent.
        Dernière édition par ti44 à 06/01/2012, 17h06

        Commentaire


        • #5
          Re : Passage 1.5.21 à 1.5.25 perte des sous-menus

          Il faut continuer à paramétrer le menu.
          Il faut aller (au même endroit) dans autres paramètres et cocher la case non sur développer le menu.
          Et normalement cela devrait fonctionner.

          Autrement faire une copie écran de paramètres module et autres paramètres pour y voir plus claire
          Le bonheur pour une abeille ou un dauphin est d'exister, pour l'homme, de le savoir et de s'en émerveiller. (J-Y COUSTEAU) A méditer!

          Commentaire


          • #6
            Re : Passage 1.5.21 à 1.5.25 perte des sous-menus

            En fin de compte j'ai refait le transfert des fichiers pour la mise à jour de la 1.5.21 vers la 1.5.25
            Et je n'ai plus le problème, un fichier a du manquer dans le transfert.
            J'ai testé le paramètre "développer le menu" mais il n'a pas l'air d'avoir d'effet sur le menu. je l'avais déjà remarqué précédemment, c'est peut-être lié au template utilisé.

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins
            Travaille ...
            X