Problème de restauration en localhost d'un site distant

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème de restauration en localhost d'un site distant

    Bonjour

    Suite à un crash de mon PC, j'ai dû le changer et j'en ai profité pour passer à Windows 8.1 (j'étais encore sous xp sp3). En vu d'une mise à jour de mon site distant, j'ai utilisé quickstart pour copier mon site distant en localhost. Les fichiers sont bien passés, mais pas la base de données. J'ai alors fait une exportation/importation de la dite BD, et après quelques réglages, au lancement du site en localhost, j'obtiens un tas de trucs incompréhensible pour moi, que je mets en pièce jointe.

    Merci de m'orienter vers une solution.
    Fichiers joints

  • #2
    Re : Problème de restauration en localhost d'un site distant

    Bonjour,

    Tellement fréquent sous Windows qu'il y a une FAQ http://allevents.avonture.be/fr/error-reporting.html
    Pas de demande de support par MP.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

    Commentaire


    • #3
      Re : Problème de restauration en localhost d'un site distant

      Effectivement je n'ai plus ces messages après modification de la variable $error_reporting de configuration.php.

      Par contre, j'ai maintenant une erreur 500 et impossibilité d'accéder à phpmyadmin. Je pars à la chasse aux renseignements et cela fera éventuellement l'objet d'un post différent.

      Merci.
      Dernière édition par Kyos à 10/02/2014, 16h13

      Commentaire


      • #4
        Re : Problème de restauration en localhost d'un site distant

        Bonjour

        J'éprouve les plus grandes difficultés à re-installer en local Joomla 1.5.22. Après plusieurs jours de galère, et aidé par Otomatic (WampDerveur), je ne suis arrivé à aucun résultat. Finalement, je me demande, peut-être un peu tard, si les versions des composants wamp sont compatibles avec cette version de Joomla, et même si cette version de Joomla est compatible avec Win 8.1.

        J'utilise la version 2.4 32 bits de Wampserver, avec Apache 2.4.4, PHP 5.4.16, MySQL 5.6.12 et phpMyAdmin 4.0.4.

        Merci de m'indiquer si tout cela colle, ou éventuellement ce qu'il faudrait.

        PS: je sais qu'il me faut migrer vers Joomla2.5.x et c'est pour ce faire que je dois rapatrier une version de mon site en1.5.22 en localhost

        Commentaire


        • #5
          Re : Problème de restauration en localhost d'un site distant

          Joomla!, à plus forte raison une version 1.5 qui n'est même pas à sa dernière mouture 1.5.26 n'est PAS compatible PHP 5.4 http://docs.joomla.org/Joomla_1.5_won't_work_on_PHP_5.4

          Pour pouvoir l'installer localement, il te faut une pile windows avec un ancien PHP 5.3, par exemple wampserver 2.2e qui lui a un ancien PHP 5.3 http://www.wampserver.com/
          Pas de demande de support par MP.
          S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

          Commentaire


          • #6
            Re : Problème de restauration en localhost d'un site distant

            Bonjour

            Effectivement, la version WampServer 2.2.E fonctionne mieux, presque bien. Restent cependant deux problèmes:

            1°/Il me faut utiliser 1.0.0.1 et non local host pour mes adresses en local.

            2°/ L'installation de Joomla affiche une erreur à la phase 4. C'est semble-t-il un problème de type de fichier et il faudrait déclarer ENGINE=ISAM et non TYPE=ISAM. Mais je n'ai pas trouvé où, sinon que ce serait dans my.ini.
            Une autre solution serait de charger dans WampServer un addon de MYSQL 5.1.36 por Wamp? Qu'en penses-tu?

            Bref tout cela devient bien obscur.

            Merci.

            PS: il semblerai que pour le pb 2, la solution addon soit la bonne. Je l'ai téléchargé et je passe la phase 4.
            Dernière édition par Kyos à 20/02/2014, 09h29

            Commentaire


            • #7
              Re : Problème de restauration en localhost d'un site distant

              Bonjour,

              Et pourquoi pas plus simplement utiliser server2GO qui marche bien, sans aucun paramétrage particulier sous Windows 8.1

              Je n'utilise pas WampServer 2.2 (ni 2.4), mais j'essaie depuis quelques temps de nombreuses possibilités locales sous WIndows 7, Windows 8 et même Vista.

              Pour Windows 8 (et 8.1), il faut clairement paramétrer et configurer le pare-feu. Il faut également installer et (la plupart du temps avec toutes les piles AMP) démarrer le serveur en mode administrateur.
              Suivant ce qui est installé sur ton PC, il faut (assez souvent) reconfigurer le port , certains process Windows l'utilisant dès le démarrage.

              Quand à remplacer 127.0.0.1 par localhost (mais on peut s'en passer), il suffit de rajouter une ligne dans le fichier host pour que cela fonctionne correctement.

              Dès que j'aurai un peu de temps (??) j'essaierai d'écrire un tuto comparatif des différentes piles AMP sous PC et de leurs subtilités de paramétrage
              Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X