impossible de modifier la configuration générale

Réduire
Ce sujet est fermé.
X
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • impossible de modifier la configuration générale

    Bonjour,

    Je viens de débuter un site en joomla 1.5 et je débute en conception de sites web et j'ai découvert Joomla, il y a peu... C'est dire l'insondable profondeur de ma méconnaissance !

    J'aimerais modifier la configuration générale. Malheureusement le lien "appliquer" et "sauver" me renvoie vers :
    " la page que vous recherchez n'existe pas sur ce site, vous avez été donc redirigé vers notre site d'hébergement HOSTEUR.COM. "

    J'ai pourtant modifié les attributs du fichier configuration.php en 777. J'ai certainement du oublier quelque chose...

    Merci de votre aide.

  • #2
    Bonjour,
    Est-ce que vous avez installé le site directement depuis le serveur, ou fait un upload depuis une config locale ?

    Commentaire


    • #3
      Directement depuis le serveur.
      J'ai copié le fichier configuration proposé dans un fichier configuration.txt que j'ai uploader sur le serveur. J'ai ensuite modifié l'extension en .php

      Commentaire


      • #4
        Lors de l'installation, un fichier de configuration a été généré par joomla, vous l'avez donc sans doute écrasé avec le nouveau.
        Il faut que vous éditiez configuration.php en local et que vous l'uploadiez à nouveau
        Mettre à jour en particulier :
        $mosConfig_absolute_path = 'chemin/serveur/vers/repertoire/joomla';
        $mosConfig_cachepath = 'chemin/serveur/vers/repertoire/joomla/cache';
        $mosConfig_live_site = 'http://www.mondomaine.com';
        $mosConfig_db = 'nom_database';
        $mosConfig_user = 'user_database';
        $mosConfig_password = 'password_database';

        Commentaire


        • #5
          Ces lignes ne figurent pas du tout dans mon fichier configuration.php

          Dois-je les ajouter ? si oui, début ou fin de fichier ou dans une section particulière ?
          J'ai bien compris que je devais les modifier avec mes paramètres.

          Désolé si mes questions sont basiques ...

          Commentaire


          • #6
            Je me permet de faire un UP de cette question.
            Au besoin, je peux envoyer mon fichier configuration.php par MP à la personne qui aura la gentillesse de bien vouloir m'aider à progresser.

            D'avance merci.

            Commentaire


            • #7
              moodsign > Les lignes que lu montre sont celles de la version 1.0.x
              Esberoth > A la racine de ton site existe un fichier configuration.php-dist . C'est un modèle de fichier de configuration. Après modification des paramètres, tu enlève le -dist.

              Commentaire


              • #8
                Bonjour,

                Je pense que ça ressemble beaucoup à mon problème :

                http://forum.joomla.fr/showthread.php?t=54618

                On est chez hosteur tout les deux.

                Si tu as des infos, ça m'intéresse !

                Thierry

                Commentaire


                • #9
                  Envoyé par joomler Voir le message
                  Esberoth > A la racine de ton site existe un fichier configuration.php-dist . C'est un modèle de fichier de configuration. Après modification des paramètres, tu enlève le -dist.
                  Cela n'a pas réglé le problème ! Que puis-je essayer ?

                  Commentaire


                  • #10
                    Esberoth , tbar403, mivory > Avez-vous pensé à vérifier dans le menu Aide > Infos système > 5 onglets que tout est OK ?

                    Commentaire


                    • #11
                      Autant que je puisse en juger tout semble en ordre.
                      Les permissions des dossiers sont toutes au vert... pour le reste, c'est plus difficile à dire mais rien ne me parait suspect...

                      Je ne suis pas contre de donner l'accès par MP pour que quelqu'un de plus compétent que moi y jette un oeil...

                      Merci d'avance.

                      Commentaire


                      • #12
                        J'ai le même souci...

                        Je vais dans \Site\Configuration Globale\Serveur pour y changer le fuseau horaire qui est par défaut sur Londres et quand je clique sur le bouton Sauver j'ai le droit à une belle page

                        Forbidden
                        You don't have permission to access /test/administrator/index.php on this server.

                        Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
                        Apache/1.3.37 Server at www.tourville-en-ligne.net Port 80
                        J'ai vérifié comme toi que toutes les permissions étaient au vert (voir les photos ci-joint) et c'est le cas mais rien à faire ! D'ailleurs sur la dernière photo (infosys3.jpg) est il normal que des xxxxxxxx apparaissent en lieu et place des infos réelles dans la section "Database configuration section" de l'onglet fichier de configuration ?

                        Autre souci constaté. Je viens d'installer un template commercial certifié compatible Joomla 1.5 et quand je le sélectionne par défaut j'ai le droit à une belle page en frontend

                        Direct Access to this location is not allowed.
                        Quid ????

                        Je précise au passage que je suis hébergé chez mavenhosting.com

                        Par avance merci de votre aide
                        Fichiers joints
                        Silverscott
                        Hors Zone - Made in Rock!
                        http://www.horszone.net

                        Commentaire


                        • #13
                          Un petit Up car j'ai le même soucis.
                          Je suis chez hosteur, installation sans problème, permission au vert et page 404 dès que je veux modifier la config global !!
                          Aucun Log d'erreur sur le serveur (pas normal les 404 sont d'habitude inscrits)
                          Aucun Log d'erreur dans Joomla

                          Je nage

                          Commentaire


                          • #14
                            Bon je vais appliquer le patch pour basculer en v1.51 et voir ce que ça donne...
                            Silverscott
                            Hors Zone - Made in Rock!
                            http://www.horszone.net

                            Commentaire


                            • #15
                              Ben, je suis content de pas être tout seul a avoir le problème...

                              En attendant, ce n'est toujours pas résolu.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X