Joomladay francophone 2018 à Paris 18 et 19 mai

liens internes qui ne fonctionnent pas sur joomla distant

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • liens internes qui ne fonctionnent pas sur joomla distant

    Bonjour,
    Après avoir paramétré mon site local je suis passé à une installation distante. Et là il se passe des choses étranges sur les liens internes : une fois que j'ai créé mes sections, catégories, articles, je rajoute un menu pour afficher par exmple une catégorie (lien interne > category layout), lorsque je test j'ai bien mes articles mais dès que je clique sur un article j'ai une erreur 404. Ce qui est bizarre c'est l'URL qui est censée m'emmener à ces articles : au lieu d'avoir quelque chose du genre : (comme c'est le cas en local)
    index.php?view=article&catid=1:alias-categorie&id=1:alias-article&option=com_content&itemid=8
    j'ai sur le distant un lien qui ressemble à ça :
    alias-categorie&id=3:alias-article?option=com_content&view=category&id=1&item id=8

    donc la mention au fichier index.php a tout simplement disparu et le point d'interrogation qui sert à passer les variables est pas du tout placé au bon endroit
    Je me dis que le problème vient soit de la configuration de joomla (pourtant meme manip qu'en local, et j'ai la version 1.5.1), soit de mon hébergeur ?
    Si quelqu'un voit d'ou celà pourrait venir là je sèche ...

    *EDIT* mon site est hébergé chez ovh, la page d'accueil s'affiche correctement, seuls les liens internes ne semblent pas fonctionner normalement
    Dernière édition par mark_vador à 19/02/2008, 11h09

  • #2
    Bonjour,

    je suis désolé, je ne vais pas pouvoir t'aider, car j'ai un problème similaire chez mon hébergeur claranet. Les liens dans les articles, et les liens associés aux rubriques "Latest News" et "Most Popular" (entre autres) ne fonctionnent pas.

    J'ai tenté d'activer l'url_rewriting, en modifiant plusieurs fois mon htaccess, mais rien n'y fait. J'essaie actuellement de contacter la hotline claranet.

    Si quelqu'un a une idée...

    Commentaire


    • #3
      Hum, c'est évidemment au moment que je poste que je reçois la réponse de claranet :

      Par contre, Joomla n'est pas compatible avec nos serveurs. Cela est dû essentiellement à certaines variables PHP utilisées par joomla et que nous ne mettons pas à disposition sur nos serveurs mutualisés, pour des raisons de sécurité.
      Voilà qui est réglé dans mon cas. Je sais que ce n'est pas le cas chez ovh en revanche.

      Voilà, désolé d'avoir floodé ton post, j'espérais trouver une solution pour nous deux...

      Commentaire


      • #4
        J'ai eu aussi des erreurs 404 dues au rewritting d'url

        il existe un outil de rewritting des url dans joomla 1.5, alors qu'avant, c'était un composant en plus ...

        J'ai essayé d'activer cette fonction ... ça plante ...

        Quelques minutes après : j'ai désactivé le rewritting d'url
        menus Site - Configuration générale - site - paramètres SEO : tous les paramètres à non

        Et cela marche !

        le rewritting a encore frappé

        la configuration PHP de mon hébergeur n'est pas bonne !
        Dernière édition par didier l à 24/02/2008, 11h44
        Didier L
        Le webmaster de quelques sites associatifs développés sur Joomla !

        Commentaire


        • #5
          Exactement le meme probleme
          voici l'exemple
          nomdedomaine.com/welcome-to-joomla&catid=1:latest-news&Itemid=50
          pour l'artilce en page d'accueil
          mais que ce passe t_il ????
          Merci à vous
          Si quelqu'un a une idée...

          Commentaire


          • #6
            J'ai le même problème sur un serveur local (Mandriva 2006) alors que cela fonctionne très bien sur une autre machine (Debian etch).
            Par contre la machine qui ne fonctionne pas n'a pas de problème avec l'ancienne version de Jommla! (1.0.15).
            J'y perds mon latin ...

            Le 28 mars 2008, j'édite ce message pour le faire remonter dans la pile. Je n'ai toujours pas résolu mon problème.
            Dernière édition par Franbour à 28/03/2008, 16h47

            Commentaire


            • #7
              Un petit message pour faire remonter le topic en bonne position car je n'ai toujours pas trouvé la solution.
              Merci de votre aide.

              Commentaire


              • #8
                La solution est peut-être en regardant ici

                Alvaro
                Jardiner, c'est respirer!

                Commentaire


                • #9
                  J'ai essayé la manip dans le fichier .htacess mais sans résultat pour l'instant. Merci pour l'aide.

                  Commentaire


                  • #10
                    bonjour

                    quelqu un est il venu à bout de ce problème?

                    o

                    Commentaire


                    • #11
                      Bonjour,

                      J'ai le meme pb.
                      Avez-vous trouver la solution?

                      Merci.

                      Jiku

                      Commentaire


                      • #12
                        Non, pas avec Mandriva.

                        Commentaire


                        • #13
                          Ca me casse la tête la cette affaire là.

                          Les liens de mes menus fonctionnent très bien, tandis que les liens de mes articles, c'est du n'importe quoi...

                          Jilu
                          http://www.mapemploiquebec.com

                          Commentaire


                          • #14
                            Nous avons exactement le même problème avec Joomla 1.5.4 en distant et la manip du .htaccess ne fonctionne pas...

                            D'autres auraient-ils trouvé?

                            Commentaire


                            • #15
                              Le problème venait du serveur (problème de php apparement...)

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X