etre son propre hebergeur joomla

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • etre son propre hebergeur joomla

    Bon, voila, je galere et je trouve pas!
    J'ai installé joomla 1.5.6 sur une machine à la maison, afin de developper mon site. Pour ce faire j'ai installé Xamplite et tout le toutim.
    Ca roule parfait.
    Bon le site est fini, et je veux le faire tourner sur Internet SUR MA PROPRE BECANE et non pas chez un hebergeur.Bien evidement, j'ai une adresse IP fixe, et tout est parfaitement configuré sur mon routeur.
    que dois-je faire au niveau de xamplite, ou de myphpadmin ???
    D'avance merci pour votre aide
    Dernière édition par zeev à 07/09/2008, 10h26

  • #2
    Ton routeur a une adresse IP Fix fournit par ton provider, pas le PC !!

    Tu as bien fait la route sur ton routeur port 80 = IP de ta machine dans le réseau interne ?
    Quel est l'adresse IP de ton PC en local ? est-elle fixe ou DHCP ? Dans le cas DHCP, recevra-t-elle toujours la même ?

    J'imagine que c'est une machine Windows ? a-t-elle un firewall ? est-il ouvert ?
    Règlement du forum : http://forum.joomla.fr/faq.php
    Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
    Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
    http://www.iwannaclick.org

    Commentaire


    • #3
      sharky a écrit:
      Ton routeur a une adresse IP Fix fournit par ton provider, pas le PC !!

      Tu as bien fait la route sur ton routeur port 80 = IP de ta machine dans le réseau interne ?
      Quel est l'adresse IP de ton PC en local ? est-elle fixe ou DHCP ? Dans le cas DHCP, recevra-t-elle toujours la même ?

      J'imagine que c'est une machine Windows ? a-t-elle un firewall ? est-il ouvert ?

      Argh, j'ai bien ecrit que j'avais parfaitement configuré mon routeur, et c'est une machine windows. Je ping parfaitement www.mondomaine.com
      Pas de firewall pour l'instant avant de mettre en ligne le site.
      Je reformule la question: quels sont les fichiers et les programmes que je dois modifier sachant que j'utilise xamplite (est-ce approprié pour un serveur web ?) afin que le site pointe vers l'adresse IP de ma machine qui est 192.168.0.102
      Cette adresse est en dmz sur mon routeur qui lui, a une adresse publique.
      Merci de vos réponses
      zeev

      Commentaire


      • #4
        oui tu l'as dis mais est-ce que ça impliquait vraiment tout ?? ça manque de détails et faut croire que non si ça ne fonctionne pas

        Détails ce que tu as fait pour que l'on puisse t'aider

        tu testes depuis où ? un autre PC dans le même réseau ??
        Comment tu testes http://tondomaine.com ou http://adresseIP? c'est un domaine complet ? ou no-ip/dyndns ?

        En utilisant l'adresse IP du provider est-ce que ça fonctionne ?
        En utilisant l'adresse local est-ce que ça fonctionne ?
        Quand tu ping c'est quel adresse IP en retour ?
        Quand/comment ça ne fonctionne pas ???

        En te posant toutes ces questions, je cherche l'erreur, des réponses seraient bien venu

        Xamp est un bon choix pour un serveur WEB, je préfèrerai sous OS linux
        Dernière édition par sharky à 30/08/2008, 19h07
        Règlement du forum : http://forum.joomla.fr/faq.php
        Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
        Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
        http://www.iwannaclick.org

        Commentaire


        • #5
          Comme je ne connais pas ton domaine, sur la machine avec laquelle tu testes, edites ton fhichier host qui ce trouve %windir%\System32\drivers\etc et ajoute une ligne

          192.168.0.102 mondomaine.com

          et teste encore une fois
          Règlement du forum : http://forum.joomla.fr/faq.php
          Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
          Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
          http://www.iwannaclick.org

          Commentaire


          • #6
            Bonjour sharki

            Je vais essayer d'etre le plus clair possible. ( Je suis pourtant Ingé reseau)
            1: J'ai une freebox V5 en mode routeur, et une adresse IP fixe
            Dans le routeur j'ai mis en dmz l'ip de la machine locale sur laquelle tourne
            actuellement Joomla grace a Xamplite, mysql apache et phpmyadmin
            Joomla tourne impec si je lance http://localhost/monsite
            OK ?
            Mon nom de domaine deposé chez un registrar a un dns correct et je peux pinger
            www.mondomaine.com.
            Le Cname est correct sur le port 80
            Toutes les configs de Xamplite, pointent vers localhost n'est-ce pas ?
            Je veux donc connaitre les fichiers exemple :apache et mysql pour que
            je puisse lancer mon site a partir d'une adresse publique. et le rendre donc visible a tous

            Zeev

            Commentaire


            • #7
              Rien a faire ... si ça marche localhost et que le réseau est bien configuré ça devrait fonctionner ...

              Tu peux rajouter, mais ça ne devrait rien changer, dans la config d'apache httpd.conf (environ ligne 170) ServerName
              Règlement du forum : http://forum.joomla.fr/faq.php
              Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
              Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
              http://www.iwannaclick.org

              Commentaire


              • #8
                heberger son serveur web

                Ca marche en localhost, ca ne marche pas depuis l'exterieur.
                Je deviens fou, parce que je fais ca "finger in the noze"
                avec IIS
                Avec Apache que je ne maitrise pas, c'est l'usine a gaz.
                Je suis sous vista, mon fichier host pointe bien sur 192.168.0.102 mondomaine.com
                Mon adresse Ip publique (free) est sur un dns qui marche bien et tous les zonechecks sont ok
                Dans la freebox, j'ai mis en dmz l'adresse ip interne sur laquelle je fais tourner le serveur apache.
                Pas d'antivirus ni de firewall (tous desactivés pour les test)
                J'ai essayé xamp, wamp, mov'amp rien a faire
                J'ai meme desactiver l'acces a joomla et mis une seule page web index.html dans le repertoire www, qui dit "bienvenue"
                J'ai tripoté le fichier http.conf dans tous les sens rien n'y fait.
                Donc je dois zapper un truc tout simple non ?
                Je demande aux ames charitables de me donner une config archi basic pour mon httpd.conf, y a t'il aussi qq chose a changer dans d'autres prog tels que mysql ou que sais-je ?

                Merci a tous par avance
                Zeev

                Commentaire


                • #9
                  les ports

                  c'est clairement un probleme réseau. J ai bien compris que le serveur est en DMZ mais redirige quand meme les ports (au moins le 80) sur ton routeur vers ton serveur comme le suggere sharky

                  Commentaire


                  • #10
                    +1
                    Je maintient qu'il manque la route sur le routeur

                    Toutes requêtes sur le port 80 provenant du PUBLIC doivent être redirigées sur ta machine hôte du serveur WEB, en y indiquant son adresse IP, même avec une DMZ.
                    Dernière édition par sharky à 04/09/2008, 06h13
                    Règlement du forum : http://forum.joomla.fr/faq.php
                    Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                    Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                    http://www.iwannaclick.org

                    Commentaire


                    • #11
                      j'ai enleve le dmz et remis ma machine en nat traditionnel avec ouverture
                      des ports 80 vers 192.168.0.102

                      Ca change rien !
                      En fait, je n'ai aucun souci pour taper depuis l'exterieur: ping www.mondomaine.com
                      ou ping mamachine.domaine.com
                      Ca répond nickel avec l'adresse IP correspondante .
                      Chez mon registrar j'ai un dns correct, voila le fichier zone tout simple:

                      @ A 82.241.XX.XX
                      mamachine A 82.241.XX.XX
                      www A 82.241.XX.XX
                      je crois supposer que le loopback avec le routeur free ne se fait pas bien

                      Cordialement

                      Commentaire


                      • #12
                        freebox

                        bah
                        en nat simple si tu redirige le port 80 t'auras des problemes en local (sauf si tu n'as que le serveur http derriere la free box) à moins de rajoutter un routeur derriere qui prenne la redirection en charge sur un sous réseau

                        et DMZ + redirection as tu enfin essayé ?

                        et reboutes tu la freebox apres les changements de config ?

                        Commentaire


                        • #13
                          Quand tu ping en fait tu tombe sur ta freebox

                          C'est pas un routeur la freebox ?? désolé en suisse on en pas donc ne connais pas !!
                          Règlement du forum : http://forum.joomla.fr/faq.php
                          Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                          Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                          http://www.iwannaclick.org

                          Commentaire


                          • #14
                            Youpi Ca marche.
                            Apres avoir passé des heures et des heures a modifier des configs dans tous les sens, je suis retourné voir ma config routeur freebox
                            Et là ... horreur, y avait une ligne qui natait une autre machine (qui n'existe plus) sur le port 80

                            Merci à tous pour votre aide,
                            Cordialement

                            Commentaire


                            • #15
                              Gg

                              content que cela fonctionne.
                              En meme temps sharky te le dis depuis le début qu'il y a un souci de routage

                              merci de passer le sujet en Réglé

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X