MAJ sécurité 1.5.7 - FAQ

Réduire
Ceci est un sujet important.
X
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • MAJ sécurité 1.5.7 - FAQ

    Conseils pour un bon fonctionnement:

    1. Composant page d'acceuil
    Dans la 1.5.7, un nouveau paramètre est présent pour l'élément de menu Page d'acceuil en format Blog lors de l'utilisation de plusieurs colonnes.
    Tri selon plusieurs colonnes
    Lors de la Mise à jour, la valeur par défaut est "Bas" au lieu de "Entre" (sous entendu: colonnes).
    Il suffit d'éditer ce menu et de le sauvegarder pour que l'affichage revienne à votre affichage précédent.

    2. Si vous utilisez php4, cette erreur se produira lors d'édition d'un article dans l'interface site:
    Fatal error: Call to undefined function: stripos()
    L'article est néanmoins sauvegardé correctement.
    Utilisez la solution proposée ici:
    http://aide.joomla.fr/Administration...en-fron-4.html
    sinon faq anglophone
    http://docs.joomla.org/Why_do_you_ge...using_PHP_4%3F

    Ajouter ce code à la fin du fichier
    /libraries/joomla/utilities/compat/php50x.php
    Code:
    if(!function_exists('stripos')) {
     function stripos($haystack, $needle, $offset = 0) {
      return strpos(strtolower($haystack), strtolower($needle), $offset);
     }
    }

    Cette modification résoud des problèmes de login sous php4.
    Dernière édition par infograf768 à 30/09/2008, 08h04
    Jean-Marie Simonet / infograf768
    Joomla co-fondateur. Joomla Production Working Group.
    Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

  • #2
    Bonjour, j'ai un soucis après mise à jour en 1.5.7(depuis la 1.5.6)

    Je n'ai plus de contenu en fronted (http://www.valoris-tiqss.eu/jsite/) et en backend j'ai la page de connexion mais une fois connecté il m'apparait "Restricted access" et je ne peux rien faire.

    Je ne pense pas que le problème vienne de php car j'ai un autre site au même endroit (http://www.valoris-tiqss.eu/site/) qui a très bien supporté la mise à jour.

    Pouvez-vous m'aider ?
    Dernière édition par Colloc à 11/09/2008, 14h26

    Commentaire


    • #3
      Pouvez-vous m'aider également

      impossible d'accèder au site après la mise à jour de 1.5.6 à 1.5.7

      Code:
      Warning: Unterminated comment starting line 55 in /home/www/client/www/lesveloselectriques_com/www/libraries/joomla/database/table.php on line 55
      
      Parse error: syntax error, unexpected $end, expecting T_FUNCTION in /home/www/client/www/lesveloselectriques_com/www/libraries/joomla/database/table.php on line 55
      http://www.lesveloselectriques.com/

      Merci d'avance

      Commentaire


      • #4
        Envoyé par Colloc Voir le message
        Bonjour, j'ai un soucis après mise à jour en 1.5.7(depuis la 1.5.6)

        Je n'ai plus de contenu en fronted (http://www.valoris-tiqss.eu/jsite/) et en backend j'ai la page de connexion mais une fois connecté il m'apparait "Restricted access" et je ne peux rien faire.

        Je ne pense pas que le problème vienne de php car j'ai un autre site au même endroit (http://www.valoris-tiqss.eu/site/) qui a très bien supporté la mise à jour.

        Pouvez-vous m'aider ?
        http://www.valoris-tiqss.eu/jsite est un site en Joomla 1.0.x ....
        Jean-Marie Simonet / infograf768
        Joomla co-fondateur. Joomla Production Working Group.
        Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

        Commentaire


        • #5
          Envoyé par megakea Voir le message
          Pouvez-vous m'aider également

          impossible d'accèder au site après la mise à jour de 1.5.6 à 1.5.7

          Code:
          Warning: Unterminated comment starting line 55 in /home/www/client/www/lesveloselectriques_com/www/libraries/joomla/database/table.php on line 55
          
          Parse error: syntax error, unexpected $end, expecting T_FUNCTION in /home/www/client/www/lesveloselectriques_com/www/libraries/joomla/database/table.php on line 55
          http://www.lesveloselectriques.com/

          Merci d'avance
          On dirait un mauvais transfert FTP.
          Jean-Marie Simonet / infograf768
          Joomla co-fondateur. Joomla Production Working Group.
          Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

          Commentaire


          • #6
            Bonjour,
            J'ai fait la mise à jour de la version 1.5.6 à 1.5.7.
            Tout s'est bien déroulé, seulement quand je vais sur le site et que j'essaie de m'identifier, il me dit ceci : Fatal error: Call to undefined method: usercontroller->isinternal() in /homepages/18/d250352615/htdocs/components/com_user/controller.php on line 120
            Qu'en est-il ? J'utilise le module d'identification Joomla de base.
            Au pire, peut être avez vous un module à me conseiller.
            Merci.

            Commentaire


            • #7
              Sans doute aussi une erreur dans le transfert ftp. Local ou chez hôte?
              Jean-Marie Simonet / infograf768
              Joomla co-fondateur. Joomla Production Working Group.
              Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

              Commentaire


              • #8
                Hello,

                Je crois qu'il y a quelques petites erreurs dans le pack Fr :

                -1-
                fr-FR.com_config.ini

                A partir de:
                TIPIFSETTOSHOWDATETIMEMODIFIED=

                Le fichier est en Anglais.
                J'ai noté également la disparition de :
                TIPFILEFOLDER=Chemin d'accès pour les média accessibles via le gestionnaire de média.

                En français et en Anglais, est ce que cette variable n'est vraiment plus utilisée ? peuy être un oubli ?

                Disparition aussi de :
                TIPIMAGEFOLDER=

                -2-
                fr-FR.com_admin.ini
                fr-FR.com_banners.ini
                fr-FR.com_banners.menu.ini
                fr-FR.com_cache.ini
                fr-FR.com_categories.ini
                fr-FR.com_checkin.ini
                fr-FR.com_contact.ini
                fr-FR.com_contactmenu.ini
                fr-FR.com_cpanels.ini
                fr-FR.com_installer.ini
                fr-FR.com_languages.ini
                fr-FR.com_login.ini
                fr-FR.com_massmail.ini
                fr-FR.com_media.ini
                fr-FR.com_menus.menu.ini
                fr-FR.com_messages.ini
                fr-FR.com_modules.ini
                fr-FR.com_newsfeeds.ini
                fr-FR.com_newsfeeds.menu.ini

                (...) un peu marre là...

                N'ont subis aucun changements, peut être n'est il pas nécessaire de les inclure dans le pack ?(on pourrait avoir dans certains cas des modifs écrasées pour rien...)

                Attention quelque uns ont bien été modifiés...

                Je continue mes petites investigations...
                Dernière édition par crony à 12/09/2008, 10h59
                Enjoy J!

                Commentaire


                • #9
                  bonsoir,
                  j'ai refait les transferts, et j'ai toujours cette erreur ... une autre piste ?

                  Commentaire


                  • #10
                    Salut,

                    Quelles versions utilises tu de php et mysql ?
                    Enjoy J!

                    Commentaire


                    • #11
                      solution

                      J'ai trouvé la réponse ici ... http://forum.joomla.fr/showthread.php?t=73974
                      Dernière édition par Hichem à 12/09/2008, 06h51
                      www.spidexweb.com

                      Commentaire


                      • #12
                        Erreur lors du log user sur le front end

                        Bonjour à tous et à toutes,
                        Je viens de mettre à jour mon site 1.5.6 vers 1.5.7 ... aucune erreur signalée lors de l'opération.

                        SAUF QUE
                        Quand j'essaie de me connecter sur le front end, voici l'erreur que j'ai :

                        Code HTML:
                        Fatal error: Call to undefined function: stripos() in /data/www/org/e/u/ycbasque.org/www/htdocs/libraries/joomla/environment/uri.php on line 675
                        quelqu'un a-t-il rencontré ce problème ???
                        Matt
                        http://www.yakamama.com, Agence de Référencement Naturel (SEO) qualifiée "Google Analytics", SPECIALISÉE Joomla
                        Sur le forum, outils gratuits pour agence web

                        Commentaire


                        • #13
                          @Crony
                          Je confirme le problème dans certains ini
                          Il semble bien que le composant que nous utilisons pour les traductions, Translation Manager, a besoin d'être adapté aux versions de J > 1.5.5

                          Désolé... Nous allons nous en occuper au plus tôt.
                          Jean-Marie Simonet / infograf768
                          Joomla co-fondateur. Joomla Production Working Group.
                          Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                          Commentaire


                          • #14
                            Envoyé par rawaruska Voir le message
                            Bonjour à tous et à toutes,
                            Je viens de mettre à jour mon site 1.5.6 vers 1.5.7 ... aucune erreur signalée lors de l'opération.

                            SAUF QUE
                            Quand j'essaie de me connecter sur le front end, voici l'erreur que j'ai :

                            Code HTML:
                            Fatal error: Call to undefined function: stripos() in /data/www/org/e/u/ycbasque.org/www/htdocs/libraries/joomla/environment/uri.php on line 675
                            quelqu'un a-t-il rencontré ce problème ???
                            Matt
                            Regardez un peu plus haut... "Faq 1.5.7" http://forum.joomla.fr/showthread.php?t=74077
                            Jean-Marie Simonet / infograf768
                            Joomla co-fondateur. Joomla Production Working Group.
                            Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                            Commentaire


                            • #15
                              Merci

                              Envoyé par infograf768 Voir le message
                              Regardez un peu plus haut... "Faq 1.5.7" http://forum.joomla.fr/showthread.php?t=74077
                              Merci beaucoup, j'ai bien appliqué le conseil sur le menu page d'accueil mais j'ai pas compris que le second point correspondait à mon problème ...
                              Merci encore.
                              Matthieu
                              http://www.yakamama.com, Agence de Référencement Naturel (SEO) qualifiée "Google Analytics", SPECIALISÉE Joomla
                              Sur le forum, outils gratuits pour agence web

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X