Xampp sur Vista et sécurité

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Xampp sur Vista et sécurité

    Bonjour,
    J'ai installé Xampp v1.7.0 sous Vista, quand je tape localhost sur mon navigateur, j'ai bien le message de bienvenue, cependant quand je clique sur Sécurité, il m'apparait ceci:

    Accès interdit!

    Vous n'avez pas le droit d'accéder à l'objet demandé. Soit celui-ci est protégé, soit il ne peut être lu par le serveur.

    Si vous pensez qu'il s'agit d'une erreur du serveur, veuillez contacter le gestionnaire du site.

    Error 403

    ...

    Est-ce que quelqu'un pourrait m'aider?

  • #2
    l'installe est une solution facile, problème c'est que le répertoire xampp ce place dans c:\program files et que celui-ci est un répertoire "système"
    Change la sécurité du répertoire ...\xampp\htdocs.
    Bouton droite desssus -> propriété puis tu vas dans l'onglet sécurité. fais en sorte que le groupe "tout le monde" a les droits d'écriture
    Règlement du forum : http://forum.joomla.fr/faq.php
    Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
    Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
    http://www.iwannaclick.org

    Commentaire


    • #3
      C'est fait! Mais j'ai toujours le même message

      Commentaire


      • #4
        Essayes en démarrant XAMPP en administrateur (clique droit sur le raccourcis)
        Règlement du forum : http://forum.joomla.fr/faq.php
        Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
        Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
        http://www.iwannaclick.org

        Commentaire


        • #5
          J'ai déjà fait ça aussi mais toujours le même résultat :-(
          J'avais déjà installé Xampp sur Win XP et tout s'était bien passé du premier coup. Cette fois-ci, Vista me semble réellement le problème. Le serveur Apache fonctionne bien mais c'est du côté de MySql que ça ne semble pas bien fonctionné.

          Commentaire


          • #6
            Chez moi c'est OK ...
            désintalles-le et utilises la version ZIPé
            Décompresse à la racine de C:\
            démarre xampp-control en administateur
            Règlement du forum : http://forum.joomla.fr/faq.php
            Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
            Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
            http://www.iwannaclick.org

            Commentaire


            • #7
              Pour désinstaller, on supprime simplement le répertoire? Ce n'est pas une vraie désinstallation...
              Et est-ce normal que même en cochant "Exécuter ce programme en tant qu'administrateur", il apparaisse une fenêtre d'avertissement du genre "Est-ce que vous certain de vouloir exécuter ce programme?..."
              C'est bien la version1.7.0 de Xampp que je dois utiliser?
              J'essaie ça dès ce soir!

              Merci Sharky!
              Dernière édition par carob à 21/01/2009, 18h09

              Commentaire


              • #8
                "Est-ce que vous certain de vouloir exécuter ce programme?..." ce n'est pas Wamp, mais Vista qui te donne ce message.

                Uitilise la version 2.0 qui est la dernière. Pour désinstaller Wamp, tu vas dans "C" (le système) et tu supprimes l'ensemble de Wamp. Attention si tu as précédemment placé un dossier dans Wamp il sera... supprimé. Ouvre Wamp, puis www (la racine où se trouve en fait tout le répertoire) et où tu y trouveras tes fichiers éventuels à sauvegarder ailleurs.

                Jacq
                Dernière édition par Jacq à 26/01/2009, 09h06
                Le savoir ne vaut que s'il est partagé par tous......

                Commentaire


                • #9
                  Ce n'est pas Wamp que j'utilise mais bien Xampp...

                  Commentaire


                  • #10
                    J'ai tout supprimé et tout réinstallé, mais décidément Vista ne veut pas coopérer avec Mysql. J'ai découvert que Mysql était bloqué par le pare-feu de Vista, je l'ai donc autorisé, mais toujours le même problème
                    Ça semble être un problème de sécurité de Vista qui empêche Mysql de faire son travail.
                    Assez décourageant ce Vista, je ne sais plus trop où chercher...
                    Avez-vous d'autres suggestions?

                    Commentaire


                    • #11
                      Si c'est MySQL qui te poses un problème, tu as peut-être quelque chose d'autre qui tourne sur le pourt 3306
                      pour le savoir, lance une conolde de ligne de commande (exécuter -> cmd) et tapes
                      Code:
                      netstat -a -o
                      Règlement du forum : http://forum.joomla.fr/faq.php
                      Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                      Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                      http://www.iwannaclick.org

                      Commentaire


                      • #12
                        D'accord et je fais quoi si c'est le cas?

                        Est-ce que ça serait une bonne idée de changer pour Wamp ou Easyphp??

                        Commentaire


                        • #13
                          et bien il faut la désactiver pour que MySQL puisse fonctionner
                          une seule appli par port
                          Règlement du forum : http://forum.joomla.fr/faq.php
                          Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                          Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                          http://www.iwannaclick.org

                          Commentaire


                          • #14
                            Et comment je fais pour la désactiver?
                            Ça risque pas de causer un autre problème à celui qui l'utilise?

                            Commentaire


                            • #15
                              Donc tu as bien une autre application qui utilise le port 3306 ?
                              Aurais-tu installé un au système MySQL ?
                              Règlement du forum : http://forum.joomla.fr/faq.php
                              Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                              Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                              http://www.iwannaclick.org

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X