Plus d'accès après avoir activé SSL

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Plus d'accès après avoir activé SSL

    Bonjour,

    J'ai fait une grosse bétise.

    Sur la nouvelle installation de Joomla 1.5.9

    Dans la partie administration, au niveau des paramètres du site, j'ai activé l'accès SSL, et dans la seconde qui suivait je n'ai plus d'accès au site ni à l'administration, les pages essayent de se charger en prenant l'adresse https://.....

    Savez vous à quel endroit dans la base de données je pourrai désactiver ce paramètre ?

    Merci d'avance pour votre aide

    Zoumok
    Mon site communautaire : "http://www.burgien.fr"
    Burgien, étant le nom des habitants de Bourg-en-Bresse, préfecture de l'Ain.

  • #2
    Envoyé par zoumok Voir le message
    Savez vous à quel endroit dans la base de données je pourrai désactiver ce paramètre ?
    Si tu as une sauvegarde de ta base de données, tu peux toujours l'importer tu verras bien ce que cela donne.

    Alvaro
    Jardiner, c'est respirer!

    Commentaire


    • #3
      Edite ton fichier de configuration, et regarde la variable $force_ssl : il faut qu'elle soit à 0
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

      Commentaire


      • #4
        Envoyé par RobertG Voir le message
        Edite ton fichier de configuration, et regarde la variable $force_ssl : il faut qu'elle soit à 0
        Ouf !!!

        Merci pour ton aide Robert, c'était en effet à cet endroit qu'il fallait agir, ça remarche à nouveau.

        Zoumok
        Mon site communautaire : "http://www.burgien.fr"
        Burgien, étant le nom des habitants de Bourg-en-Bresse, préfecture de l'Ain.

        Commentaire


        • #5
          Bonjour j'ai fait la meme erreure et en remettant 0 a la place de 1 dans la variable $force_ssl
          il me mets un message d'erreure


          Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/conseill/public_html/configuration.php:1) in /home/conseill/public_html/libraries/joomla/session/session.php on line 423

          Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/conseill/public_html/configuration.php:1) in /home/conseill/public_html/libraries/joomla/session/session.php on line 423

          Warning: Cannot modify header information - headers already sent by (output started at /home/conseill/public_html/configuration.php:1) in /home/conseill/public_html/libraries/joomla/session/session.php on line 426

          quel'qun aurait t'il une idee
          merci

          Commentaire


          • #6
            Bonjour,

            Ce type de message correspond a une erreur dans le fichier php que tu as modifié, en l'occurrence configuration.php

            http://docs.joomla.org/Cannot_modify...s_already_sent

            Ou tu réussis a rectifier ton fichier ou tu fais une réinstallation pour générer un configuration.php OK.

            http://forum.joomla.fr/showthread.php?t=85814

            Alvaro
            Dernière édition par alvaro à 14/02/2009, 07h22
            Jardiner, c'est respirer!

            Commentaire


            • #7
              merci, j'ai fais une réinstallation pour générer un configuration.php


              je vous remercie

              Commentaire


              • #8
                J'ai tout tenté...

                Même gaffe... et me voilà bloqué à l'extérieur de mon site.

                J'ai bien lu le message, modifié le configuration.php mis le $force_ssl à 0 et malgré tout, je n'ai toujours pas accès à mon Administration

                Échec de la connexion sécurisée

                Une erreur est survenue pendant une connexion à www.***.fr.

                SSL a reçu un enregistrement qui dépasse la longueur maximale autorisée.

                (Code d'erreur : ssl_error_rx_record_too_long)
                Help !!!
                Dernière édition par AZA3LL à 10/03/2009, 14h00 Raison: Précisions

                Commentaire


                • #9
                  Bobn, j'ai résolu le problème en partie en supprimant carrément var $force_ssl = '0'; et j'ai retrouvé la maîtrise de mon Admin, par contre je n'ai plus accès aux pages de la Boutique (Virtuemart) et je ne comprends pas pourquoi !!

                  Commentaire


                  • #10
                    Envoyé par RobertG Voir le message
                    Edite ton fichier de configuration, et regarde la variable $force_ssl : il faut qu'elle soit à 0
                    en effet j' ai fait la même bourde et j' ai pu résoudre mon problème avec cette manip .... merci

                    Commentaire


                    • #11
                      bonsoir désolé de remonter ce post
                      mais j ai le meme message d'erreur que AZA3LL mais moi j ai accès à l'admin sans problème sauf que le client ne peut pas passer sa commande
                      quand il clic sur commander j ai le message suivant qui apparait

                      Échec de la connexion sécurisée

                      Une erreur est survenue pendant une connexion à www.oliodelsole.fr.

                      SSL a reçu un enregistrement qui dépasse la longueur maximale autorisée.

                      (Code d'erreur : ssl_error_rx_record_too_long)

                      si quelqu'un peut m'aider rapidement ce serais bien, j ai fait tout les forum et je galere a mort
                      merci beaucoup
                      je suis en joomla 1511 et vm 113 hébergé chez 1TO1
                      www.oliodelsole.fr

                      Commentaire


                      • #12
                        Tu sélectionnes ton fichier configuration.php et tu changes les permissions du fichier, il faut l'amener à 777. Ensuite tu édites le fichier configurrtion.php en changeant $force_ssl à 0 , ensuite tu le sauvegarde et là ca va marcher.
                        a+

                        Commentaire


                        • #13
                          Bonjour à tous.

                          Alors moi j'ai le même problème mais je ne devrais pas...

                          En effet, mon serveur dispose bien d'un certificat SSL (OpenSSL de type localhost, généré localement) que je comptais utiliser UNIQUEMENT pour l'accès à l'interface administrateur.

                          j'ai trouvé sur le web des manips a faire pour Joomla 1.0 mais "normalement" pour la 1.5 cela n'est pas nécessaire.

                          Dés l'activation du SSL pour administrateurs seulement, d'une part, TOUT le site deviens exclusivement acessible en HTTPS et d'autre part, j'ai bien Firefox qui détecte mon certificat SSL (valide jusqu'en 2020) que j'accepte et je confirme l'exception permanent, mais après...Impossible de trouver la page !

                          Joomla 1.5.17 + Firefox 3.6.3 + OpenSSL 0.9.8b + PHP 5.1.12

                          Merci d'avance pour votre aide.
                          Dernière édition par MacIntox à 29/04/2010, 11h26

                          Commentaire


                          • #14
                            Personne n'as un petite idée pour le post juste au dessus ?

                            Commentaire


                            • #15
                              Re : Plus d'accès après avoir activé SSL

                              Envoyé par ducable Voir le message
                              en effet j' ai fait la même bourde et j' ai pu résoudre mon problème avec cette manip .... merci

                              Moi aussi j'ai fait ma même bourde... j'ai essayé en changeant la variable à "0" ... même pb... donc j'ai essayé en supprimant la ligne.... et toujours la même réponse

                              SSL a reçu un enregistrement qui dépasse la longueur maximale autorisée.
                              (Code d'erreur : ssl_error_rx_record_too_long)

                              Quelqu'un aurait une idée ? Merci.
                              je rappelle : le front reste visible, seul le back-office est indisponible.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X