Joomladay francophone 2018 à Paris 18 et 19 mai

pas de design css après installation

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] pas de design css après installation

    Bonjour,

    Je viens de mettre en ligne un site Joomla 1.5.9.
    Ce site se trouve dans un répertoire car c'est une sous-site (partie pour professionnels)
    Il se trouve que lorsque je fait appel à ce site uniquement en mettant le nom du répertoire dans le lien la page s'affiche sans le design css alors que si je rajoute index.php le design s'affiche.
    Voila le lien en indiquant que le dossier.
    Et voici le lien en ajoutant index.php après le dossier

    Vous me direz où est le problème tu n'as qu'à mettre le chemin complet.

    C'est vrai je pourrais faire ça, mais il se trouve que si je veux revenir sur cette page par l'onglet "accueil" je me retrouve sur la page sans design...

    Donc ma question est déjà pourquoi le design n'est pas pris en compte sans que je sois obligée d'indiquer le chemin complet vu que cette page est la page d'accueil?

    Et si je dois vraiment indiquer ce lien au complet où puis-je le changer sous l'onglet accueil?

    Merci à ceux qui s'arrêteront pour me répondre.
    Dernière édition par Ipszy à 08/02/2009, 17h00
    ipszy

  • #2
    J'aurais tendance à dire qu'il manque "gbpro" dans les chemins d'accès aux répertoires "tmp" et "logs" du fichier de configuration.
    Les fichiers ont-ils été déplacés de la racine à ce répertoire après l'installation initiale ?
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Non ce n'est pas ça j'avais bien fait attention de spécifier le bon chemin
      Dernière édition par Ipszy à 05/02/2009, 14h50
      ipszy

      Commentaire


      • #4
        Alors n'y a-t-il pas une mauvaise info dans la variable livesite ?
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          oui sans doute mais où? et pourquoi en local je n'ai eu aucun souci?
          ipszy

          Commentaire


          • #6
            Personne d'autres n'as une idée du pourquoi le lien n'affiche pas le design?

            Quelqu'un sait changer le chemin du lien de l'onglet accueil pour pouvoir ajouter index.php?
            ipszy

            Commentaire


            • #7
              J'ai supprimé et réinstallé tout le site et ça n'a rien donné toujours ce problème de css qui n'apparaît pas sur cette page
              Si je rajoute index.php dans la barre d'adresse le css y est associé.
              Je ne sais plus quoi faire...
              Aidez-moi SVP!
              ipszy

              Commentaire


              • #8
                Là, je ne sais pas ce que tu as fait, mais il ne fonctionne plus du tout...
                Le répertoire gbpro est interdit à la lecture : problèmes de droits d'accès à régler.
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Je vais essayer de mettre en ligne une version vierge de joomla et de tout recommencer à partir du serveur
                  ipszy

                  Commentaire


                  • #10
                    Je ne suis pas du tout convaincu que ce soit la solution.
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                    Commentaire


                    • #11
                      Voila j'ai mis en ligne la dernière version de Joomla vierge et le problème est le même... voir ici et ici avec index.php rajouté dans la barre d'adresse.
                      Donc j'en conclu que ça vient de cette dernière version.
                      A qui dois-je m'adresser pour identifier cette erreur dans cette version?
                      Dernière édition par Ipszy à 06/02/2009, 20h46
                      ipszy

                      Commentaire


                      • #12
                        Voila je viens de trouver!
                        Il faut rajouter le nom du répertoire sur le lien du CSS dans le head.
                        ipszy

                        Commentaire


                        • #13
                          Si tu dois faire ça, c'est que tu as mis un lien "en dur", ce qu'il ne faut pas faire.
                          Il faut en effet, pour pouvoir éventuellement déplacer le site ou changer son nom de domaine, utiliser les variables de Joomla!
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                          Commentaire


                          • #14
                            Bonjour Robert,

                            Tu as raison car lorsque je change de template le problème revient.
                            Je crois que c'est une erreur de la dernière version de joomla (1.5.9).
                            Avec la version 1.5.8 ça ne se produit pas.
                            Que dois-je faire? repasser à l'avant dernière version?
                            ipszy

                            Commentaire


                            • #15
                              Il faut que les liens dans index.php pour utiliser la feuille de style soit du type :
                              <link rel="stylesheet" href="<?php echo $this->baseurl ?>/templates/rhuk_milkyway/css/template.css" type="text/css" />
                              ou
                              <link rel="stylesheet" href="<?php echo $tmpTools->templateurl(); ?>/css/template.css" type="text/css" />
                              Assure-toi aussi que ta variable live_Site dans configuration.php est bien vide
                              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X