Joomladay francophone 2018 à Paris 18 et 19 mai

Petit probleme lors de l'installation de mon site sur le serveur distant

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Petit probleme lors de l'installation de mon site sur le serveur distant

    Bonjour à tous,
    Nouvel utilisateur de Joomla,j'ai un petit problème d'installation de mon site chez OVH.
    J'ai créé mon site sous movamp sur mon poste en local et je souhaiterais maintenant l'installer chez mon hébergeur.
    1)J'ai créé ma base chez OVH
    2)J'ai sauvegardé avec jommlapack, mon site
    3)j'ai décompressé la sauvegarde dans un dossier x
    4)j'ai transféré le contenu de ce dossier x vers mon espace OVH
    5)Je me suis connecté sur mon site, pour executer joomlapack installer 2.0
    Parfait
    6)j'exéute joomlepack installer et patatra... sur l'écran database restoration, le message suivant apparait :Caught AJAX error SyntaxError: missing ; before statement: Could not eval <br />
    <b>Fatal error</b>: Undefined class name 'jtext' in <b>/homez.68/logicap/www/libraries/joomla/database/database.php</b> on line <b>227</b><br />

    Et là, Et là... He ben je suis bloqué..
    J'ai cherché sur les forums une réponse à ce problème et dans mon grand désespoir j'ai vraiment besoin d'aide. Merci pour votre coup de main.

    Eliedebeaufort

  • #2
    Tu peux aussi faire un transfert classique, dans ce cas tu devras éditer ton fichier de configuration qui se trouve à la racine de ton site.

    Commentaire


    • #3
      Meci

      Merci je fais le test immédiatement.

      Commentaire


      • #4
        utilise jmoove.php pour modifier le fichier de configuration. Tu peux le télécharger sur www.jmoove.fr
        *Pour transférer votre site, pensez à : JMoove (www.jmoove.fr)
        Un Merci fait toujours plaisir.....
        Pas de MP sans y avoir été invité.

        Commentaire


        • #5
          Galere sur galere ...

          Après toute une après-midi de tests infructueux (avec joomlapack, sans joomlapack, avec jmoove, sans jmoove...) de nombreux plantages sur la base de données, j'ai décidé de tout stopper avant de péter un plomb et de réinstaller une solution propre d'abord en local avec xamp (et non mov'amp) en respectant à la lettre mes docs (joomla pour les nuls etc..).
          Donc, super, je désinstalle tout (en prenant bien soin de sauvegarder mon site) et j'entreprends après téléchargement de xamp 1.7.0, joomla 1.5.9, je réinstalle le tout correctement semble-t'il, nouveau projet, nouveau dossier, ok sur toute la ligne jusqu'au moment ou je veux aller dans phpmyadmin ==>> erreur MySQL a répondu: #2003 - Le serveur ne répond pas. !!!

          Vérification, Apache et Mysql sont running !!! Que faire ??? (je suis en local et non chez OVH)

          Je dois vraiment être nul

          Commentaire


          • #6
            j'entreprends après téléchargement de xamp 1.7.0, joomla 1.5.9, je réinstalle le tout correctement semble-t'il, nouveau projet, nouveau dossier, ok sur toute la ligne jusqu'au moment ou je veux aller dans phpmyadmin ==>> erreur MySQL a répondu: #2003 - Le serveur ne répond pas. !!!
            Vérification, Apache et Mysql sont running !!! Que faire ??? (je suis en local et non chez OVH)
            J'ai rencontré un problème similaire hier (phpMyAdmin inaccessible). Cela venait a priori du fait des valeurs par défaut que j'avais laissé telles quelles à l'installation de Wamp (et pas Xamp). J'ai tout désinstallé, installé d'abord Wamp en laissant "localhost" comme identifiant mais mon e-mail et pas celui proposé, puis installé Joomla dans le dossier www où j'ai créé ensuite le dossier sitejoomla (comme indiqué sur JPLN) et la procédure d'installation finale de Joomla s'est déroulée comme prévu sans plus de message d'erreur.

            Je ne suis pas sûre que ça t'aide mais bon...

            Commentaire


            • #7
              Aujourd'hui 14...

              Tout d'abord merci à vous tous pour votre aide, il fait un super soleil, mais bon j'ai du boulot.

              1) Désinstaller proprement xamp et installer plutôt wamp (merci devpepro).
              Opération effectuée => OK
              2) Décompressé Joomla 1.5.8 dans un sous dossier yyyyyy su répertoire www de wamp.
              Opération effectuée => OK
              3) Démarrer wamp
              Opération effectuée => OK
              4) Démarrer firefox et aller sur la page http://localhost
              Opération effectuée => wamp5 s'affiche super !!!
              5) Aller sur la page http://localhost/yyyyyy
              Opération effectuée => je configure les paramétres de mon site yyyyyy => OK
              6) supprimer le fichier installation
              Opération effectuée => ok
              7) Aller sur la page http://localhost/yyyyyy
              Opération effectuée => je suis sur la page de mon site (joomla) avec les articles de test, super
              8) Aller sur la page http://localhost/yyyyyy/administator
              Opération effectuée => je saisi mon profil et mon mot de passe et ... patatra


              Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 53 bytes) in C:\wamp\www\yyyyyy\libraries\joomla\language\langu age.php on line 344

              Il semble que ce soit un problème de mémoire ??? vérification de ma mémoire virtuelle =>OK, vérification de ma mémoire RAM (2 Go) ??? Tout semble ok !!! si vous avez une idée je sature merci, je vais faire un tour avec mon amie, il fait beau, le soleil brille , des fois je me dis que je fais un métier de ....

              Commentaire


              • #8
                Envoyé par eliedebeaufort Voir le message
                8) Aller sur la page http://localhost/yyyyyy/administator
                Opération effectuée => je saisi mon profil et mon mot de passe et ... patatra
                J'ai rencontré ce matin un problème similaire, l'adresse http://localhost/sitejoomla/administrator est NOT FOUND.
                J'ai réussi à rentrer sur l'administrator en cliquand sur "Administrator" (menu Ressources dans le template par défaut) sur la page du site virtuel. Là s'ouvre la page de Login.

                Mais ne me demande pas pourquoi, je suis une buse en informatique.

                Commentaire


                • #9
                  Précisions...

                  J'ai également essayé de modifier les valeurs "memory_limit = 8M" en passant à 16, dans les fichiers PHP.INI (de apache2 et php).
                  Rien n'y fait!!!

                  Commentaire


                  • #10
                    Message Fatal error .... Résolu

                    Pour le problème Fatal error => résolu avec 32 mais il fallait penser à tout redémarrer .
                    Je vous tiens au courant si je bloque.
                    Et encore merci pour toute votre aide.

                    Commentaire


                    • #11
                      suite des evenements

                      * JFolder::create: Infinite loop detected
                      * Attention ! - Le fichier n'a pas pu être déplacé

                      impossible d'installer le moindre composant, module, template, que penser ....

                      Commentaire


                      • #12
                        Probleme resolu

                        Après le problème de "JFolder create Infinite loop detected" mais après diverses recherches, j'ai modifier mon configuration.php, plus précisément les var logs et tmp que j'ai remplacé ainsi :

                        var $log_path = 'C:\\wamp\\www\\yyyyyy\\logs';
                        var $tmp_path = 'C:\\wamp\\www\\yyyyyy\\tmp';

                        Problème solutionné -hip hip hip hourra !!!

                        Reste à gérer maintenant mon problème initiale d'hébergeur ... C'est une autre histoire !!!

                        Commentaire


                        • #13
                          Probleme resolu

                          VOILA JUSTE UN PETIT COUCOU POUR VOUS SIGNALER QUE L'ENSEMBLE DE MES PROBLEMES SONT RESOLUS.

                          He oui beaucoup d'inattention de ma part et également quelques incompétences, mais on apprend tous les jours.

                          MERCI BEAUCOUP A TOUS.

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X