Joomladay francophone 2018 à Paris 18 et 19 mai

Transfert local=>hébergeur : plus d'images ni CSS

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Transfert local=>hébergeur : plus d'images ni CSS

    Bonjour.

    Tout est normal, si je considère qu'un transfert local=>hébergeur ne marche jamais au premier coup. En tous cas, avec moi.

    Cette fois, j'ai un site sans mise en forme ni images.
    En local tout était nickel, et il me semble avoir bien changé les 4 paramètres de configuration.php, et utilisé wherami, comme d'hab. Et comme d'hab., il y a un bug.

    Est-ce que quelqu'un aurait une idée de la cause de mes emm.... malheurs ?

    Django
    Dernière édition par django29 à 04/03/2009, 09h12

  • #2
    Tu as une url???
    *Pour transférer votre site, pensez à : JMoove (www.jmoove.fr)
    Un Merci fait toujours plaisir.....
    Pas de MP sans y avoir été invité.

    Commentaire


    • #3
      www.location-vacances-finistere.eu (mais, chut ! n'en parle à personne ...)

      Commentaire


      • #4
        Motus et bouche cousue ...

        Edit : je ne peux accéder à ton site... Erreur 403!
        Dernière édition par drf14 à 03/03/2009, 10h28
        *Pour transférer votre site, pensez à : JMoove (www.jmoove.fr)
        Un Merci fait toujours plaisir.....
        Pas de MP sans y avoir été invité.

        Commentaire


        • #5
          Oups. j'avais oublié que je l'avais redirigé vers un répertoire vide, le temps de trouver une solution.

          C'est remis sur le "bon" répertoire, avec des guillemenets, vu qu'il ne fonctionne pas correctement.

          Django

          Commentaire


          • #6
            Bonjour

            Tu as une erreur dans tes urls :
            /www.location-vacances-finistere.eu/

            au lieu de :
            http://www.location-vacances-finistere.eu/

            Je ne réponds pas aux mp.

            Commentaire


            • #7
              Avec webdeveloppeur, en faissant "Find broken images", on obtient ca :
              http://www.location-vacances-finiste...ools_small.png
              il y a donc un problème au niveau de l'adresse de chargement du css et des images...

              Vérifie ton index.php (celui du template)
              *Pour transférer votre site, pensez à : JMoove (www.jmoove.fr)
              Un Merci fait toujours plaisir.....
              Pas de MP sans y avoir été invité.

              Commentaire


              • #8
                T-bug : Tu veux dire que tous les src="/www.location-vacances ....." devraient être src="http://www.location-vacances ..." ?
                ça ne figure dans index.php que en php sous la forme :
                src="<?php echo $this->baseurl; ?>/templates/<?php echo $this->template ?>/js/.....
                et c'est fait automatiquement par joomla.
                Donc je ne sais pas quoi faire.

                drf14 : je n'ai rien vu d'anormal dans les adresses du fichier CSS et des images.

                Donc je ne sais toujours pas quoi faire.... à part tout effacer et réinstaller.

                ça ne pourrait pas venir de ioncube loader non plus ? Il sert au décryptage de Jomres.

                Commentaire


                • #9
                  T-bug : Tu veux dire que tous les src="/www.location-vacances ....." devraient être src="http://www.location-vacances ..." ?
                  Oui

                  drf14 : je n'ai rien vu d'anormal dans les adresses du fichier CSS et des images.
                  En fait, le lien qu'il te donne est :
                  http://www.location-vacances-finiste...ools_small.png

                  au lieu de :
                  http://www.location-vacances-finiste...ools_small.png
                  Je ne réponds pas aux mp.

                  Commentaire


                  • #10
                    C'est bon !

                    Dans configuration.php j'avais oublié un / : http:/www.location ... au lieu de http://www.location...


                    Maintenant j'aimerais bien effacer cette adresse de site du forum, mais je ne peux le faire que dans mes messages ...


                    Il reste quelques liens à mettre (Googlemaps etc...), et ajouter le module de réservation Jomres.

                    Merci pour votre aide.
                    Dernière édition par django29 à 03/03/2009, 16h33

                    Commentaire


                    • #11
                      Tu n'es en principe pas obligé de mettre l'url en question dans la variable $live_site, en version 1.5 : tu peux la laisser vide.
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X