Joomladay francophone 2018 à Paris 18 et 19 mai

Impossible d'installer des composants "lourds" ?

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Impossible d'installer des composants "lourds" ?

    Bonjour,

    Lorsque j'essai d'installer un composant "lourd" comme ChronoFrom 3.1 ou JoomlaPack 2.2, une belle erreur 500 s'affiche après un chargement d'environ 30 secondes :

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/1.3.41 Server at www.mon-site.com Port 80

    J'ai donc testé de nombreuses solutions pour résoudre se problème :

    - Augmentation de la valeur php "max_execution_time" dans le .htaccess (car je n'ai pas accès au php.ini chez mon hébergeur : Teaser) : résultat, je ne peux même plus accéder ni au frontend ni au backend de mon site, erreur 500 dès que je rentre l'url de mon site, on dirai que je n'ai pas le droit de modifier cette valeur dans le .htaccess meme si mon hébergeur me dit le contraire au téléphone .

    - J'ai également essayer de mettre le composant dézippé dans le dossier /tmp de joomla pour essayer de réduire le temp d'installation : résultat au bout de 30 secondes erreur 500 ...

    - J'ai peu être une autre idée mais je ne sais pas si elle est très judicieuse : vu que je ne peut pas augmenter le max_execution_time pour tout le site (.htaccess de la racine), je pensai changer cette valeur dans chaque fichier .php du composant à installer en rajoutant une ligne de ce type :
    Code:
    <?php
    ini_set('max_execution_time', '300');
    ?>
    Je ne sais pas si c'est une bonne idée donc je me tourne vers vous.

    A part sa je ne sais plus trop que faire, donc si vous avez des suggestions je suis preneur.

    Je suis parti sur l'hypothèse que l'erreur 500 s'affiché lors de l'insatllation du composant car le max_execution_time été dépasser mais les 30 secondes avant l'erreur ne sont peu-être qu'une coïncidence ...

    Je suis donc ouvert à toutes suggestions ... Je suis perdu

    J'utilise Joomla 1.5.11, je ne sais plus comment vous donnez tous les renseignement de ma config joomla avec une url que je tape, j'ai oublier ...

    Merci de votre aide

  • #2
    Compléments ...

    Voila plus d'info sur ma config

    Information de diagnostic
    Joomla! Version: Joomla! 1.5.10 Production/Stable [ Wohmamni ] 27-March-2009 23:00 GMT
    configuration.php: Modifiable (Mode: 600 ) | RG_EMULATION: N/A
    Architecture/Plateforme: FreeBSD 7.2-PRERELEASE ( i386) | Web Serveur: Apache/1.3.41 (Unix) mod_fastcgi/2.4.6 | PHP Version: 5.0.5
    PHP Configuration requise: register_globals: Désactivé | magic_quotes_gpc: Activé | safe_mode: Désactivé | MySQL Support: Oui | XML Support: Oui | zlib Support: Oui
    mbstring Support (1.5): Oui | iconv Support (1.5): Non | save.session_path: Lecture seule | Max.Execution Time: 30 secondes | File Uploads: Activé
    MySQL Version: 5.0.51a-log ( mysql50.mut.teaser.net via TCP/IP )

    Information étendue:
    SEF: Désactivé (sans ReWrite) | FTP Layer: Désactivé | htaccess: Non implémenté
    PHP/suExec: Mêmes comptes pour utilisateur et Serveur web. (PHP/suExec probablement installé)
    PHP Environnement: API: cgi | MySQLi: Non | Max. Memory: | Max. Upload Size: 8M | Max. Post Size: 8M | Max. Input Time: -1 | Zend Version: 2.0.5
    Désactivé Fonctions:
    MySQL Client: 5.0.51a ( latin1 )
    Dernière édition par faureclement à 17/06/2009, 09h34

    Commentaire


    • #3
      Bjr
      surprenant! A qui appartient le .htaccess , a t'il bien comme propriétaire le même que pour les autres fichiers de ton site?

      Sinon tu crées un fichier nommé php.ini à la racine de ton site dans lequel tu mets
      ta commande

      A tester

      Bonne journée
      http://www.ashrando.fr
      http://www.lehaillan-volley.fr

      Commentaire


      • #4
        C'est tout simplement une restriction de son hébergeur ..
        La taille d'upload maximale devrait être très basse .. pour cela l'upload lourd ne fonctionne pas et crée une erreur internal !
        Essaille d'uploader le dossier manuellement, et fichier par fichier, non pas tout en vague ..
        Cela marcherait .. c'est un truc qui fait de quelques hébergeurs les pires sur le Net ! une limite d'upload .

        Commentaire


        • #5
          Merci de ta réponse.

          J'ai créer un php.ini a la racine du site avec ma commande
          Code:
          php_value max_execution_time 60
          mais cela n'a aucun effet (pas d'erreur 500 c'est déja pas mal ), dans les info php de joomla il me dit que le max_execution_time est toujours à 30

          Par contre je n'ai pas compris ta question concernant l'appartenance du .htaccess ? Comment voir son propriétaire ?

          Commentaire


          • #6
            Essai de copier le fichier dezipper sur le dossier TMP de ton site via HTTP
            et lance un installation depuis ce repertoire tmp

            j'ai resolu des soucis similaire sur free avec ces methode
            JeFF
            http://millepattesmacon.fr/
            J 3.6
            Hébergé chez OVH

            Commentaire


            • #7
              C'est tout simplement une restriction de son hébergeur ..
              La taille d'upload maximale devrait être très basse .. pour cela l'upload lourd ne fonctionne pas et crée une erreur internal !
              Essaille d'uploader le dossier manuellement, et fichier par fichier, non pas tout en vague ..
              Cela marcherait .. c'est un truc qui fait de quelques hébergeurs les pires sur le Net ! une limite d'upload .
              Si j'upload le dossier du composant grâce a mon ftp avec filezilla tous se passe sans problème, mais ce n'est pas une installation joomla qui est PROPRE.

              Même si j'upload le dossier de mon composant sur /tmp et que j'utilise l'option joomla "Install from Directory" qui permet d'installer directement le composant depuis /tmp sans avoir besoin de l'upload, j'ai quand même l'erreur 500... Est ce normal la aussi ?

              Commentaire


              • #8
                C'est surtout pas normal !

                Commentaire


                • #9
                  Quelqu'un a-t-il une autre idée ? Je tourn en rond ...

                  Commentaire


                  • #10
                    Envoyé par faureclement Voir le message
                    Quelqu'un a-t-il une autre idée ? Je tourn en rond ...
                    Avec filezilla, une colonne indique : propriétaire/groupe,
                    Il doit être identique partout, sauf si certains fichiers sont tenus par ton hebergeur.

                    c'est un hebergeur payant?
                    Il faut que tu fasses pression pour qu'il augmente son temps de réponse, même avec des gratuits comme free il n'y a pas ce problème..
                    ps: dans le dossier tmp, il ne doit y avoir que le répertoire du programme que tu veux installer ( dezippé) et index.html
                    Tout le reste doit être supprimé
                    http://www.ashrando.fr
                    http://www.lehaillan-volley.fr

                    Commentaire


                    • #11
                      Oui c'est un hébergeur payant.

                      Oui je suis propriétaire du .htaccess.

                      Oui dans /tmp j'ai uniquement index.html et le composant que je veux installer dans un répertoire dézipper.

                      Merci quand même de me consacrer du temps

                      Si vous avez d'autres idées je suis toujours preneur.
                      Dernière édition par faureclement à 17/06/2009, 12h59

                      Commentaire


                      • #12
                        J'avais eu, avec mon précédent hebergeur, un problème différent, c''était l'espace disque insuffisant.

                        Je l'ai menacé de partir ailleurs si rien n'était fait, il a vite réagit dans le bon sens, mais pas assez à mon gout, donc je l'ai quitté.
                        Le seul problème fut celui du nom de domaine qu'il tenait, mais cela m'a permis de passer, sans finalement de bobos, de .com en .fr

                        Autre question, tu installes la version 1.5.11, est ce que la version php de ton hebergeur est compatible, il me semble qu'il faut mini 5.0.10

                        Bon courage,
                        http://www.ashrando.fr
                        http://www.lehaillan-volley.fr

                        Commentaire


                        • #13
                          Source Joomla.fr :
                          Attention : depuis la version Joomla 1.5.6, si vous exécutez sur un serveur php 5, une version php supérieure à 5.0.10 est nécessaire (uniquement si votre serveur est en php5, ne concerne pas les serveurs php4 !)
                          Très bien vu, c'est sur qu'avec ma version php 5.0.5 je suis pile où il faut pas ... Et dire que je me casse la tête depuis 2 jours avec se problème ...

                          Je viens donc de demander a mon hébergeur de passer en php 5.2.8, il me donnerons une réponse dans 48h.

                          En espérant que le problème vient bien de la version php, sinon c'est reparti pour la casse-tete

                          Merci encore

                          Bonne journée.

                          Commentaire


                          • #14
                            Salut,

                            logiquement si tu dézipe ton composant et que tu l'envoie en ftp dans ton dossier temp ou tout autre dossier que tu choisis, lorsque tu l'install via le "Install from Directory" tu ne devrais pas avoir d'erreur.

                            Tu dois mettre dans install from directories : tonmondedomaine/tmp/tonnomdedossier

                            exemple : votre-site-internet.ch/public_html/tmp/comprofiler

                            Tu dois bien mettre le nom de dossier que tu envoie dans ton dossier tmp.

                            Est-ce ce que tu a fais ?

                            Frédéric
                            “Un problème sans solution est un problème mal posé." - Albert Einstein
                            "La sagesse, c’est d’avoir des rêves suffisamment grands pour ne pas les perdre de vue quand on les poursuit." - Oscar Wilde

                            Commentaire


                            • #15
                              Merci de me répondre,

                              Oui j'ai également fais exactement cette manip est le résultat est toujours le même, l'erreur 500.

                              J'attend toujours que mon hébergeur passe à la dernière version PHP, cela devrait être fais lundi.

                              Je suis donc actuellement en PHP 5.0.5, et comme on peut le voir, le site officiel de joomla déconseil cette version.
                              Pensez vous que ça vient de la et que après upgrade de la version PHP mon problème sera résolu ?

                              Bonne journée.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X