Joomladay francophone 2018 à Paris 18 et 19 mai

Gestion des utilisateurs

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Gestion des utilisateurs

    Bonjour,

    Je m'en était pas aperçu, car sa fait plusieurs mois que j'ai migrer, mais j'ai un problème avec la gestion des utilisateurs. (je pense que c'est du à la migration)
    Quand je rentre dans la gestion des utilisateurs il m'affiche juste cela :

    DB function failed with error number 1054
    Unknown column 'aro.aro_id' in 'on clause' SQL=SELECT a.*, g.name AS groupname FROM jos_users AS a INNER JOIN jos_core_acl_aro AS aro ON aro.value = a.id INNER JOIN jos_core_acl_groups_aro_map AS gm ON gm.aro_id = aro.aro_id INNER JOIN jos_core_acl_aro_groups AS g ON g.group_id = gm.group_id GROUP BY a.id LIMIT 0, 20
    Si quelqu'un à une idée ou a déjà eu se problème merci de sa réponse.
    Dernière édition par Baf88 à 04/09/2009, 13h55

  • #2
    Salut,
    effectivement, sans doute pb de migration, la colonne aro_id dans la table jos_core_acl_aro en J!1.0 s'appelle en J!1.5 id tout court.
    Il faut aller dans phpMyAdmin, afficher la structure de la table et renommer la colonne (après une bonne sauvegarde, hein ! )
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Euh...
      non j'ai dit une bêtise, ta table est bonne c'est ta gestion des utilisateurs qui est restée en 1.0... Tu as une gestion tierce style CB ou VM ?
      Schtroumpfe toi le Schtroumpf t'aidera.
      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

      Commentaire


      • #4
        Oui j'avais essayé de renommer aro_id en id mais après y en encore une autre erreur du même style (genre id_group).
        Sinon non je n'ai pas de gestion tierce.

        Commentaire


        • #5
          Re,
          même motif
          > group_id à renommer en id dans jos_core_acl_aro_groups,
          > section_id en id itou dans jos_core_acl_aro_sections,
          > par contre group_id reste group_id dans jos_core_acl_groups_aro_map.
          > vérifie que tu as bien jos_core_acl_aro_map

          Il doit te manquer un champ value dans jos_core_acl_aro_groups à créer en varchar de 255 et à initialiser avec :
          Code:
          UPDATE `jos_core_acl_aro_groups` SET `value` = `name`
          Tu l'as faite avec quoi cette migration ???
          Schtroumpfe toi le Schtroumpf t'aidera.
          Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

          Commentaire


          • #6
            En fait tous les champs que tu m'as indiqués sont bons.

            J'ai fait ma migration avec mtwmigrator.

            Commentaire


            • #7
              J'ai même remplacé toutes les tables jos_core_acl_xxx par celle d'un site joomla qui marche.

              Sinon y a pas une manipulation pour reseté tout cela, car je n'enfiche j'ai que le compte admin pour l'instant.

              Commentaire


              • #8
                Re,
                comme je le disais dans mon 2ème post dans un éclair de lucidité : c'est ta gestion des utilisateurs qui est restée en 1.0...
                dans le message tu as le fichier php en cause ? essaye de remonter à grands coups de FTP admin/components/com_user et peut être aussi /libraries
                Schtroumpfe toi le Schtroumpf t'aidera.
                Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                Commentaire


                • #9
                  Non je n'ai pas le fichier en cause dans le message d'erreur. Mais j'ai comparé le contenue du dossier administrator/components/com_users avec un joomla qui marche.
                  Et je me suis apercu qu'il y avait les fichiers la en trop :

                  admin.users.html.php
                  admin.users.php
                  toolbar.users.html.php
                  toolbar.users.php

                  Donc j'ai mis un _ au début de leur nom pour les désactiver et maintenant sa marche. Je pense que je peux les supprimer maintenant.

                  Merci Grand Schtroumpf de ton aide

                  Commentaire


                  • #10
                    Envoyé par Baf88 Voir le message
                    Non je n'ai pas le fichier en cause dans le message d'erreur. Mais j'ai comparé le contenue du dossier administrator/components/com_users avec un joomla qui marche.
                    Et je me suis apercu qu'il y avait les fichiers la en trop :

                    admin.users.html.php
                    admin.users.php
                    toolbar.users.html.php
                    toolbar.users.php

                    Donc j'ai mis un _ au début de leur nom pour les désactiver et maintenant sa marche. Je pense que je peux les supprimer maintenant.

                    Merci Grand Schtroumpf de ton aide
                    Bonsoir

                    j'avais le même pb résolu en supprimant c'est fichiers!

                    Merci à toi!
                    http://www.notregrandefamille.info
                    http://www.jumeauxetpluslorraine.com

                    Commentaire


                    • #11
                      Bonjour,

                      Voici 4 jours que je "gratte" sur les forums et j'ai enfin trouvé LA solution grâce à ce post.
                      Encore un grand merci !

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X