banniere flash ne s affiche pas toujours.

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] banniere flash ne s affiche pas toujours.

    Bonsoir et merci d avance pour l aide.

    je travaille avec joomla 1.5 en local avec wamp . J ai réalisé une bannière avec swish max 3 . Il s agit d une banniere composé de 4 scènes. Ces scenes s affichent aléatoirement.
    j ai insérer le code flash dans le index.php de mon temlpate.
    lorsque je clique sur le menu Accueil ,OU CONATCT ou Faq, la bannière ne s affiche pas .Si je clique sur inscription , la banniere s affiche et tourne nickel.
    Quand elle ne s affiche pas il apparait un rectangle blanc . flash est reconnue car en effectuant un clic droit , il apparait à propos d adobe flash player etc etc
    D'avance merci pour le coup de main.

    voivi le code de index.php du template.
    <?php
    defined( '_JEXEC' ) or die( 'Restricted access' );
    JPlugin::loadLanguage( 'tpl_SG1' );
    ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php echo $this->language; ?>" lang="<?php echo $this->language; ?>" >
    <head>
    <jdoc:include type="head" />
    <link rel="stylesheet" href="templates/system/css/system.css" type="text/css" />
    <link rel="stylesheet" href="templates/<?php echo $this->template ?>/css/template.css" type="text/css" />
    <!--[if lte IE 6]>
    <link rel="stylesheet" href="templates/<?php echo $this->template ?>/css/ie6.css" type="text/css" />
    <![endif]-->

    </head>
    <body id="page_bg">
    <div id="wrapper">

    <div class="logo">
    <table cellspacing="0" cellpadding="0">
    <tr>
    <td>
    <h1><a href="index.php"><?php echo $mainframe->getCfg('sitename') ;?></a></h1>
    </td>
    </tr>
    </table>
    </div>
    <div id="search"><jdoc:include type="modules" name="user4" /></div>
    <div class="clr"></div>
    <div id="pillmenu"><jdoc:include type="modules" name="user3" /></div>
    <div class="clr"></div>
    <div id="header">
    <p>
    <object id="flash" width="921" height="200" data="header.swf" type="application/x-shockwave-flash">
    <param name="align" value="center" />
    <param name="allowScriptAccess" value="sameDomain" />
    <param name="quality" value="high" />
    <param name="bgcolor" value="#ffffff" />
    <param name="src" value="header.swf" />
    <param name="name" value="flash" />
    </object>

    </p>

    <div class="newsflash<?php if(!$this->countModules('user1') and JRequest::getCmd('layout') != 'form') : ?> only<?php endif; ?>">
    <jdoc:include type="modules" style="rounded" name="top" />
    </div>
    <div class="cpathway"><jdoc:include type="module" name="breadcrumbs" /></div>
    </div>

    <div id="content">
    <?php if($this->countModules('left') and JRequest::getCmd('layout') != 'form') : ?>
    <div id="leftcolumn">
    <jdoc:include type="modules" name="left" style="rounded" />
    <br />
    <?php $sg = 'banner'; include "templates.php"; ?>
    <br />
    </div>
    <?php endif; ?>

    <?php if($this->countModules('left') and $this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
    <div id="maincolumn">
    <?php elseif($this->countModules('left') and !$this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
    <div id="maincolumn_left">
    <?php elseif(!$this->countModules('left') and $this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
    <div id="maincolumn_right">
    <?php else: ?>
    <div id="maincolumn_full">
    <?php endif; ?>
    <div class="nopad">
    <jdoc:include type="message" />
    <?php if($this->params->get('showComponent')) : ?>
    <jdoc:include type="component" />
    <?php endif; ?>
    </div>
    </div>

    <?php if($this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
    <div id="rightcolumn">
    <jdoc:include type="modules" name="right" style="rounded" />
    </div>
    <?php endif; ?>
    <div class="clr"></div>

    </div>

    <div id="footer">
    <div id="footer_holder">
    <jdoc:include type="modules" name="debug" />
    <?php $sg = ''; include "templates.php"; ?>
    <a href="http://validator.w3.org/check/referer">valid xhtml</a>
    <a href="http://jigsaw.w3.org/css-validator/check/referer">valid css</a>
    </div>
    </div>
    </div>
    </body>
    </html>

  • #2
    bonjour
    quelle version de swish utilises tu? Ton probleme est il reproductible sur IE et opéra?

    cdt
    marc
    HOB France http://www.hob-fr.com/joomla.html editeur de communique-de-presse.com http://www.communique-de-presse.com est createur de templates et composants Mambo / Joomla depuis 2003.

    Commentaire


    • #3
      Bonjour ,

      la version de swish est swish max 3
      dans IE ca marche nickel > Opera = je ne l ai pas .
      Le fait d etre ne local affecterait il l affichage dans firefox ?

      merci pour l aide

      Commentaire


      • #4
        Il s'agit très certainement d'une question d'adresse d'accès au fichier, mal reconstituée à partir du seul nom.
        Essaie une adresse de type "http://localhost/monsite/header.swf"
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          bonsoir,

          J ai testé de changer les adresses , ca ne fonctionne pas . SOus firefox , rien ne s affiche . Sur explorer , seulement un rectangle blanc dans l emplacement du flash .
          je vais tenter autres choses ..

          merci Robert.

          Commentaire


          • #6
            alors , j ai fait des manips dans tous les sens ... j ai meme reessayé avec le module banner de joomla .. c est pire , rien de s affiche et j ai essayé ajax banner , qui fonctionne bien si je mets le module dans la partie droite ou gauche du site . Par contre dans le header , il prend pas ...

            il me reste 2 options . La premiere , je vais essayer de stocker le swf dans une base de donnée et l afficher avec quelques lignes de php
            option2 , comme j ai terminé le site il ne reste que les animations à optimiser , je vais le mettre sur mon serveur et on verra bien par la suite ...
            si quelqu un a une autre idée , je suis preneur .

            merci

            Commentaire


            • #7
              La question est surtout de savoir si le SWF a besoin d'être à un emplacement précis et s'il appelle éventuellement des fichiers complémentaires dont le répertoire doit avoir une adresse également précise.

              Je ne vois pas ce que stocker le SWF dans une base de données changera.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X