probleme avec les Ancres: Joomla 1.5

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • probleme avec les Ancres: Joomla 1.5

    Bonjour tout le monde

    j'ai un petit soucis avec les Ancres dans Joomla 1.5

    voila quand je clic sur le lien c'est la page d'accueil qui s'affiche

    le lien n'est pas complet exp
    http://www.xxxxxxxxxxx.fr/#Identification

    il manque la moitier du lien.
    Dernière édition par opware2000 à 24/01/2008, 18h07 Raison: pas de décorum dans les titres des messages merci !

  • #2
    Pas évident de voir d'ou viens ton souci avec la moitier du lien, donc je vais t'expliquer comment moi je fais pour faire une ancre ça t'aidera peut-être

    Lorsque tu tape ton article, pour placer une ancre il te suffit de cliquer sur l'icone en forme d'ancre dans le menu au dessus.
    Pour faire un lien vers cette ancre, tu selectionne le texte avec lequel tu veux faire le lien et tu clique sur l'icone pour créer un lien, dans le menu qui te sera proposé tu as un menu déroulant avec toutes les ancres contenu dans ton article, tu choisi celle que tu veux et hop le tour est joué

    Commentaire


    • #3
      Merci pour la reponse

      Envoyé par Tizuhl Voir le message

      Lorsque tu tape ton article, pour placer une ancre il te suffit de cliquer sur l'icone en forme d'ancre dans le menu au dessus.
      Pour faire un lien vers cette ancre, tu selectionne le texte avec lequel tu veux faire le lien et tu clique sur l'icone pour créer un lien, dans le menu qui te sera proposé tu as un menu déroulant avec toutes les ancres contenu dans ton article, tu choisi celle que tu veux et hop le tour est joué


      c'est ce que je fait de A à Z mais quand je clic sur le lien il m'affiche l'Index

      En faite le lien qui se mets automatiquement est erronée d'après moi.
      Il ne mets rien d'autre dans le lien que www.XXXX.fr/#ancre et donc il manque la référence de l'article.
      Est ce que vous avez ce souci ?
      Dernière édition par bah7911 à 24/01/2008, 12h27

      Commentaire


      • #4
        Problème ancre

        Bonjour,

        J'ai exactement le même problème. L'ancre ne fonctionne pas sur une page crée avec l'éditeur lorsque cette dernière est en ligne, le lien n'est pas complet !

        Commentaire


        • #5
          Solution 1

          Désactiver System - SEF dans plugins

          Commentaire


          • #6
            Merci arkeo
            ça marche si on a un seul lien mais une fois qu'on ajoute un deuxieme le premier n'est plus bon

            Le deuxieme bon:


            Le premier pas bon :

            Commentaire


            • #7
              Je ne peux confirmer ici. Tout marche.
              Example de lien obtenu dans l'article joomla overview
              http://monsite.com/joomla15/joomla-overview.html#top
              Jean-Marie Simonet / infograf768
              Joomla co-fondateur. Joomla Production Working Group.
              Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

              Commentaire


              • #8
                Re : probleme avec les Ancres: Joomla 1.5

                Bonjour,

                J'ai le même souci chez moi, quelqu'un a-t-il pu mettre la main sur une solution satisfaisante ?

                J'ai trouvé des réponses sur ce fil de discussion mais rien qui ne me fasse avancer étant donné que je ne dispose pas, dans le répertoire de mon site, du dit fichier à modifier. Après investigation, les répertoires ont quelque peu changé entre les anciennes versions et la 1.5.x, par conséquent les solutions valables il y a quelques années ne le sont plus aujourd'hui.

                ------------------

                Version de Joomla : Joomla! 1.5.22 Stable
                Dernière édition par vinylourson à 05/01/2011, 16h23

                Commentaire


                • #9
                  Re : probleme avec les Ancres: Joomla 1.5

                  j'ai trouvé une solution, un peu contraignante au quotidien, mais sans mettre les mains dans les fichiers php, ni dépublier le plugin SEF

                  ma version: Joomla 1.5.15 + editeur JCE

                  donc 1 je créé mon ancre dans mon article en cliquant là où je veux, et en utilisant le bouton "ancre", je lui donne un nom unique : ancre1

                  en 2, ailleurs dans mon article, je créé mon lien : je sélectionne mon texte "lien vers ancre1", en utilisant le bouton "lien"

                  en 3, je sélectionne mon item de menu qui correspond à mon article "présentation"
                  ça me génère l'url
                  index.php?option=com_content&view=article&id=10&It emid=5

                  en 4, je rajoute au bout l'id de mon ancre, ce qui donne:
                  index.php?option=com_content&view=article&id=10&It emid=5#ancre1

                  ensuite je règle la cible (non défini en l'occurence) et le titre (aller à l'ancre1)
                  et zou, ça marche

                  à voir par contre si sur 2 articles différents j'ai #ancre1 et #ancre2, si joomla ne se mélangera pas les pinceaux ?

                  Commentaire


                  • #10
                    Re : probleme avec les Ancres: Joomla 1.5

                    Bonjour claire39,

                    J'ai également fait quelque chose d'à peu près similaire pour pouvoir faire pointer les ancres là où elles devraient pointer mais cette solution ne peut être que temporaire.

                    J'utilise l'URL réécrite, si par exemple l'adresse est www.monsite.com/une_section/une_page

                    il me suffira de mettre une_section/une_page#une_ancre comme URL pour l'ancre.

                    Toutefois comme je disais plus haut, cette solution ne peut être que temporaire car je ne compte pas modifier la centaine d'articles qui comprennent en moyenne entre deux et quatre ancres .

                    Donc si jamais quelqu'un passe par là avec une solution sous le bras ce serait, comment dire… salvateur

                    Commentaire


                    • #11
                      Re : probleme avec les Ancres: Joomla 1.5

                      Bonjour,
                      Y a-t-il eu une solution de trouvée, depuis ???

                      Commentaire


                      • #12
                        Re : probleme avec les Ancres: Joomla 1.5

                        Salut,
                        Envoyé par la brioche Voir le message
                        Bonjour,
                        Y a-t-il eu une solution de trouvée, depuis ???
                        Sachant qu'à l'époque de ce fil la version de Joomla était 1.35.15 et qu'aujourd'hui nous en sommes à la version 1.5.25 il y a des tas de choses qui ont changé. De plus j'ignore ce que tu utilises comme éditeur mais eux aussi ont beaucoup évolué depuis, ne serait-ce que pour se mettre au diapason des versions 1.6 puis 1.7 et même 2.5

                        Je te propose donc de créer un nouveau fil et de poser ta question, tu auras plus de chances d'obtenir une réponse
                        adishatz, érix
                        https://www.agerix.fr/
                        Vous aimez ce forum ? Aidez-nous à le maintenir en adhérant à l'AFUJ : https://www.joomla.fr/association/adherer

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X