Problème path du répertoire images

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème path du répertoire images

    Bonjour,
    Je suis sous JOOMLA 1.5.3. Ca marchait, ca ne marche plus.
    Lorsque je suis connecté sur le front-end et que je veux ajouter une image à l'article que je suis en train de publier :

    1) Je clique sur le bouton image et j'obtiens la fenêtre suivante.
    www.belcodene.com/images/problemes/image1.gif
    Je clique alors sur le dossier de mon choix dans lequel je veux y ranger une image ... rien ne se passe.

    2) J'essai de chosir mon dossier au travers de la liste déroulante comme suit.
    www.belcodene.com/images/problemes/image2.gif
    J'obtient alors le message d'erreur suivant :
    www.belcodene.com/images/problemes/image3.gif

    J'ai testé la manip en me connectant sur le back-end, dans ce cas ça marche.
    Voir l'image suivante. Remarquez que par rapport à image2.gif que les chemins affichés dans la liste déroulante sont différents.
    www.belcodene.com/images/problemes/image4.gif

    Je suis hébergé chez Online, il y a eu des évolutions PHP et migration de bases de données de MYSQL4 vers MYSQL5. Je pense que le problème est apparu lors de ces migrations, Online me certifie que NON, que c'est un problème de WEBMASTERING et que je n'ai qu'à me débrouiller

    Ca fait maintenant une dizaine de jours que je sèche sur ce problème.

    Je sollicite votre aide, merci.

    FABULON
    Dernière édition par fabulon à 13/07/2008, 02h45

  • #2
    Quels sont les paramètres dans Configuration globale->onglet système?
    (Voir image)
    le "Chemin vers le dossier image" doit diriger vers images ou un sous-dossier d'images
    Fichiers joints
    Jean-Marie Simonet / infograf768
    Joomla co-fondateur. Joomla Production Working Group.
    Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

    Commentaire


    • #3
      Bonjour,
      Le "Chemin vers le dossier image" est : images/belcodene
      voir copie d'écran ici : www.belcodene.com/images/problemes/image5.gif

      J'ai vérifié aussi directement dans la base de données au niveau du composant com_media, c'est correct.
      Un indice de plus, si j'efface les paramètre du Chemin vers le dossier image, JOOMLA met images/stories. Même dans ce cas ça ne marche pas alors que ça marche quand je suis connecté sur le BACK_END

      Merci pour votre aide.

      FABULON

      Commentaire


      • #4
        Hmmm.
        la seule chose que je vois d'étrange est l'absence de <base href dans le header des pages.

        Votre hôte a en effet dû changer quelque chose.
        Essayez de renseigner le champ livesite dans configuration.php.
        var $live_site = '';

        Utilisez-vous un htaccess? Si oui, est-il spécifique à l'hôte?
        Jean-Marie Simonet / infograf768
        Joomla co-fondateur. Joomla Production Working Group.
        Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

        Commentaire


        • #5
          Je n'ai pas de fichier htaccess. Le seul que j'ai utilisé était pour filtrer les adresses IP sur le BACK-END. J'ai essayé de le retirer, ça ne change rien au problème.
          Je viens de mettre le nom de domaine de mon site dans la variable $live_site. Ca "détraque tout".
          Qu'est-ce qu'il pourrait expliquer que le chemin du dossier images soit correct lorsque j'édite un nouvel article au travers de la partie administration ?
          revoir : http://www.belcodene.com/images/problemes/image4.gif
          Merci,
          Dernière édition par fabulon à 30/06/2008, 16h41

          Commentaire


          • #6
            je viens de modifier, à nouveau, la variable $live_site = 'http://www.belcodene.com'. Dans ce cas, le site fonctionne toujours, mais le problème demeure.... mystère

            Commentaire


            • #7
              En dernier ressort, il faut penser à la corruption d'un fichier et donc ècraser l'installation par un nouveau paquet.

              Votre template contient-il:
              <jdoc:include type="head" />

              Si oui, l'absence de <base href me turlupine et me conforte dans l'idée que vous avez un ou des fichiers corrompus.
              Jean-Marie Simonet / infograf768
              Joomla co-fondateur. Joomla Production Working Group.
              Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

              Commentaire


              • #8
                bonjour,

                Oui, je retrouve jdoc:include type="head" dans le fichier index.php de mon template et dans un fichier nommé component.php

                Quel serait les fichiers ou l'ensemble de fichiers à mettre à jour ?
                Puis-je les remplacer en les écrasants à partir d'une connexion FTP ?
                Que me conseilleriez vous ?

                Milles mercis,

                FABULON

                PS : Je viens de changer de template, pour voir, toujours le même problème.

                - J'aurai bien aimé que bourke se manifeste, car il semble avoir le même problème que moi : http://forum.joomla.fr/showthread.php?t=67955

                Commentaire


                • #9
                  Ecraser avec un paquet complet.
                  Le mieux est de décompresser par le File Manager de l'hôte APRES avoir ftp le paquet.
                  N'oubliez pas de sauvegarder tout changement dans des fichiers originaux du core.
                  Jean-Marie Simonet / infograf768
                  Joomla co-fondateur. Joomla Production Working Group.
                  Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                  Commentaire


                  • #10
                    Pour l'instant, ça m'a pris beaucoup de temps, j'ai recopié sur mon PC via FTP, l'ensemble du site. Ensuite j'ai comparé la taille en octets de chaque répertoire du moteur JOOMLA. Les quelques différences que j'ai pu noter par rapport à un JOOMLA original s'expliquent et proviennent du plugin/module JUMI que j'ai ajouté et des quelques fichiers languages pour lesquels j'ai modifié les traductions. Je ne vois pas d'autres différences. Ca me prend la tête de ne pas trouver
                    Le fait que le chemin soit correct quand j'utilise la même fonction à partir du backend m'interpelle.

                    Commentaire


                    • #11
                      Grrr....
                      Ecrasez sur votre PC par un paquet propre et vérifiez...
                      Jean-Marie Simonet / infograf768
                      Joomla co-fondateur. Joomla Production Working Group.
                      Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                      Commentaire


                      • #12
                        Envoyé par infograf768 Voir le message
                        Grrr....
                        Ecrasez sur votre PC par un paquet propre et vérifiez...
                        Ouups, désolé. Je vais faire ça en milieu d'après midi.

                        Problème, je vais être obligé de faire une copie de l'ensemble des fichiers au travers de ma connexion FTP, car je ne sais pas décompresser directement sur le site.

                        Je vous tiens informé,

                        Merci

                        Commentaire


                        • #13
                          Je viens d'écraser les fichiers de la racine ainsi que les répertoires suivants :

                          administrator
                          components
                          includes
                          language
                          librairies
                          modules
                          plugins
                          media
                          xmlpc

                          Malheureusement le problème persiste.

                          Voici ce que j'obtiens comme adresse URL de l'image lorsque je clique sur une image de la racine voir : www.belcodene.com/images/problemes/image6.gif

                          Merci pour votre patience

                          Commentaire


                          • #14
                            bonjour,

                            Afin d'éliminer le fait que le problème puisse venir de la base de données, j'ai récupéré cette dernière sur le site de belcodene.com et l'ai recopiée chez un autre hébergeur (PHPNUX) sur le site www.belcodene.net
                            Je n'ai pas constaté de défaut sur belcodene.net

                            Pourriez vous m'aider svp ?

                            Merci

                            FABULON

                            PS : pour rappel, mon site belcodene.com est hébergé chez Online. Ces derniers ont effectué une migration de machines. Les bases de données Myslql 3 et 4 ont été converties en Mysql 5. Depuis, lorsque je veux uploader une image à partir du frontend, le chemin du dossier images est mal calculé par JOOMLA.
                            Si quelqu'un a eu des problèmes similaires lors de la récente migration, merci de me le faire savoir.

                            Commentaire


                            • #15
                              Ce n'est pas un pb de base, mais donc un problème de configuration serveur.
                              Mystére...
                              Jean-Marie Simonet / infograf768
                              Joomla co-fondateur. Joomla Production Working Group.
                              Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X