Encodage en page d'accueil.

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Encodage en page d'accueil.

    Bonjour,

    Je suis en train de me faire un site sous joomla pour partager mes notes sur astuces pour des serveur sous debian.

    Le problème est que sur ma page d'accueil j'ai un problème d'encodage avec les caractère "é". Mais uniquement en page d'accueil!!

    D'où pourrait venir ce problème?
    Voici le site:http://blog.seedaumas.fr

    Merci.

  • #2
    Je ne vois aucun problème!!

    voici une phrase provenant de ta page d'acceuil : Voila un des pré-requis pour que je puisse travailler à distance.

    le é est bien encodé.

    Pour info, j'utilise Firefox 2.0.0.14
    *Pour transférer votre site, pensez à : JMoove (www.jmoove.fr)
    Un Merci fait toujours plaisir.....
    Pas de MP sans y avoir été invité.

    Commentaire


    • #3
      Moi firefox 3.0.1.

      Mais as tu essayer de rentrer dans un article puis de cliquer sur accueil dans le menu. C'est là que pour moi les problème commencent?

      Merci.

      Commentaire


      • #4
        Bonjour

        Je viens de tester avec IE 7. Je constate les mêmes problèmes que toi mis à part que lorsque je clique sur "lire la suite" d'un de tes articles, le problème d'encodage persiste.
        Je ne réponds pas aux mp.

        Commentaire


        • #5
          Une idée sur les paramètres à contrôler dans joomla ou apache2?

          Commentaire


          • #6
            Je me suis fais avoir dernièrement par dreamweaver

            Je ne sais pas si tu l'utilises mais dans les options de dream, il est dit que si le document ne connait pas l'encodage, il choisit celui affiché dans les préférences par défaut a l'ouverture du document...

            Donc mettons que je changes des paramètres dans un, deux , 10, 100 documents... je ne vois rien sur mon serveur local(et je ne peux l'expliquer). Ensuite, je le mets sur le serveur de mon client et bam pleins de problèmes d'encodage. (J'avais changé d'ordi entre temps, ce qui m'a fait penser que c'était dream). J'ai modifié cette spécification dans mes préférences pour de l'utf-8 par defaut... J'ai fais une recherche sur <?PHP et j'ai remplacer par <?PHP dans tout mes dossiers permettant ainsi le réenregistrement de mes documents sous le bon encodage.

            J'ai réuploader le tout et presque plus de troubles. Il me restait juste mes fichiers languages .ini, je les ai réenregistré, réuploader et plus de troubles.

            J'ai trouvé ca très bizarre mais fonctionnel.

            En gros, je te dirai de vérifier
            • via le phpinfo si ton serveur permet le charset utf-8
            • de vérifier également que ton serveur et tes tables sont en utf-8
            • que tous les documents qui sont utilisés et qui foirent l'encodage sont en utf-8

            Commentaire


            • #7
              Voici la ligne phpinfo ce là à l'air OK:
              Code:
              HTTP_ACCEPT_CHARSET 	ISO-8859-1, utf-8;q=0.7,*;q=0.7
              Pour les table elles sont en UTF8.

              Et pour les documents se sont des articles écrit avec joomla, je n'ai utilisé dreamwaver.

              Commentaire


              • #8
                Bon c'est presque réglé.... j'ai modifié apache pour qu'il soit par defaut en UTF-8 au lieu d'avoir le ISO par defaut et le UTF-8 en suivant... et là ca marche.

                Par contre j'ai une base sql d'un autre site que j'aimerais passer de latin à utf-8 mais je ne connais pas la commande sql car sous phpmyadmin je n'y arrive pas.

                Commentaire


                • #9
                  Salut,

                  Si tu as tu as le droit d'ajouter une nouvelle base de donnée... Tu crées ta base de donnée en choisissant utf8_unicode_ci dans collation ou par defaut le MYSQL connection collation et l'autre sur collation, comme c'est le cas ici. Ensuite tu clic sur créer base.
                  voir printscreen

                  Tu exportes ton ancienne base

                  ensuite quand tu vas importer ton ancienne base dans la nouvelle via la commande sql, il faut faire attention au charset des tables car de base un export sans toucher aux options te génére une table de la sorte
                  Code:
                  CREATE TABLE `jos_bannertrack` (
                    `track_date` date NOT NULL,
                    `track_type` int(10) unsigned NOT NULL,
                    `banner_id` int(10) unsigned NOT NULL
                  ) ENGINE=MyISAM DEFAULT CHARSET=utf8;
                  donc bien vérifier le charset...

                  J'èspère que ca peut t'aider...

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X