lire la suite -> affichage en blog foireux -> désespoir profond

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • lire la suite -> affichage en blog foireux -> désespoir profond

    Bonjour,
    ça fait une semaine que je galère pour faire un site tout con et j'en peux plus.

    j'essaye d'afficher une catégorie sous forme de blog et ça ne ressemble à rien, pire encore, toute la mise en page devient foireuse.

    La faute à qui? Aux "lire la suite". Si je les retire, tout va bien

    http://jeango.net/jtest/fr/varietes

    Mais des que je les rajoute, tout foire

    http://jeango.net/jtest/fr/conditionnements

    Je viens de passer tout mon week-end à raison de 13h par jour à galérer, j'ai même refait le site entièrement à partir d'une installation joomla toute neuve pour être sur de pas avoir un module ou un plugin qui venait faire foirer les choses. Et là en faisant un test tout bête je vois que ça vient de ce "lire la suite", j'ai essayé avec 4 template différents, ca fait toujours la même chose. Actuellement c'est sur Beez-2 non-modifié tel qu'il est livré de base avec joomla, donc si ça marche pas, alors qu'est-ce qui peut marcher.

    Je vous en prie aidez-moi parce que là je suis vraiment loin, j'en peux plus, si ça continue je vais finir par péter un cable.

  • #2
    Re : lire la suite -> affichage en blog foireux -> désespoir profond

    Ah miracle, merci la loi de murphy...
    donc frustration universelle oblige, j'essayais de faire un exemple pour illustrer mon problème, et hop effet démo, je n'arrivais pas à reproduire le problème.

    c'est là que je me dis: mais qu'ai-je fait de différent? Ah oui j'ai pas fait de copier-coller... non??????? ne me dites pas que.....

    OUIIIIIIIII!!!!

    Quand on fait copier-coller dans tinymce, pour une raison qui m'échappe, ça rajoute ceci dans le code:

    <div style="color: #333333; font-family: Tahoma, Helvetica, Arial, sans-serif; font-size: 76%; background-image: initial; background-attachment: initial; background-origin: initial; background-clip: initial; background-color: #ffffff; line-height: 1.3em; background-position: initial initial; background-repeat: initial initial; margin: 8px;">

    Quand je refais mes articles à la main, miracle, plus de problème.

    Je vous remercie quand-même à tous pour votre aide car si je n'avais pas essayé de démontrer mon problème, je n'aurais jamais découvert le poteau rose ni le pot aux roses, c'est selon

    me voilà soulagé d'une bien misérable détresse, temps de péter un coup et d'aller prendre un bol d'air, ou non tiens je vais inviter ma copine au resto, ça me changera les idées, bonne soirée à tous et que vos vies soient belles et remplies de belles choses

    désolé je pars en ******* mais ça fait du bien j'en ai besoin aaaaaaaaaaaaaaaaaaaaah bon allez je raccroche a bientôt les amis

    Commentaire


    • #3
      Re : lire la suite -&gt; affichage en blog foireux -&gt; désespoir profond

      Bonjour,
      si ça revient (ou plutôt quand ça reviendra) vérifie si tu n'a pas planté ton lire la suite entre deux balises html, séparant du coup le <p> de son </p> ou le <span> de son </span> etc. ce qui explique le bazar sur la page.
      Pour cela regarde la page en mode HTML (bouton [HTML] dans tinyMCe ou [<>] dans JCE).
      Schtroumpfe toi le Schtroumpf t'aidera.
      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

      Commentaire


      • #4
        Re : lire la suite -&gt; affichage en blog foireux -&gt; désespoir profond

        Depuis quoi fais-tu tes copier-coller ? Si c'est depuis Word, ne cherche pas ailleurs. Word ajoute des quantités de balises qui sèment une joyeuse pagaille dans le html.

        Commentaire


        • #5
          Re : lire la suite -&gt; affichage en blog foireux -&gt; désespoir profond

          Envoyé par lesoutier Voir le message
          Depuis quoi fais-tu tes copier-coller ? Si c'est depuis Word, ne cherche pas ailleurs. Word ajoute des quantités de balises qui sèment une joyeuse pagaille dans le html.
          Non, pas depuis word, simplement depuis tinymce

          en gros j'avais fait, pour tous mes articles, un contenu temporaire présenté sous la forme suivante:

          intro
          ---lire la suite---
          texte

          j'ai donc fait ça pour le premier article, puis j'ai sélectionné tout et copié. Ensuite tous les articles suivants, j'ai juste fait un coller.

          Mais ce que je ne voyais pas (wysiwyg oblige) c'est qu'il avait aussi copié la mise en forme, qu'il avait intégré dans une <div>, seulement voilà, le 'lire la suite' coupe la <div> qui par conséquent n'était pas refermée en mode blog. => mise en page foireuse

          Fait étonnant par contre, ce comportement n'est pas le même pour les articles en vedette... allez savoir pourquoi.

          Commentaire


          • #6
            Re : lire la suite -&gt; affichage en blog foireux -&gt; désespoir profond

            sujet déplacé forum Joomla! 1.6/1.7 Questions générales ---> Gestion des Articles
            sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
            http://virtuemart.fr

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins
            Travaille ...
            X