Joomladay francophone 2019 à Paris, les 8 et 9 mars 2019

"Bug" d'affichage en mode blog de catégorie

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] "Bug" d'affichage en mode blog de catégorie

    Bonjour à tous !

    Avant de mettre les mains dans le cambouis, je viens voir si d'autres personnes rencontrent le même problème.
    Cela se passe avec une install de la version 1.7.3
    J'ai un problème d'affichage d'un blog de catégorie.
    Impossible de respecter la forme demandée, celle qui est d'ailleurs par défaut à savoir 1 article intégral, 4 intros sur 2 colonnes...

    Chez moi je n'ai que la liste des intros, même en bidouillant l'admin de tous les côtés...
    Cliquez sur l'image pour l'afficher en taille normale

Nom : Actu_1322125398803.jpg 
Affichages : 1 
Taille : 28,4 Ko 
ID : 1814548
    C'est bizarre quand même...
    Je vais regarder du côté du composant... mais je voulais savoir si j'étais tout seul à détecter ce problème...

    Bien à vous,

    Dol.
    C'est en forgeant qu'on devient forgeron. Mais c'est pas en coupant du bois que Léonard de Vinci...” (extrait du "Da Vinci Code de l'artisanat")
    Ne m'envoyez pas de message privé pour résoudre vos problèmes sans y avoir été invité.
    Dolmenhir : tailleur de site web depuis 1997. Spécialiste Joomla depuis 2005. https://www.dolmenhir.fr

  • #2
    Re : "Bug" d'affichage en mode blog de catégorie

    Bonjour,
    "article complet" est (à mon sens) une erreur de traduction qui dure depuis la 1.0.
    Il s'agit simplement d'article affichés en pleine largeur, mais uniquement le résumé contrairement à ce que peut laisser croire "complet" : ce sont les articles de début de listes, et le paramètre colonnes n'a pas d'impact sur ces articles.

    Si le paramètre colonnes n'a pas d'impact sur les suivants, ça tient probalement à ton template (ce qui n'est pas anormal, il a l'air étroit) Essaye avec Beez pour voir.
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Re : "Bug" d'affichage en mode blog de catégorie

      le colonage ne fonctionne visiblement pas
      Que ce soit avec Beez (5 et 20)
      Cliquez sur l'image pour l'afficher en taille normale

Nom : Actu_1322127956973.jpg 
Affichages : 1 
Taille : 21,0 Ko 
ID : 1798218Cliquez sur l'image pour l'afficher en taille normale

Nom : Actu_1322128001860.jpg 
Affichages : 1 
Taille : 20,8 Ko 
ID : 1798219
      ou avec mon template (qui n'est pas étroit, c'était la capture... il fait 980px de large)
      Cliquez sur l'image pour l'afficher en taille normale

Nom : Biographie_1322128069336.jpg 
Affichages : 1 
Taille : 47,8 Ko 
ID : 1798220
      Histoire de, j'ai remplacé les fichiers du com_content par ceux de la 1.7.2, sans succès
      Bon, je vais creuser...
      C'est en forgeant qu'on devient forgeron. Mais c'est pas en coupant du bois que Léonard de Vinci...” (extrait du "Da Vinci Code de l'artisanat")
      Ne m'envoyez pas de message privé pour résoudre vos problèmes sans y avoir été invité.
      Dolmenhir : tailleur de site web depuis 1997. Spécialiste Joomla depuis 2005. https://www.dolmenhir.fr

      Commentaire


      • #4
        Re : "Bug" d'affichage en mode blog de catégorie

        Re,
        il n'y a pas de confusion entre 2 blogs ? Paramètres sur l'un et affichage de l'autre ?
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Re : "Bug" d'affichage en mode blog de catégorie

          Non, aucune confusion là dedans.
          Je viens de constater que si je mets le template Beez par défaut, j'ai mes colonnes
          Mais si je me contente de l'assigner comme template par défaut à la page (via le menu) je n'ai plus de colonnes
          Cela veux dire que les paramètres globaux et locaux sont corrects, mais que c'est dans un des fichiers du templates que qq chose interfère...
          Pourtant, ce template est on ne peut plus basique... et rien n'est sensé se substituer aux fichiers de base du système...
          Bon, je vais débugger de A à Z
          C'est en forgeant qu'on devient forgeron. Mais c'est pas en coupant du bois que Léonard de Vinci...” (extrait du "Da Vinci Code de l'artisanat")
          Ne m'envoyez pas de message privé pour résoudre vos problèmes sans y avoir été invité.
          Dolmenhir : tailleur de site web depuis 1997. Spécialiste Joomla depuis 2005. https://www.dolmenhir.fr

          Commentaire


          • #6
            Re : "Bug" d'affichage en mode blog de catégorie

            Bon, ben un grand classique...
            une coquille dans la définition de la classe...
            Bref, rien de bien méchant et tout est rentré dans l'ordre
            Comme quoi, ne jamais coder jusque très tard dans la nuit... car les yeux ne suivent pas toujours...
            C'est en forgeant qu'on devient forgeron. Mais c'est pas en coupant du bois que Léonard de Vinci...” (extrait du "Da Vinci Code de l'artisanat")
            Ne m'envoyez pas de message privé pour résoudre vos problèmes sans y avoir été invité.
            Dolmenhir : tailleur de site web depuis 1997. Spécialiste Joomla depuis 2005. https://www.dolmenhir.fr

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins

            Partenaire de l'association

            Réduire

            Hébergeur Web PlanetHoster
            Travaille ...
            X