Problème mot "Article" lors de l'utilisation d'url option=com_content&view=article&id

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème mot "Article" lors de l'utilisation d'url option=com_content&view=article&id

    Bonjour

    Je suis actuellement en train de créer un site avec Joomla 1.7
    Mon problème est le suivant :
    Grace à un script php je vais chercher dans la table _content le contenu de l'article, son titre et son id.

    J'affiche le début de l'article dans un bandeau de news défilant, avec un lien vers l'article complet, qui est donc du type monsite/option=com_content&view=article&id=xxx

    Sauf que lorsque j'accède à un article de cette façon il y a toujours le mot "Article", écrit au dessus, ce qui n'est pas super. J'aimerais donc enlever ce mot.

    Les quelques infos que j'ai réussi à trouver sur d'autres topics ne correspondent pas à mon cas, je m'adresse donc à vous

    Merci

  • #2
    Re : Problème mot "Article" lors de l'utilisation d'url option=com_content&view=artic

    Bonjour,
    Je suis actuellement en train de créer un site avec Joomla 1.7
    Tu devrais passer à la version 2.5 de Joomla!.

    Pour le mot article, l'astuce est de créer un élément de menu (qui doit être publié mais qui peut être placé dans un menu non-publié) menant vers l'article en question ou vers la catégorie de l'article.
    Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous

    Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine[/CENTER]

    Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

    Commentaire


    • #3
      Re : Problème mot "Article" lors de l'utilisation d'url option=com_content&view=artic

      Le problème étant que je ne peux pas créer un lien de menu à chaque fois que je vais créer un nouvel article
      Mon bandeau de news prends les 3 derniers articles afin de les afficher, je ne peux donc compter que sur les informations de la base de données

      J'ai du rester en 1.7 pour des questions de plugins

      Commentaire


      • #4
        Re : Problème mot "Article" lors de l'utilisation d'url option=com_content&view=artic

        Le problème étant que je ne peux pas créer un lien de menu à chaque fois que je vais créer un nouvel article
        Tu peux donc faire un lien de menu vers tes catégories.

        J'ai du rester en 1.7 pour des questions de plugins
        La version 1.7 de Joomla! ayant un faille de sécurité, je ne pense pas que ce soit une bonne idée de ne pas migrer en 2.5.
        Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous

        Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine[/CENTER]

        Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

        Commentaire


        • #5
          Re : Problème mot "Article" lors de l'utilisation d'url option=com_content&view=artic

          Bonjour,

          Comme indiqué par SimonG, passer en 2.5 est impératif, la version 1.7 (transitoiire) n'étant plus maintenue et une faille importante de sécurité ayant été corrigée en 2.5.3. Pour les plugins, sauf exception d eplugin vraiment mal écrit, la compatibilité avec 2.5 est normalement garantie.

          Pour ton problème de liens, il faut effectivement avoir publié au moins la catégorie quelque part, par exemple dans un menu invisible, pour que les IDs soient corrects. Ce qui peut paraître complexe, mais fait partie du fonctionnement normal de Joomla!
          Pas de demande de support par MP.
          S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

          Commentaire


          • #6
            Re : Problème mot "Article" lors de l'utilisation d'url option=com_content&view=artic

            Le truc c'est que j'ai déjà des catégories, et mes articles sont dedans (et affichés correctement), de plus le fait d'utiliser la recherche (enfin le lien avec l'id) me permet de trouver n'importe quel article ou qu'il soit, mais toujours avec ce "Article" immonde en premier
            Dernière édition par pampal à 02/04/2012, 20h25

            Commentaire


            • #7
              Re : Problème mot "Article" lors de l'utilisation d'url option=com_content&view=artic

              Bonjour,
              toujours avec ce "Article" immonde en premier
              oui, et ça continuera comme ça tant que tu ne feras pas ce que l'on te dit : crée un lien de menu de type blog vers chacune de tes catégories et dans les paramètres, section affichage de la page sélectionne Mettre à jour l'en-tête =non.
              Schtroumpfe toi le Schtroumpf t'aidera.
              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

              Commentaire


              • #8
                Re : Problème mot "Article" lors de l'utilisation d'url option=com_content&view=artic

                Merci de vos réponses,mais soit vous ne comprenez pas, soit je suis nul en explications.
                J'ai déja un menu avec des liens qui mènent vers les catégories qui contiennent mes articles, et pour tous ces liens, la fameuse case en-tête est déja fixée sur "non".

                Ce qu'il faudrait dans ce cas que j'arrive a faire c'est de choper dans la base de données l'url du lien de menu correspondant, mais je ne sais pas si c'est possible.
                Dernière édition par pampal à 03/04/2012, 12h05

                Commentaire


                • #9
                  Re : Problème mot "Article" lors de l'utilisation d'url option=com_content&view=artic

                  Bonjour,
                  Ce qu'il faudrait dans ce cas que j'arrive a faire c'est de choper dans la base de données l'url du lien de menu correspondant, mais je ne sais pas si c'est possible
                  Dans la base de données, non, mais plus simplement affiche les menus cachés le temps de cliquer sur le lien et de récupérer l'URL dans la barre de navigation. Une fois que tu auras repéré que ce qui te manque c'est le &Itemid=xxx où xxx est l'id du lien de menu, tu devrais pouvoir compléter tes URL à la main.
                  Schtroumpfe toi le Schtroumpf t'aidera.
                  Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                  Commentaire


                  • #10
                    Re : Problème mot "Article" lors de l'utilisation d'url option=com_content&view=artic

                    L'utilisation de "Itemid=xxx" à la suite de "?option=com_content&view=article&id=xxx" me permet effectivement de ne plus afficher le mot "Article"

                    Merci beaucoup !

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X