problème avec "lire la suite" en blog

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] problème avec "lire la suite" en blog

    Bonjour, je rencontre un problème avec "lire la suite" voir ICI

    Lorsque mes articles ne comportent pas de lien " lire la suite" la mise en page est ok voir ICI Si je désire mettre "lire la suite sur mes articles , en blog sur 2 colonnes, j'ai une mise en page erratique. voir ICI
    Avez vous une solution ?
    Merci
    Jommla 2.5.19 + template rockettheme
    Dernière édition par toffffe à 02/04/2014, 07h58

  • #2
    Re : problème avec "lire la suite" en blog

    je ne vois rien d'"erratique" sur ta page, les 2 articles sont sur 2 colonnes... proprement ???
    Christophe
    http://www.webcrea.fr

    Commentaire


    • #3
      Re : problème avec "lire la suite" en blog

      heu....c'est bien ICI que tu trouves ma page "normale" avec les liens "lire la suite" ?

      Commentaire


      • #4
        Re : problème avec "lire la suite" en blog

        Salut
        de ce que j'ai vu il y a un problème dans les 2 cas sous chrome, ton td est trop large et les colonne se chevauche.
        Formation Joomla agence internet https://www.stylitek.com
        Melijoy création de site Joomla compétitif https://www.melijoy.fr
        agence web spécialiste référencement http://www.agence-web-stylitek.fr

        Commentaire


        • #5
          Re : problème avec "lire la suite" en blog

          ah...chrome...n'affiche pas toujours convenablement. Mon template est sur responsive. Peux tu regarder avec Firefox ? il y a un problème uniquement dans le premier cas (avec le lien "lire la suite" ) merci

          Commentaire


          • #6
            Re : problème avec "lire la suite" en blog

            ..j'ai posté sur le forum de rockettheme...savoir si ce problème est lié à joomla ou au template...j'attends la réponse.

            Commentaire


            • #7
              Re : problème avec "lire la suite" en blog

              Cela vient de ton template ou à ton contenu.
              Formation Joomla agence internet https://www.stylitek.com
              Melijoy création de site Joomla compétitif https://www.melijoy.fr
              agence web spécialiste référencement http://www.agence-web-stylitek.fr

              Commentaire


              • #8
                Re : problème avec "lire la suite" en blog

                Contenu...je ne vois pas, ce sont des articles. J'opterai volontiers pour le template...j'attends. Je vais essayer avec une autre template..pour voir.
                Merci

                Commentaire


                • #9
                  Re : problème avec "lire la suite" en blog

                  ...et voici la réponse de rockettheme ;
                  When you use a system-readmore you have to ensure that your HTML tags in your article are balanced both BEFORE and AFTER the system readmore, otherwise the tags will be unbalanced when only the "intro" part of the article is shown. That seems to be the case here...validator.w3.org/check?uri=http%3A%2F%2Fwww.2014.jeanmariecastaing. com%2Findex.php%2Fblog&charset=(detect+automatical ly)&doctype=Inline&group=0

                  Lorsque vous utilisez un système en savoir plus vous devez vous assurer que vos balises HTML dans votre article sont équilibrées à la fois avant et après la en savoir plus du système, sinon les balises seront déséquilibré lorsque seule la partie "intro" de l'article est affiché. Cela semble être le cas ici ...
                  validator.w3.org/check?uri=http%3A%2F%2Fwww.2014.jeanmariecastaing. com%2Findex.php%2Fblog&charset=(detect+automatical ly)&doctype=Inline&group=0

                  c'est à dire que vous n'avez balises HTML asymétriques.

                  Si j'ai bien compris, est-ce un problème avec joomla qui ne met pas les bonnes balises là ou il le faut ?
                  Merci de vos lumières
                  Dernière édition par mimimike64 à 01/04/2014, 14h49

                  Commentaire


                  • #10
                    Re : problème avec "lire la suite" en blog

                    Il ne parle pas de joomla, mais à mon avis du contenu de ton article qui a peut être une balise qui s'ouvre et qui ne se ferme pas avant le lien lire la suite, donc provoque un déséquilibre.
                    Voila tu ouvres un tableau avec un td qui se ferme qu'en fin d'article.
                    Formation Joomla agence internet https://www.stylitek.com
                    Melijoy création de site Joomla compétitif https://www.melijoy.fr
                    agence web spécialiste référencement http://www.agence-web-stylitek.fr

                    Commentaire


                    • #11
                      Re : problème avec "lire la suite" en blog

                      je colle le code de l'article; 1 avec lire la suite, l'autre sans.
                      Si erreur il y a, à qui en imputer la responsabilité ? joomla ? jce ? personnellement je ne touche pas au code....suis pas doué.
                      Merci
                      article avec lire la suite:
                      <p>
                      <table style="width: 782px; height: 727px;" align="left">
                      <tbody>
                      <tr>
                      <td valign="top">
                      <p style="text-align: center;">Le Blog</p>
                      <p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer ac tincidunt nisl. Nam laoreet et ipsum id eleifend. Suspendisse risus leo, consectetur non consectetur sit amet, dictum at dui. Aenean rhoncus egestas eros, ac pellentesque metus. Curabitur tellus erat, dignissim pharetra justo scelerisque, molestie facilisis nisi.</p>
                      <hr id="system-readmore" />
                      <p>&nbsp;</p>
                      <p>Sed ut purus tortor. Ut porttitor ipsum quis sem imperdiet, quis posuere velit hendrerit. Cras mollis ante mauris, laoreet pellentesque nisl viverra nec. Proin ornare feugiat diam sed lacinia. Nulla non vulputate ipsum. Cras dolor odio, molestie eget ornare vel, iaculis convallis tellus. Cras sapien ante, fringilla sit amet suscipit non, semper eget odio. Ut purus metus, ultricies vel hendrerit ultrices, faucibus in nisl. Sed sit amet nunc vitae dui commodo laoreet nec quis ipsum. Phasellus vel orci metus. Suspendisse eget pellentesque metus.</p>
                      <p>Quisque gravida eros et ultrices porta. In fringilla, ligula id dapibus eleifend, magna ante laoreet dui, at sodales mi lectus non nibh. Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere cubilia Curae; Donec viverra felis quis libero vehicula adipiscing. Vestibulum et turpis sed neque vulputate viverra nec ut velit. Fusce non posuere dui. Nunc congue mollis dolor, sodales feugiat sem vehicula quis. Cras eget vulputate nisl. Proin blandit placerat leo id ultrices. Vestibulum venenatis tortor eget auctor eleifend. Praesent libero eros, rutrum ut urna sit amet, tempus cursus tellus.</p>
                      <p>Vivamus scelerisque tellus magna, ac vestibulum enim dictum a. Fusce ut ornare risus. Aenean vitae ante et dolor aliquam malesuada eget vel dui. Morbi pulvinar justo elit, sit amet molestie leo dignissim a. Donec velit magna, aliquam vel purus sed, pellentesque cursus leo. Donec adipiscing aliquet dui at semper. Aenean auctor orci non venenatis ultrices. Ut pellentesque ac leo quis porta. Fusce velit justo, ullamcorper adipiscing venenatis varius, consectetur eu ante. Etiam eleifend, ligula ac feugiat tincidunt, lorem purus porttitor quam, eget gravida lectus mauris et ligula. Nullam aliquam, turpis in sagittis rutrum, velit odio feugiat ligula, vitae rutrum leo ipsum vel diam. Maecenas ac neque vestibulum, cursus quam eu, commodo nisl. Praesent quis tortor et nibh pellentesque egestas. Fusce et velit et erat vehicula rhoncus ut a risus.</p>
                      <p>Aliquam egestas lectus turpis, sit amet placerat nunc scelerisque nec. Proin vehicula auctor nisl in ultrices. Duis eros sapien, pulvinar sit amet velit in, ullamcorper scelerisque ante. In consequat felis a sodales vulputate. Nam orci risus, aliquet quis risus in, condimentum facilisis tortor. Donec tincidunt justo ut vulputate adipiscing. Donec faucibus volutpat lobortis. Duis at varius lorem. Integer euismod ut ante quis semper. Ut tincidunt euismod mi, et pulvinar est venenatis eu. Phasellus vel mauris tortor. Vivamus accumsan, augue a molestie adipiscing, nulla eros dignissim eros, quis cursus diam sem semper massa. Quisque mi odio, mattis nec lobortis in, interdum id leo. Aenean vel odio at diam sollicitudin placerat in at quam. Pellentesque aliquet sed diam eget aliquam. In viverra urna vitae dolor pretium eleifend.</p>
                      <p>&nbsp;</p>
                      <hr />
                      <p>&nbsp;</p>
                      </td>
                      </tr>
                      </tbody>
                      </table>
                      </p>
                      __________________________________________________ __________________________________________________ ___________

                      Sans lire la suite:
                      <p>
                      <table style="width: 782px; height: 727px;" align="left">
                      <tbody>
                      <tr>
                      <td valign="top">
                      <p style="text-align: center;">Le Blog</p>
                      <p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer ac tincidunt nisl. Nam laoreet et ipsum id eleifend. Suspendisse risus leo, consectetur non consectetur sit amet, dictum at dui. Aenean rhoncus egestas eros, ac pellentesque metus. Curabitur tellus erat, dignissim pharetra justo scelerisque, molestie facilisis nisi.</p>
                      <p>&nbsp;</p>
                      <p>Sed ut purus tortor. Ut porttitor ipsum quis sem imperdiet, quis posuere velit hendrerit. Cras mollis ante mauris, laoreet pellentesque nisl viverra nec. Proin ornare feugiat diam sed lacinia. Nulla non vulputate ipsum. Cras dolor odio, molestie eget ornare vel, iaculis convallis tellus. Cras sapien ante, fringilla sit amet suscipit non, semper eget odio. Ut purus metus, ultricies vel hendrerit ultrices, faucibus in nisl. Sed sit amet nunc vitae dui commodo laoreet nec quis ipsum. Phasellus vel orci metus. Suspendisse eget pellentesque metus.</p>
                      <p>Quisque gravida eros et ultrices porta. In fringilla, ligula id dapibus eleifend, magna ante laoreet dui, at sodales mi lectus non nibh. Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere cubilia Curae; Donec viverra felis quis libero vehicula adipiscing. Vestibulum et turpis sed neque vulputate viverra nec ut velit. Fusce non posuere dui. Nunc congue mollis dolor, sodales feugiat sem vehicula quis. Cras eget vulputate nisl. Proin blandit placerat leo id ultrices. Vestibulum venenatis tortor eget auctor eleifend. Praesent libero eros, rutrum ut urna sit amet, tempus cursus tellus.</p>
                      <p>Vivamus scelerisque tellus magna, ac vestibulum enim dictum a. Fusce ut ornare risus. Aenean vitae ante et dolor aliquam malesuada eget vel dui. Morbi pulvinar justo elit, sit amet molestie leo dignissim a. Donec velit magna, aliquam vel purus sed, pellentesque cursus leo. Donec adipiscing aliquet dui at semper. Aenean auctor orci non venenatis ultrices. Ut pellentesque ac leo quis porta. Fusce velit justo, ullamcorper adipiscing venenatis varius, consectetur eu ante. Etiam eleifend, ligula ac feugiat tincidunt, lorem purus porttitor quam, eget gravida lectus mauris et ligula. Nullam aliquam, turpis in sagittis rutrum, velit odio feugiat ligula, vitae rutrum leo ipsum vel diam. Maecenas ac neque vestibulum, cursus quam eu, commodo nisl. Praesent quis tortor et nibh pellentesque egestas. Fusce et velit et erat vehicula rhoncus ut a risus.</p>
                      <p>Aliquam egestas lectus turpis, sit amet placerat nunc scelerisque nec. Proin vehicula auctor nisl in ultrices. Duis eros sapien, pulvinar sit amet velit in, ullamcorper scelerisque ante. In consequat felis a sodales vulputate. Nam orci risus, aliquet quis risus in, condimentum facilisis tortor. Donec tincidunt justo ut vulputate adipiscing. Donec faucibus volutpat lobortis. Duis at varius lorem. Integer euismod ut ante quis semper. Ut tincidunt euismod mi, et pulvinar est venenatis eu. Phasellus vel mauris tortor. Vivamus accumsan, augue a molestie adipiscing, nulla eros dignissim eros, quis cursus diam sem semper massa. Quisque mi odio, mattis nec lobortis in, interdum id leo. Aenean vel odio at diam sollicitudin placerat in at quam. Pellentesque aliquet sed diam eget aliquam. In viverra urna vitae dolor pretium eleifend.</p>
                      <p>&nbsp;</p>
                      <hr />
                      <p>&nbsp;</p>
                      </td>
                      </tr>
                      </tbody>
                      </table>
                      </p>
                      __________________________________________________ __________________________________________________ __
                      Dernière édition par mimimike64 à 01/04/2014, 15h49

                      Commentaire


                      • #12
                        Re : problème avec &quot;lire la suite&quot; en blog

                        Comme je te l'ai dis tu as un tableau ouvert avant le lire la suite et qui se ferme après.
                        Le problème viens de ton code article pas de Joomla
                        Formation Joomla agence internet https://www.stylitek.com
                        Melijoy création de site Joomla compétitif https://www.melijoy.fr
                        agence web spécialiste référencement http://www.agence-web-stylitek.fr

                        Commentaire


                        • #13
                          Re : problème avec &quot;lire la suite&quot; en blog

                          ...soit, mais je donne ma langue au chat. (cela le fait avec tous les articles créés....quelle solution ?)
                          Je fais quoi ...pour être concret ? Que dois je supprimer...puisque tu sembles avoir trouvé l'erreur.
                          Merci pour ton aide

                          Commentaire


                          • #14
                            Re : problème avec &quot;lire la suite&quot; en blog

                            Tu as
                            <p>
                            <table style="width: 782px; height: 727px;" align="left">
                            <tbody>
                            <tr>
                            <td valign="top">
                            là comme tu le vois ton tableau n'est pas fermé loin de là
                            Ensuite tu as ton lire la suite
                            <hr id="system-readmore" />
                            Et tu peux remarqué que tes balises de tableaux ne sont toujours pas fermées
                            et ensuite elle se ferme à la fin
                            </td>
                            </tr>
                            </tbody>
                            </table>
                            idem pour la balise <p> qui entoure le tout

                            Tu ne peux donc pas avoir de tableau ni de balise à cheval sur un lien lire la suite, il faut que les balises soient fermées
                            Formation Joomla agence internet https://www.stylitek.com
                            Melijoy création de site Joomla compétitif https://www.melijoy.fr
                            agence web spécialiste référencement http://www.agence-web-stylitek.fr

                            Commentaire


                            • #15
                              Re : problème avec &quot;lire la suite&quot; en blog

                              ...bien, je comprends tout cela et je te remercie pour tes explications...mais toujours pas de solution à mon problème. Le code est généré par le système, soit joomla soit jce. Pour moi ce n'est pas loin d'être chinois...ce code, donc....
                              Dois-je abdiquer et ne pas mettre de lien "lire la suite" ou ...existe t-il une solution quelque part ?
                              J'ai déja utilisé cette fonction "lire la suite" sur d'autres sites et je n'ai jamais eu de problème.
                              Désinstaller l'editeur de texte et le réinstaller ? Désinstaller joomla ?
                              I am lost ! help me !...please !

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X