Impossible afficher un menu déroulant

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Impossible afficher un menu déroulant

    Bonjour, je suis novice dans Joomla. Je n'arrive pas à faire apparaître un menu déroulant. Je crée un menu dans un module. Puis un premier lien de menu qui s'affiche bien sous le menu précédent. Mais lorsque je crée un nouveau lien de menu sous le lien précédent (en indiquant le lien précédent comme "parent item") il s'affiche sous le lien précédent au lieu de n'apparaître que lorsque je clique sur le premier lien de menu.

    Par contre, dans un autre menu, ça fonctionne correctement. Je n'arrive pas à trouver la solution. Merci de votre aide.

  • #2
    Re : Impossible afficher un menu déroulant

    Bonjour,

    as tu un lien vers le site et/ou le nom du template utilisé ?
    Ce template permet-il d'avoir des menus déroulants ?
    Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous

    Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine[/CENTER]

    Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

    Commentaire


    • #3
      Re : Impossible afficher un menu déroulant

      Bonjour et merci de m'aider.

      Le site est sur mon ordinateur et je ne l'ai pas monté sur un serveur externe pour l'instant.

      J'utilise le template fourni avec Joomla: Beez2_défault. Juste à côté j'utilise le module fourni avec Joomla (dans lequel il y a le menu: utliser Joomla avec une série de menus et sous menus imbriqués) et ça fonctionne sans problème. Il suffit de créer un lien de menu prenant le lien précédent comme parent pour que le menu déroulant fonctionne.
      Mais dans le nouveau module, menus et sous-menus apparaissent les uns à la suite des autres. Frustrant, non ?

      Commentaire


      • #4
        Re : Impossible afficher un menu déroulant

        Bon, j'ai réglé mon problème en dupliquant le module qui fonctionne bien et en changeant puis en lui affectant de nouveaux menus. Mais je n'ai toujours pas compris pourquoi je n'y arrivais pas dans l'autre module !
        Merci de votre aide.

        Commentaire


        • #5
          Re : Impossible afficher un menu déroulant

          Les deux menus dont tu parles sont publiés à la même "position" dans le template ?
          Certaines positions peuvent forcer l'affichage permanent des sous-menus. J'ignore si ce comportement existe dans Beez.
          Je cherche toujours la solution moi-même avant de venir vous tanner

          Commentaire


          • #6
            Re : Impossible afficher un menu déroulant

            Envoyé par boumy Voir le message
            Les deux menus dont tu parles sont publiés à la même "position" dans le template ?
            Certaines positions peuvent forcer l'affichage permanent des sous-menus. J'ignore si ce comportement existe dans Beez.
            Oui, les deux menus, mais chacun dans un module différent sont dans à la même position. Je pense que la différence de comportement des menus vient des "modules" mais je n'en suis pas sûr. Pourtant les modules ont l'air d'être indentiques.

            Commentaire


            • #7
              Re : Impossible afficher un menu déroulant

              Je ne comprend pas bien si ton problème est maintenant résolu ou non.

              Perso, j'ai déjà constaté que deux menus placés chacun dans un module distinct et placés à une même position pouvaient avoir des comportements différents. Celui qui était issu du Main Menu se comportait correctement avec ses effets de déroulant, alors que le second menu pouvait avoir un aspect tout différent et pas de drop down pour les sous-menus. Tu peux permuter l'attribut de menu principal en définissant un des items de menu comme "Accueil" (étoile orangée dans le backend à "Gestion des menus : Liens de menu"
              Pour voir ce que cela change.
              Je cherche toujours la solution moi-même avant de venir vous tanner

              Commentaire


              • #8
                Re : Impossible afficher un menu déroulant

                Envoyé par boumy Voir le message
                Je ne comprend pas bien si ton problème est maintenant résolu ou non.

                Perso, j'ai déjà constaté que deux menus placés chacun dans un module distinct et placés à une même position pouvaient avoir des comportements différents. Celui qui était issu du Main Menu se comportait correctement avec ses effets de déroulant, alors que le second menu pouvait avoir un aspect tout différent et pas de drop down pour les sous-menus. Tu peux permuter l'attribut de menu principal en définissant un des items de menu comme "Accueil" (étoile orangée dans le backend à "Gestion des menus : Liens de menu"
                Pour voir ce que cela change.
                Oui, j'ai résolu mon problème en supprimant le module qui n'acceptait pas les menus déroulants et en dupliquant le module qui fonctionnait comme je le souhaitais. J'en ai déduit comme toi que le comportement des menus dérivait du type de module dans lesquels ils sont situés. Mais je n'ai pas compris pourquoi. Merci de ton aide. rbyl.

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X