Menu déroulant /!\

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Menu déroulant /!\

    Bonjour à tous et à toutes,


    Avant tout, je vous explique un peu ma situation : je travaille pour une toute petite boite et nous avons récemment décidé de lancer un nouveau projet, un nouveau département ! Evidemment, pour lancer ce nouveau département, nous avons besoin de publier nos nouveaux services en ligne sur notre site web !

    Autrefois notre entreprise ne faisait que du recrutement. Le menu du site web ne comportait donc que les onglets essentiels à ce type d'activités :

    - Accueil
    - Offres d'emploi
    - Espace candidat
    - Espace entreprise
    - Contact

    Maintenant que nous lançons un nouveau département, nous souhaitons réorganiser le menu et ses onglets de la manière suivante (en imbriquant sous la forme d'un menu déroulant les sous-onglets relatif à l'un ou l'autre des 2 départements) :

    - Accueil
    - Département Recrutement
    1) Offres d'emploi
    2) Candidats
    3) Espace Entreprise
    - Nouveau département
    1) Sous onglet 1
    2) Sous onglet 2
    3) Sous onglet 3, ...
    - Contact

    J'ai donc suivi un petit tuto pour faire un menu déroulant et imbriquer sous un onglet parent des sous-onglets ... Ce que j'ai réussi sans trop de difficultés ! Voila donc à quoi ressemble désormais le menu :

    Cliquez sur l'image pour l'afficher en taille normale

Nom : Menu.png 
Affichages : 1 
Taille : 12,8 Ko 
ID : 1824273

    Et voilà à quoi cela ressemble lorsque l'on déplie/déroule un onglet :

    Cliquez sur l'image pour l'afficher en taille normale

Nom : Menu déroulé.png 
Affichages : 1 
Taille : 23,1 Ko 
ID : 1824274


    Ce qui m'amène au(x) problème(s) que j'ai par rapport à ça :


    PROBLEME N°1 :

    Je trouve l'affichage des sous-onglets vraiment vraiment vraiment hideux (jugez par vous-même)
    J'aurais souhaité que les sous-onglets s'affichent, comme les onglets du menu principal : dans des cases/cellules !

    Le plus étrange, c'est que lorsque l'on clique sur l'un de ces sous-onglets pour le visiter, le sous onglet se retrouve muni d'une case/cellule !

    Cliquez sur l'image pour l'afficher en taille normale

Nom : MENU2.png 
Affichages : 1 
Taille : 5,4 Ko 
ID : 1824275 --> Cliquez sur l'image pour l'afficher en taille normale

Nom : MENU 1.png 
Affichages : 1 
Taille : 5,5 Ko 
ID : 1824276

    Je souhaiterais que lorsqu'un onglet "parent" se déroule pour montrer ses sous-onglets, les-dits sous onglets soient dans des cellules/cases comme les autres onglets (peut-être légèrement en retrait/décalé par rapport à l'onglet parent)... Quelqu'un pourrait-il m'aider ?


    PROBLEME N°2 :

    J'aurais aussi souhaité, même si c'est plus accessoire, que le menu se déroule lorsque la souris le survole et non pas lorsque l'on clique dessus. Est-ce possible sans trop de manipulations ?


    Quelques informations importantes :

    - Je dispose d'un compte de Super Administrateur pour le site mais je ne m'y connais que très très peu en HTML, CSS etc.
    - Dans l'interface administrateur, il est mentionné que nous utilisons la version 1.8 de Joomla.
    - Je ne veux pas modifier le site trop profondément, je suis juste chargé d'en modifier la structure et le contenu.


    Je sais que c'est un peu long mais j'ai réellement besoin de vos conseils avisés !


    D'avance merci !


    Brieux

  • #2
    Re : Menu déroulant /!\

    Bonsoir et bienvenu
    regarde du coté du menu accordeon de Cedric
    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

    Commentaire


    • #3
      Re : Menu déroulant /!\

      Envoyé par manu93fr Voir le message
      Bonsoir et bienvenu
      regarde du coté du menu accordeon de Cedric
      Merci pour votre réponse !
      J'ai regardé le menu cependant, la version joomla avec laquelle le site est fait est la version 1.8, et je ne trouve là que des extensions pour joomla 2.5 mini... Ca ne fonctionnera pas j'imagine...

      Et ..Je ne peux pas mettre à jour joomla ...

      Commentaire


      • #4
        Re : Menu déroulant /!\

        la version joomla avec laquelle le site est fait est la version 1.8, et je ne trouve là que des extensions pour joomla 2.5 mini...
        Votre site web étant le reflet de votre activité, rester sur cette version (que je ne connais pas) est un peu suicidaire ! Il ne va pas juste falloir modifier votre menu

        Et ..Je ne peux pas mettre à jour joomla ...
        Et pourquoi ça ? Vous n'avez jamais eu d'alerte sur votre backend ?

        Pour les versions :
        https://docs.joomla.org/What_version..._you_use%3F/fr

        Pour les pré-requis des versions :
        https://www.joomla.fr/afuj/item/1468...es-pour-joomla

        Pour les mises a jour :
        http://aide.joomla.fr/telechargement...our-joomla-2-5

        Attention, faire une sauvegarde avant toute action sur le site
        Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

        Commentaire


        • #5
          Re : Menu déroulant /!\

          Envoyé par manu93fr Voir le message
          Votre site web étant le reflet de votre activité, rester sur cette version (que je ne connais pas) est un peu suicidaire ! Il ne va pas juste falloir modifier votre menu


          Et pourquoi ça ? Vous n'avez jamais eu d'alerte sur votre backend ?

          Pour les versions :
          https://docs.joomla.org/What_version..._you_use%3F/fr

          Pour les pré-requis des versions :
          https://www.joomla.fr/afuj/item/1468...es-pour-joomla

          Pour les mises a jour :
          http://aide.joomla.fr/telechargement...our-joomla-2-5

          Attention, faire une sauvegarde avant toute action sur le site
          Je sais que c'est un peu suicidaire, le site est une vieillerie. C'est même moi qui l'ait fait remarquer à notre manager. Malheureusement, notre manager a décidé de ne faire que de petites modifications pas trop profondes uniquement par rapport à la structure des onglets et au contenu.

          C'est pourquoi je voudrais juste réarranger le menu pour le rendre plus propre, sans pour autant devoir refaire tout le site (ce qui n'est pas dans mes compétences)

          De plus, je ne sais pas les implications d'une telle mise à jour et n'étant pas le concepteur initial du site (ni son hébergeur), je ne sais pas si j'en ai les droits.

          N'y aurait-il pas une option pour rendre ce menu plus esthétique, plus structuré sans pour autant devoir refaire tout ?

          Commentaire


          • #6
            Re : Menu déroulant /!\

            Dès que l'hébergeur fera disparaître l'ancienne version de PHP sur laquelle tourne le site pour y installer une version récente, ce site sera définitivement hors service. Il faut que le manager le sache !
            Il n'y a pas eu de version 1.8, je pense donc que c'est une version 1.5 : pour moi aussi, c'est suicidaire d'y rester.
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              Envoyé par RobertG Voir le message
              Dès que l'hébergeur fera disparaître l'ancienne version de PHP sur laquelle tourne le site pour y installer une version récente, ce site sera définitivement hors service. Il faut que le manager le sache !
              Il n'y a pas eu de version 1.8, je pense donc que c'est une version 1.5 : pour moi aussi, c'est suicidaire d'y rester.
              C'est pourtant ce qu'il est écrit en haut à droite dans l'interface administrateur : "version 1.8"...

              Je ne m'y connais que tres tres peu dans le domaine et j'avoue que c'est un peu du chinois !
              Le concepteur du site (qui l'a conçu il y a des années) est un web designer externe à notre entreprise et c'est également lui qui l'héberge (si j'ai bien compris) sur son serveur.

              Je ne sais pas quand le site sera définitivement hors service, cependant je sais que j'ai jusqu'à la fin de la semaine pour le rendre plus structuré, plus propre et refaire son contenu.

              Commentaire


              • #8
                Re : Menu déroulant /!\

                Il n'y a pas eu de version 1.8, je pense donc que c'est une version 1.5 : pour moi aussi, c'est suicidaire d'y rester.
                je me disais aussi, tiens 1.8 ?
                envoies une capture de la page accueil de ton backend qu'on puisse voir à quoi ça ressemble, si c'est du 1.5 ou autre
                Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
                http://www.template-creator.com Outil de création de templates
                Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

                Commentaire


                • #9
                  Re : Menu déroulant /!\

                  Envoyé par ced1870 Voir le message
                  je me disais aussi, tiens 1.8 ?
                  envoies une capture de la page accueil de ton backend qu'on puisse voir à quoi ça ressemble, si c'est du 1.5 ou autre
                  Je n'y ai pas accès dans l'immédiat. Mais ça ressemble presque exactement à celle-ci :
                  Cliquez sur l'image pour l'afficher en taille normale

Nom : joomla-1_5-1-580x258.jpg 
Affichages : 1 
Taille : 19,1 Ko 
ID : 1805651

                  En revanche, si on pouvait arrêter d'insister pour que je mette à jour Joomla () et m'aider à trouver une solution pour rendre l'affichage de mes sous-menu plus esthétique.

                  Comme je vous l'ai dit, je n'ai ni la permission, ni le temps, ni la mesure des conséquences d'une telle mise-à-jour.
                  Tout ce que je souhaiterais, c'est que mes sous-onglet du menu soient dans des cases comme les onglets normaux.
                  Un petit coup de main ?

                  Commentaire


                  • #10
                    Re : Menu déroulant /!\

                    Celle-ci est une version 1.5.22 ! Pas à jour non plus puisque la dernière 1.5 était la 1.5.26 parue en août 2012
                    Quant à insister pour la mise à jour, je préciserai simplement qu'il doit y avoir trois ans au moins que la maintenance de cette version 1.5 a été stoppée et je doute que tu trouves encore des gens susceptibles de répondre à ta problématique sur une si ancienne version.
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                    Commentaire


                    • #11
                      Re : Menu déroulant /!\

                      Comme je vous dis : mon interface
                      ressemble à celle-ci mais il est écrit version 1.8.

                      J'imagine qu'il suffit de modifier quelque chose dans le menu, mais je ne m'y connais pas assez

                      Commentaire


                      • #12
                        Re : Menu déroulant /!\

                        Cliquez sur l'image pour l'afficher en taille normale

Nom : images_joomlaadmin.jpg 
Affichages : 1 
Taille : 38,2 Ko 
ID : 1805652 Voilà, ça, c'est exactement l'interface que j'ai.

                        Quelle version j'utilise du coup ?

                        Quelle extension menu déroulant je pourrais télécharger qui serait compatible avec ma version de joomla ?

                        Commentaire


                        • #13
                          Re : Menu déroulant /!\

                          Quelle version j'utilise du coup ?
                          Quelle extension menu déroulant je pourrais télécharger qui serait compatible avec ma version de joomla ?
                          Ah ouais ... quand même ... c'est une version 1.0.2 ... cette version date de plus de 10 ans !
                          Va falloir te débrouiller sans extension ... c'est de la préhistoire !!!!
                          Dernière édition par manu93fr à 22/07/2016, 01h52
                          Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

                          Commentaire


                          • #14
                            Re : Menu déroulant /!\

                            Envoyé par manu93fr Voir le message
                            Ah ouais ... quand même ... c'est une version 1.0.2 ... c'est version date de plus de 10 ans !
                            Va falloir te débrouiller sans extension ... c'est de la préhistoire !!!!
                            Oui je m'en doutais un peu ... :/
                            Comment est-ce que je peux me débrouiller sans extension alors ?

                            HELP PLEASE

                            Commentaire


                            • #15
                              Re : Menu déroulant /!\

                              ah oui, là c'est du vieux de chez vieux, je vais pas insister sur la mise à jour car ça ne sert à rien (dans ton cas à résoudre ta demande), mais effectivement tu ne trouveras plus d'extension
                              va falloir editer ton template et ajouter les fonctionnalités à la main. Perso à ta place je ferais simplement un peu de css pour rendre joli et j'oublierais les effets d'ouverture au survol et tout
                              Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
                              http://www.template-creator.com Outil de création de templates
                              Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X