Bug du menu principal dès que j'installe un module.

Réduire
Ce sujet est fermé.
X
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Bug du menu principal dès que j'installe un module.

    Bonjour,
    Dès que j'installe un nouveau module sur mon site, le menu principal ne marche plus.
    A quoi cela peut être dû.

    Merci de votre assistance.

  • #2
    Re : Bug du menu principal dès que j'installe un module.

    Pourrais-tu préciser un peu ce qui se passe ? Parce que "le menu principal ne marche plus", c'est un peu succinct.
    Est-ce que ça se produit à l'installation d'un module spécifique ou quel que soit le module ?
    Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
    C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
    Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

    Commentaire


    • #3
      Re : Bug du menu principal dès que j'installe un module.

      Salut Lesoutier,
      Merci de ta réaction.
      Dès que j'installe un module, les liens du menu principal ne fonctionnent plus. Quand je clique sur un lien j'obtiens un diese #. Les sous-menus ne s'affichent plus non plus.
      Quelque soit le module installé, le menu principal ne fonctionne plus. Seul les modules natifs du template fonctionnent.

      Lien: http://avocats-valdemarne.com/Immobi...obilieres.html

      NB: sur la page d'accueil le slideshow est un module natif. Et le menu principal marche bien. Par contre sur le lien que j'ai fourni, le slideshow installé est un nouveau module qui fait que le menu principal ne fonctionne plus.
      Dernière édition par Slixis à 15/04/2014, 17h03

      Commentaire


      • #4
        Re : Bug du menu principal dès que j'installe un module.

        C'est très probablement un problème de conflit Javascript entre plusieurs extensions. À noter que pas mal de slideshows sont coutumiers du fait.
        Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
        C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
        Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

        Commentaire


        • #5
          Re : Bug du menu principal dès que j'installe un module.

          salut
          c'est un conflit javascript, essaies le plugin "jquery easy" pour résoudre ton souci, et essaies le en activant le mode "no conflict"
          sinon il faut demander au développeur du slideshow de t'aiguiller
          CEd
          Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
          http://www.template-creator.com Outil de création de templates
          Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

          Commentaire


          • #6
            Re : Bug du menu principal dès que j'installe un module.

            Bonjour

            Tu as créé un nouveau sujet pour expliquer le même problème et recevoir les mêmes réponses que celles que je t'ai faites... Es-tu plus avancé maintenant ?

            http://forum.joomla.fr/showthread.ph...67#post1012367

            Moi déjà dire que module slideshow de toi était KO; voilà, moi pas seul à dire ça maintenant...
            Christophe (cavo789)
            Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

            Commentaire


            • #7
              Re : Bug du menu principal dès que j'installe un module.

              Envoyé par ced1870 Voir le message
              salut
              c'est un conflit javascript, essaies le plugin "jquery easy" pour résoudre ton souci, et essaies le en activant le mode "no conflict"
              sinon il faut demander au développeur du slideshow de t'aiguiller
              CEd
              Salut ced1870,
              Tu viens de sauver mon emploi. Le plugin "Jquery easy" a désactivé le conflit. Mes Menus et sous-menus ne sont plus bloqués dès que je télécharge un nouveau module.
              Tout roule comme sur des rails......;
              Grand merci à toi, à Lesoutier, ainsi qu'à toi cavo789 (Même si toi pas toujours comprendre problème que moi il avait! ;-).
              Merci à tous et excellente journée. Je vais de ce pas liker vos fiches.

              Commentaire


              • #8
                Re : Bug du menu principal dès que j'installe un module.

                Envoyé par Slixis Voir le message
                Même si toi pas toujours comprendre problème que moi il avait! ;-).


                Ben, je pense que oui... Sauf que le plugin de Cédric à fait le boulot de correction du conflit qui, en l'absence de ce remède miraculeux, aurait dû être résolu par le développeur du module.
                Christophe (cavo789)
                Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

                Commentaire


                • #9
                  Re : Bug du menu principal dès que j'installe un module.

                  aurait dû être résolu par le développeur du module
                  dans un monde idéal oui
                  Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
                  http://www.template-creator.com Outil de création de templates
                  Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

                  Commentaire


                  • #10
                    Re : Bug du menu principal dès que j'installe un module.

                    Juste une simple correction et après le sujet est clos. Peut-être que cela servira à quelqu'un d'autre. Lol
                    Là où je dis que l'on ne se comprend toujours pas Cavo789, c'est que toi tu t'imagines que c'est le slideshow qui posait problème et qu'il fallait que je m'adresse au développeur. Or moi je pense que ce n'est pas le module en question, pour la bonne et simple raison qui est que le menu bloquait qu'importe le module que j'utilisais. Lesoutier me l'a fait préciser en début de discussion. Quelque soit le module que j'installais, pas seulement le slideshow (faut bien saisir cette info importante), le menu et les sous-menus se bloquaient.
                    Si je suis ta logique, c'est-à-dire contacter le développeur du slideshow, cela voudrait signifier que pour les autres modules aussi qu'il me faudrait installer dans le futur, je serais à chaque fois obliger de demander aux développeurs de ces modules, de les paramétrer pour mon site puisque tous font bugger mon menu.
                    J'ai testé le slideshow incriminé sur un autre site et il fonctionnait très bien. Ce qui veut dire que le module ne pose pas problème, mais qu'il existe sur mon site un script qui empêchaient les modules de s'installer normalement.
                    Tu n'as pas saisi qu'il ne s'agit pas que d'un seul module, mais que le problème se passait avec tous les modules que j'essayais d'installer. J'ai essayé d'installer un module accordéon: Le menu se bloque. J'essaie un module Tab: le menu se bloque.
                    Cela signifie que pour le module accordeon ou le module Tab, la solution serait de contacter les développeurs?
                    Personnellement je pense que c'était un problème interne au site. ET le tout est rentré dans l'ordre, grâce à toi aussi car tu m'as bien orienté vers un souci de script. J'espère que l'on se comprend. Vive la communauté Joomla.
                    Dernière édition par Slixis à 16/04/2014, 11h00

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X