mauvaise manip et problèmes

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] mauvaise manip et problèmes

    Bonjour,

    En me fiant au guide des débutant pour joomla 2.5. je pense avoir fait une mauvaise manip et aimerai bien rattraper cette erreur.
    Dans le paragraphe "paramètre serveur" il est écrit:
    Tous les paramètres Serveur sont les mêmes que dans Joomla 1.5. Néanmoins, je mentionnerais
    l'option Forcer SSL. Cette option attire de plus en plus d'attention. Vous pouvez offrir à vos utilisateurs un
    trafic entièrement sécurisé. Il est nécessaire d'avoir SSL configuré dans votre serveur web et vous aurez
    besoin d'un certificat SSL.

    Je fait donc comme c'est: Forcer le SSL: administration et site et depuis je ne parviens plus a acceder au site ni a phpMyadmin.
    Je passe par wamp et même par là impossible de faire quoi que se soit.

    Quelqu'un peut-il m'aider???

    Merci

  • #2
    Re : mauvaise manip et problèmes

    Comme tu l'as toi-même cité :
    Il est nécessaire d'avoir SSL configuré dans votre serveur web et vous aurez
    besoin d'un certificat SSL.
    Et manifestement, ton serveur est peut-être correctement configuré pour SSL, mais tu n'as aucun certificat.

    Ouvre ton fichier de configuration avec un éditeur basique ou mieux notepad++ et mets cette variable à "0" :
    public $force_ssl = '0';
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Re : mauvaise manip et problèmes

      Merci beaucoup pour cette réponse si rapide. Je l'enregistre ou cette variable, du moins dans quel dossier exactement?

      Encore merci pour votre aide si précieuse sur ce site.

      Commentaire


      • #4
        Re : mauvaise manip et problèmes

        Je l'enregistre ou cette variable, du moins dans quel dossier exactement?
        Tu la laisses là où elle se trouve, dans le fichier configuration.php, à la racine du site.
        Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
        C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
        Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

        Commentaire


        • #5
          Re : mauvaise manip et problèmes

          Ça ne fonctionne pas. J'ai beau faire localhost/sitejoomla/administrator...rien

          Pfffffff je suis gourde parfois .....et on ne rigole pas SVP

          Commentaire


          • #6
            Re : mauvaise manip et problèmes

            Est-ce que tu as modifié le fichier "configuration.php" ?
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              Re : mauvaise manip et problèmes

              non je n'ai rien modifié

              Commentaire


              • #8
                Re : mauvaise manip et problèmes

                alors voila en essayant de faire ma tete de mule et de bien comprendre j'ai ouvert le dossier configuration.php et j'y ai inclue cette ligne. voici le résultat lorsque je me connecte:

                SCREAM: Error suppression ignored for
                ( ! ) Parse error: syntax error, unexpected 'public' (T_PUBLIC) in C:\wamp\www\sitejoomla\configuration.php on line 66
                Call Stack
                # Time Memory Function Location
                1 0.0015 260032 {main}( ) ..\index.php:0
                2 0.0353 286088 require_once( 'C:\wamp\www\sitejoomla\administrator\includes\fra mework.php' ) ..\index.php:21

                Commentaire


                • #9
                  Re : mauvaise manip et problèmes

                  La ligne existait déjà, avec "1" comme paramètre ! Pourquoi avoir ajouté une ligne ?
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                  Commentaire


                  • #10
                    Re : mauvaise manip et problèmes

                    Bonjour Robert G
                    Donc en y regardant de plus près il y avait bien cette ligne en double.
                    J'ai enlevé celle qui a été rajoutée et mise la 1ereen "0" comme il était préconisé en début de sujet.
                    Mais voila je ne peux toujours pas avoir accès au site.
                    Je m'excuse de vous embêter comme ça mais je suis totalement néophyte en conception de site et j’apprends sur le tas.
                    C'est pas facile mais ça me plait et c'est en faisant des erreurs qu'on apprend le mieux.
                    En attendant merci de prendre du temps pour moi.

                    Commentaire


                    • #11
                      Re : mauvaise manip et problèmes

                      Et si je supprimais tout simplement le tout et que que recommençais.... ça ne serai pas mieux??
                      Au moins je repartirais de zéro et pourrais continuer sans faire d'erreur.

                      Commentaire


                      • #12
                        Re : mauvaise manip et problèmes

                        c'est encore moi.....personne ne répond mais je continue a chercher quand même.
                        Donc je résume:
                        L'accès à PHPmyadmin est refusé
                        http://localhost/phpmyadmin/
                        l'accès a mon site joomla est refusé
                        http://localhost/sitejoomla/

                        bref plus rien ne fonctionne, je ne trouve de réponse dans aucun des post sur le forum......que me conseillez vous? un réinitialisation complète, un acharnement (pas vraiment thérapeutique pour mes neurones) ou un abandon total sachant que mon boss attend la réalisation de son site????, d'autant plus que je suis en pleine construction j'avais pas mal avancée.

                        AIDEZ MOIIIIIIII SVP

                        MERCI

                        Commentaire


                        • #13
                          Re : mauvaise manip et problèmes

                          Si l'accès à phpMyAdmin est refusé, c'est que tu as un problème de serveur : première chose à voir, qui n'a rien à voir avec le site et Joomla!.
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                          Commentaire


                          • #14
                            Re : mauvaise manip et problèmes

                            Bonjour robert G,
                            Bonne nouvelle du jour phpmyadmin est de nouveau en service....
                            j'ai tout simplement désinstaller wamp complètement pour le réinstaller proprement.
                            par contre si je veux aller sur le site toujours en construction voici ce que j'ai:
                            ( ! ) SCREAM: Error suppression ignored for
                            ( ! ) Parse error: syntax error, unexpected end of file, expecting function (T_FUNCTION) in C:\wamp\www\sitejoomla\configuration.php on line 67
                            Call Stack
                            # Time Memory Function Location
                            1 0.0120 260128 {main}( ) ..\index.php:0
                            2 0.0274 286168 require_once( 'C:\wamp\www\sitejoomla\administrator\includes\fra mework.php' ) ..\index.php:21

                            je n'ai plus du tout accès a l'administration de mon site.
                            comme j'ai une énorme confiance en vous je suis sure que vous allez me proposer une solution
                            en attendant un grand merci à vous.

                            Commentaire


                            • #15
                              Re : mauvaise manip et problèmes

                              un petit up

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X