Connexion à administration renvoie en frontend

Réduire
Ce sujet est fermé.
X
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Connexion à administration renvoie en frontend

    Bonjour à tous.

    Voilà l'histoire :

    Le site est en 2.5.9. Je sais, je sais, j'ai sauté des étapes. C'est pour cela que je veux faire une répétition générale en local avant de refaire les manips sur le serveur de prod, au cas où...

    J'ai sauvegardé ce site en production avec Akeeba, importé en local (wamp), et redéployé avec kickstart : aucune alerte pendant la manœuvre.
    J'ai viré .htaccess et modifie la ligne $sef_rewrite = '0'; dans configuration.php comme j'ai fait 10000 fois (au moins).
    Le frontend fonctionne correctement.
    Lorsque j'appelle la page de connexion à l'administration, elle apparait correctement.
    Je rentre identifiant et mot de passe.
    Je n'ai pas de signal d'erreur mais je me retrouve sur le frontend, dans une page qui n'existe pas.

    Ca fait 2 jours que je tourne et retourne le problème dans tous les sens, sans trouver la faille.
    Avant de me jeter dans un lac du 3e étage avec une corde au cou, je fais appel à vos avis éclairés.
    Merci d'avance.

  • #2
    Re : Connexion à administration renvoie en frontend

    Bjr,

    Tu n'aurais pas installé un plugin de sécurité sur l'administration, genre jSecure ?

    Commentaire


    • #3
      Re : Connexion à administration renvoie en frontend

      Envoyé par R.Volfoni Voir le message
      Tu n'aurais pas installé un plugin de sécurité sur l'administration, genre jSecure ?
      Eh non !

      Pour info : le site original en prod est bilingue... si ceci peut expliquer cela...

      Commentaire


      • #4
        Re : Connexion à administration renvoie en frontend

        Regarde dans les logs ça aide parfois.

        Commentaire


        • #5
          Re : Connexion à administration renvoie en frontend

          Envoyé par klin34970 Voir le message
          Regarde dans les logs ça aide parfois.
          J'ai rien dans les logs du site ni dans ceux d'Apache.

          Le site n'étant pas très volumineux en terme de pages et extensions, j'envisage de le rebâtir de 0 pour avoir une version saine en local et d'uploader tout ça au moyen d'Akeeba.
          De quoi occuper un 11 novembre pluvieux...

          Commentaire


          • #6
            Re : Connexion à administration renvoie en frontend

            As tu essayais htp://site/administrator/index.php ?

            Commentaire


            • #7
              Re : Connexion à administration renvoie en frontend

              Envoyé par klin34970 Voir le message
              As tu essayais htp://site/administrator/index.php ?
              Déjà essayé... sans succès...

              Commentaire


              • #8
                Re : Connexion à administration renvoie en frontend

                Peut tu mettre ton fichier configuration.php et verifier les chemins des logs et tmp.


                Sent from my iPhone using Forum Joomla.fr mobile app

                Commentaire


                • #9
                  Re : Connexion à administration renvoie en frontend

                  Bonjour,

                  Puisque le site est en local, il y a un accès complet aux logs apache, qui permettraient de comprendre ce qui se passe.

                  Dans configiuration.php, changer
                  Code PHP:
                      public $error_reporting 'development'
                  et retester en suivant avec un outil genre tail (http://tailforwin32.sourceforge.net/ si sous Windows) le error.log apache.

                  Le souci provient probablement d'une redirection involontaire, ou du plugin système recaptcha qui serait activé (et ne fonctionne pas correctement en local)
                  Pas de demande de support par MP.
                  S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                  Commentaire


                  • #10
                    Re : Connexion à administration renvoie en frontend

                    Pour ma part si les chemin ne sont pas bon j'ai eu se genre de réaction. Lors du login page d'erreur 500 ou le renvois au frontend suivant les config d'apache ou nginx.

                    Commentaire


                    • #11
                      Re : Connexion à administration renvoie en frontend

                      Envoyé par jisse03 Voir le message
                      Dans configiuration.php, changer
                      Code PHP:
                          public $error_reporting 'development'
                      Maintenant, la page de connexion affiche cette erreur :
                      SCREAM: Error suppression ignored for
                      Strict standards: Declaration of JCacheControllerPage::store() should be compatible with that of JCacheController::store() in C:\wamp\www\bogues2\libraries\joomla\cache\control ler\page.php on line 199

                      Et lorsque je me connecte, la page du frontend appelée par erreur affiche tout un tas d'erreurs :
                      Strict standards: Declaration of JCacheControllerPage::store() should be compatible with that of JCacheController::store() in C:\wamp\www\bogues2\libraries\joomla\cache\control ler\page.php on line 199

                      Notice: Undefined property: JSite::$registeredurlparams in C:\wamp\www\bogues2\libraries\joomla\cache\cache.p hp on line 639

                      SCREAM: Error suppression ignored for
                      Strict standards: Non-static method JSite::getMenu() should not be called statically in C:\wamp\www\bogues2\components\com_gmapfp\router.p hp on line 16

                      SCREAM: Error suppression ignored for
                      Strict standards: Non-static method JApplication::getMenu() should not be called statically in C:\wamp\www\bogues2\includes\application.php on line 539

                      SCREAM: Error suppression ignored for
                      Strict standards: Only variables should be assigned by reference in C:\wamp\www\bogues2\components\com_gmapfp\router.p hp on line 16

                      SCREAM: Error suppression ignored for
                      Strict standards: Only variables should be assigned by reference in C:\wamp\www\bogues2\components\com_gmapfp\router.p hp on line 20

                      Je n'ai recopié que l'intitulé des erreurs.
                      Le fichier apache error log généré est ici ->http://michelp.fr/michelp/afac/apach...%20log%201.txt

                      Peut tu mettre ton fichier configuration.php et verifier les chemins des logs et tmp.
                      Les chemins sont bons mais rien dans le dossier des logs.

                      Commentaire


                      • #12
                        Re : Connexion à administration renvoie en frontend

                        Le problème semble lié à GMapFP.
                        Commences par vider manuellement les caches (en racine_site/cache et racine_site/administrator/cache) SAUF le fichier index.html présent dans chacun des 2.

                        Via phpMyAdmin, dans la table #__extensions, rechercher tout ce qui concerne gmapfp et désactiver (passer enabled à 0)

                        Ensuite, la connexion devrait fonctionner. Rechercher s'il n'y a pas de mise à jour de gmapfp pour remplacer cette version.
                        Pas de demande de support par MP.
                        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                        Commentaire


                        • #13
                          Re : Connexion à administration renvoie en frontend

                          Ok.
                          Je viens de faire tout ça mais pas de changements.
                          Fichier d'erreur ici -> http://michelp.fr/michelp/afac/apach...%20log%202.txt

                          Commentaire


                          • #14
                            Re : Connexion à administration renvoie en frontend

                            La dernière erreur indique toujours un appel à com_gmapfp.
                            Pas de demande de support par MP.
                            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                            Commentaire


                            • #15
                              Re : Connexion à administration renvoie en frontend

                              Bon. Ce n'est pas grave si ça continue à m... : J'aurai aussi vite fait de rebâtir le site qui n'est pas gigantesque du tout. J'ai une sauvegarde plus ancienne qui elle fonctionne.

                              Je n'aurai qu'à compléter ce qui manque au niveau des articles (que j'irai chercher dans le site en prod qui lui, marche), rapatrier par ftp les fichiers css du template et finir par les mises à jour de Joomla et des extensions.

                              En tout cas, merci à tous de vous être penché sur mon problème. Cette entraide fait chaud au cœur !

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X