Site HS après supression d'extensions

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Site HS après supression d'extensions

    Bonjour,
    Pensant bien faire, j'ai voulu faire un peu de ménage dans mes extensions.
    En effet, beaucoup de templates inutiles et modules venaient alourdir la gestion de ceux dont je me sert effectivement. Peu être une erreur de débutant, peut-être un clic qui a glissé mais résultat après désinstallation, une nouvelle page s'est ouverte avec le message :

    jVS [0001] - Une erreur s'est produite
    JVS_ERROR_FAILED_TO_LOAD_JOOMESSLIBRARY


    Depuis, impossible de me connecter à l'interface admin, et le site n'est plus accessible.
    Je pense avoir supprimé quelque chose de vital.

    J'espère qu'il existe une astuce pour recharger un module que j'aurais supprimé, ou un template administrator... J’aimerais en tout cas éviter de tout refaire... (articles/menus et liens menus/modules/etc.)

    De mémoire, le site est sous joomla 2.5 et hébergé chez 1&1


    Dans l'attente de vos suggestions, je souhaite à tout le monde une bonne après-midi et un bon week-end.

  • #2
    Bonjour et bienvenue sur le forum,

    Le gros problème c'est que tu ne sais pas toi-même ce qui a causé ton problème. Vu de l'extérieur la leule chose qu'on puisse affirmer c'est que tu as désinstallé quelque chose qu'il ne fallait pas désinstaller. Mais j'imagine que ça ne t'avance pas beaucoup
    J'imagine aussi (mais j'espère me tromper) que tu n'as pas fait de sauvegarde de ton site avant de te lancer dans ton opération de nettoyage. Si par hasard tu as une sauvegarde récente je te conseille de la restaurer pour revenir à la situation précédente. Il t faudra alors procéder à petits pas : tu fais une sauvegarde, tu supprimes une extension, tu testes ton site, tu fais une nouvelle sauvegarde puis tu supprimes une nouvelle extension et tu testes ton site et ainsi de suite jusqu'à épuisement des extensions.
    Si tu n'as pas de sauvegarde potable, il va falloir envisager de remplacer le core de Joomla.
    Pour cela il va falloir par ftp transférer un pack d'installation de Joomla sans le répertoire install et strictement de la même version que celle actuellement en place.
    Lorsque l'on se cogne la tête contre un pot et que cela sonne creux, ça n'est pas forcément le pot qui est vide.
    Confucius

    Commentaire


    • #3
      Envoyé par lesoutier Voir le message
      Pour cela il va falloir par ftp transférer un pack d'installation de Joomla sans le répertoire install et strictement de la même version que celle actuellement en place.
      Merci pour ta réactivité !

      Effectivement, je crois que c'est ce qu'il me reste à faire.
      Avant de refaire une erreur "fatale" peux-tu me confirmer la procédure à suivre ?
      - extraire le fichier "Joomla_2.5.28-Stable-Full_Package_French_v2"
      - copier et transférer par FTP le pack extrait sans le dossier "Installation"
      - croiser les doigts...

      ???

      Dernière édition par Gadjé-Voyageurs à 31/08/2018, 16h01

      Commentaire


      • #4
        Et éventuellement bruler un cierge à Ste Rita, patronne des causes perdues

        Sinon la procédure est la bonne. Mais si c'est une extension externe à Joomla ça ne va rien changer
        Lorsque l'on se cogne la tête contre un pot et que cela sonne creux, ça n'est pas forcément le pot qui est vide.
        Confucius

        Commentaire


        • #5
          Bonjour,
          à mon avis, 1&1 fait des sauvegardes régulières FTP et Base de donnée (du même jour!)
          il peut être intéressant de les contacter pour qu'il te donne une procédure ... par contre il ne faut pas trop tarder ... car ces sauvegardes sont automatiques
          Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

          Commentaire


          • #6
            Bonsoir,
            après quelques sueurs froides, un coup de fil à 1&1 (super efficace) et une petite heure de manip' à restaurer et uplauder la restauration de 1&1, et magie, tout est ok, interface admin et site !
            Merci à vous en tout cas pour vos idées de résolutions !

            Commentaire


            • #7
              ok mais tout n'est pas réglé ...
              si j'ai tout compris ton site est resté en 2.5 ... pas bien pour la sécurité du site
              ... va falloir penser sérieusement a le passer en version 3 non ?
              Et par la même occasion; installe l'extension Akeeba Backup pour faire des sauvegardes complètes du site ...
              ça t'évitera les "sueurs froides" à l'avenir
              Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

              Commentaire

              Annonce

              Réduire
              Aucune annonce pour le moment.

              Partenaire de l'association

              Réduire

              Hébergeur Web PlanetHoster
              Travaille ...
              X