Problème après Maj vers 2.0.4

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème après Maj vers 2.0.4

    Bonjour,
    belle galère avec virtuemart qui n'en finie pas!
    deja avec la 2.0.2 je ne m'en sortais pas trop, y a la mise à jour 2.0.4 qui me pose encore plus de problèmes.
    Au passage, si quelqu'un peux nous expliquer l'histoire des dossiers à créer, voici le message que j'ai eu après la mise à jour:
    Code:
    Attention, le Chemin vers les médias de produits à vendre est vide. Pour des raisons de sécurité, il est très important de créer un dossier dans un chemin non accessible par une URL. Créer aussi un dossier pour les les factures de stocker vos données sensibles en sécurité. Notre chemin est suggéré pour votre système d' /homez.22/monsite/vmfiles
    Pour ma pars, je rencontre 2 problèmes après la màj, le premier est quand je vais dans le panier il n y a aucun prix affiché, voir photo:



    Mon 2ème problème, au cliquant sur confirmer la commande,la page de confirmation s'affiche avec les détails de la commande, mais en bas de page j'ai ce message d'erreur:
    Code:
    Warning: require(__DIR__/invoice_items.php) [function.require]: failed to open stream: No such file or directory in /homez.22/*****/monsite/components/com_virtuemart/views/invoice/tmpl/mail_html_pricelist.php on line 22
    
    Fatal error: require() [function.require]: Failed opening required '__DIR__/invoice_items.php' (include_path='.:/usr/local/lib/php') in /homez.22/*****/monsite/components/com_virtuemart/views/invoice/tmpl/mail_html_pricelist.php on line 22
    Si quelqu'un peux m'aider à regler ces problème, ou sinon je remets ma sauvegarde de la version 2.0.2.
    Belle galère, non?
    Merci par avance.
    Dernière édition par steeve34 à 10/04/2012, 16h09
    http://www.allo34.com

  • #2
    Re : Problème après Maj vers 2.0.4

    Personne n'a eu ce problème?
    Personne pour nous aider?!!
    http://www.allo34.com

    Commentaire


    • #3
      Re : Problème après Maj vers 2.0.4

      Après 1 longue journée de recherche, il s'avère que l'équipe Virtuemart a changé le code pour le panier, donc il faut certainement une mise à jour du template utilisé.
      http://www.allo34.com

      Commentaire


      • #4
        Re : Problème après Maj vers 2.0.4

        Merci pour ta réponse. Mais que faut il faire en attendant ?

        Commentaire


        • #5
          Re : Problème après Maj vers 2.0.4

          Envoyé par callisto51 Voir le message
          Merci pour ta réponse. Mais que faut il faire en attendant ?
          Bonjour,
          d'ailleurs je ne sais meme pas si c'est vraiment à cause du template, car meme en changeant le template je tombe sur l'erreur
          Code:
          Warning: require(__DIR__/invoice_items.php) [function.require]: failed to open stream: No such file or directory in /homez.22/****/monsite/components/com_virtuemart/views/invoice/tmpl/mail_html_pricelist.php on line 22
          
          Fatal error: require() [function.require]: Failed opening required '__DIR__/invoice_items.php' (include_path='.:/usr/local/lib/php') in /homez.22/****/monsite/components/com_virtuemart/views/invoice/tmpl/mail_html_pricelist.php on line 22
          ça doit venir de virtuemart, parce qu'avec la 2.0.2 tout fonctionnait très bien!.
          Et il n y a personne pour nous aider.
          http://www.allo34.com

          Commentaire


          • #6
            Re : Problème après Maj vers 2.0.4

            je suis repassé a 2.02 en attendant le correctif...
            Ca fonctionne très bien d'ailleurs ... j'ai lu sur forum GB virtuermart qu'on est pas les seuls dans ce cas.

            Commentaire


            • #7
              Re : Problème après Maj vers 2.0.4

              Envoyé par callisto51 Voir le message
              je suis repassé a 2.02 en attendant le correctif...
              Ca fonctionne très bien d'ailleurs ... j'ai lu sur forum GB virtuermart qu'on est pas les seuls dans ce cas.

              Oui, apparemment, je repasse aussi a 2.0.2 .
              http://www.allo34.com

              Commentaire


              • #8
                Re : Problème après Maj vers 2.0.4

                Oui, apparemment, je repasse aussi a 2.0.2
                Mais serrez les fesses, comme il y a un beau "trou" dans cette version, vos sites risques d'être la proie des malveillants. Sous les nombreux sites que j'héberge il y a une recrudescence d'attaques avec com_virtuemart en mots clés dans les logs!

                Commentaire


                • #9
                  Re : Problème après Maj vers 2.0.4

                  Envoyé par zepelin57 Voir le message
                  Mais serrez les fesses, comme il y a un beau "trou" dans cette version, vos sites risques d'être la proie des malveillants. Sous les nombreux sites que j'héberge il y a une recrudescence d'attaques avec com_virtuemart en mots clés dans les logs!
                  C'est vrai qu'il y a un risque, mais mon site est en tout début de construction, et ça urge car il reste beaucoup de travail à faire.
                  Si je passe en 2.0.4, je vais rester les bras croisés en attendant un correctif de chez Gavick.
                  Je pense que je vais prendre le risque de travailler avec la 2.0.2 pour avancer mon projet, à moins que vous me le déconseillez vivement?, en connaissant pas l'importance du risque!!.
                  Merci pour la réponse.
                  http://www.allo34.com

                  Commentaire


                  • #10
                    Re : Problème après Maj vers 2.0.4

                    Si le site n'est pas en prod, tu peux éventuellement continuer à bosser dessus. Je pense que l'équipe de VM c'est retrouvé prise de cours avec ce trou sur la 2.0.2 et à vite sortie une 2.0.4. Il me semble qu'il travaillait sur la 2.0.3 quand c'est arrivé.

                    Maintenant, je ne travaille pas avec VM, donc difficile de t'en dire plus, là j'intervenais pour l'aspect sécurité

                    Commentaire


                    • #11
                      Re : Problème après Maj vers 2.0.4

                      Envoyé par zepelin57 Voir le message
                      Si le site n'est pas en prod, tu peux éventuellement continuer à bosser dessus. Je pense que l'équipe de VM c'est retrouvé prise de cours avec ce trou sur la 2.0.2 et à vite sortie une 2.0.4. Il me semble qu'il travaillait sur la 2.0.3 quand c'est arrivé.

                      Maintenant, je ne travaille pas avec VM, donc difficile de t'en dire plus, là j'intervenais pour l'aspect sécurité
                      Merci beaucoup pour la réponse,
                      donc pas gros risque pour moi, je continue en 2.0.2 en faisant des sauvegardes journalières.
                      http://www.allo34.com

                      Commentaire


                      • #12
                        Re : Problème après Maj vers 2.0.4 mail_html_pricelist.php

                        Bonjour,

                        J'ai eu le même problème et ai essayé cette solution qui suit et ça fonctionne :

                        on line 22 :
                        /components/com_virtuemart/views/invoice/tmpl/mail_html_pricelist.php

                        remplacer :
                        require(__DIR__.'/invoice_items.php');

                        par :
                        require('invoice_items.php');

                        Le client reçoit le mail de commande et les administrateurs aussi.

                        Solution trouvée grâce à "corump" un forumeur virtuemart, alors un grand merci à lui

                        Et vous cela fonctionne t il avec cette solution ?

                        Pour ma part, oui.

                        à bientôt

                        christelle
                        Dernière édition par chris99 à 13/04/2012, 11h46

                        Commentaire


                        • #13
                          Re : Problème après Maj vers 2.0.4

                          Tiens! je vais tester de suite .
                          ___________________________________

                          Edit: cool, ça m'a réglé le problème d'erreur à la commande, il ne me reste que le problème d'affichage du prix qui manque dans le panier, mais ça, je pense que c'est un problème de template, j'attends qu'il soit mis à jour.
                          Merci Chris99 pour l'astuce .
                          Dernière édition par steeve34 à 13/04/2012, 10h44
                          http://www.allo34.com

                          Commentaire


                          • #14
                            Re : Problème après Maj vers 2.0.4

                            Super

                            Tu peux peut être mettre "réglé"

                            Ca aidera pour les recherches

                            à bientôt

                            Christelle

                            Commentaire


                            • #15
                              Re : Problème après Maj vers 2.0.4

                              C'est fait! merci.
                              http://www.allo34.com

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X