erreur aprés migration VM 1.1.9 vers 2.0.6

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] erreur aprés migration VM 1.1.9 vers 2.0.6

    Bonjour à tous,

    J'ai effectuer une migration de virtuemart 1.1.9 vers 2.0.6. Ok pour les catégories, produits et autres configurations.

    Cependant il me reste 2 erreurs à résoudre :

    - en front-end il y à cette erreur : vmError: $link["view"] is empty ( je n'arrive pas à comprendre ce qui est vide comme cette erreur l'indique). Nota, cette erreur est répétée sur 27 lignes tout en haut des listes de produits et catégories.

    - en back-end il y à celle la : vmError: Couldnt resolve mime images/stories/virtuemart/product/psp.png sur fond rouge. Pourtant j'ai bien transféré les images produits dans images/stories/virtuemart/product/ et utilisé les outils de migration et de synchronisation des médias.

  • #2
    Re : erreur aprés migration VM 1.1.9 vers 2.0.6

    Salut,

    As-tu résolu ton problème car avec la mise à jour 2.0.10 de virtuemart, la même erreur m'est apparu ?
    (en ce qui concerne l'erreur vmError: $link["view"] is empty )

    Commentaire


    • #3
      Re : erreur aprés migration VM 1.1.9 vers 2.0.6

      salut Babid,

      Malheureusement non, j'ai abandonné la migration et reconstruit le tout, ça m'a pris un peu de temps mais au moins il y a plus d'erreur.

      Commentaire


      • #4
        Re : erreur aprés migration VM 1.1.9 vers 2.0.6

        Bonsoir,

        Concernant ces erreurs:

        "- en front-end il y à cette erreur : vmError: $link["view"] is empty ( je n'arrive pas à comprendre ce qui est vide comme cette erreur l'indique). Nota, cette erreur est répétée sur 27 lignes tout en haut des listes de produits et catégories."

        Il s'agit d'un problème qui se produit a priori uniquement avec le compte administrator et lorsqu'on est connecté. Il me semble qu'il est aussi lié à la fonction " sef activée" de virtuemart.


        "- en back-end il y à celle la : vmError: Couldnt resolve mime images/stories/virtuemart/product/psp.png sur fond rouge. Pourtant j'ai bien transféré les images produits dans images/stories/virtuemart/product/ et utilisé les outils de migration et de synchronisation des médias."

        J'ai rencontré ce problème lors de la migration en local. Il s'agit d'un problème de droit. Il faut prendre la bonne version de xampp ou sinon tenter le transfert directement sur le site distant

        Bon courage à vous

        Commentaire


        • #5
          Re : erreur aprés migration VM 1.1.9 vers 2.0.6

          Envoyé par Hamid71 Voir le message
          Bonsoir,

          J'ai rencontré ce problème lors de la migration en local. Il s'agit d'un problème de droit. Il faut prendre la bonne version de xampp ou sinon tenter le transfert directement sur le site distant

          Bon courage à vous
          Bonjour merci Hamid71 ,

          J'ai mis les droits nécessaires et cette migration à été faite directement sur le serveur distant de même pour le transfert d'images, bref, je n'ai plus de problème la dessus car j'ai tout reconstruit manuellement avec la dernière version de VM.

          lorsque je travail en local je ne suis pas sous xampp mais wamp, ce qui pose moins de problème selon moi.

          Commentaire

          Annonce

          Réduire
          1 sur 2 < >

          C'est [Réglé] et on n'en parle plus ?

          A quoi ça sert ?
          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
          Comment ajouter la mention [Réglé] à votre discussion ?
          1 - Aller sur votre discussion et éditer votre premier message :


          2 - Cliquer sur la liste déroulante Préfixe.

          3 - Choisir le préfixe [Réglé].


          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

          2 sur 2 < >

          Assistance au forum - Outil de publication d'infos de votre site

          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

          UTILISER À VOS PROPRES RISQUES :
          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

          Problèmes connus :
          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

          Installation :

          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

          Archive zip : https://github.com/AFUJ/FPA/zipball/master

          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
          et remplacer www. votresite .com par votre nom de domaine


          Exemples:
          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/
          Pour executer le script: http://www..com/fpa-fr.php

          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/cms/
          Pour executer le script: http://www..com/cms/fpa-fr.php

          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
          Voir plus
          Voir moins
          Travaille ...
          X