VM problème d'affichage de la page produit

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • VM problème d'affichage de la page produit

    Bonjour,

    J'ai un petit souci d'affichage sur la fiche produit.
    Je suis sous VM 2.0.20b.
    Lorsque ma fiche produit s'affiche, j'ai un petit "1" qui se balade en haut à gauche.
    J'ai regardé dans la description de mon produit, il n'y a rien, ni dans ma page \html\com_virtuemart\views\productdetails\tmpl.
    J'utilise Firebug, mais çà ne m'a rien indiqué non plus

    Je vous joins une capture écran pour mieux y voir !

    Si quelqu'un peut m'aider...

    Merci d'avance pour votre aide

    Nathalie

  • #2
    Re : VM problème d'affichage de la page produit

    Bonjour,

    Êtes vous sûr que dans le fichier en question il n'y a pas de 1 tout en haut du fichier avant le <?php ou juste après ?
    Cela le fait pour tous les produits ?

    Des fois, ça m'arrive de faire CTRL+1 au lieu de CRTL+A et de sauvegarder (oui me demandez pas pourquoi ).

    PS : on ne peut pas voir le fichier joint ...

    Cdt
    Dernière édition par XdiZ à 26/04/2013, 19h00
    Besoin de debugguer votre site, pensez à Firebug : http://www.grafikart.fr/tutoriels/ht...ion-firefox-76
    Vous avez trouvé une solution, mettez votre discussion en [Réglé] ? http://forum.joomla.fr/announcement.php?f=58
    Je ne donne pas suite aux messages privés (MP) non sollicités !

    Commentaire


    • #3
      Re : VM problème d'affichage de la page produit

      Tout d'abord merci pour ta réponse si rapide
      J'ai en effet bien vérifié entre les balises php, d'autant que "oui" çà s'affiche sur toutes les pages produits. C'est vraiment étrange.
      Je remets ci-joint le lien vers la capture écran Cliquez sur l'image pour l'afficher en taille normale

Nom : site capture.jpg 
Affichages : 1 
Taille : 30,2 Ko 
ID : 1802741
      Bon j'espère que mon lien va marcher, je suis novice sur le forum

      Nathalie

      Commentaire


      • #4
        Re : VM problème d'affichage de la page produit

        Il faut vérifier avec Notepad++ ou un autre éditeur de ce type que tous les derniers fichiers que vous avez ouverts et/ou modidiés sont bien encodés en UTF-8 sans BOM.

        Avec Notepad++ > menu Encodage > UTF-8 sans BOM.
        Besoin de debugguer votre site, pensez à Firebug : http://www.grafikart.fr/tutoriels/ht...ion-firefox-76
        Vous avez trouvé une solution, mettez votre discussion en [Réglé] ? http://forum.joomla.fr/announcement.php?f=58
        Je ne donne pas suite aux messages privés (MP) non sollicités !

        Commentaire


        • #5
          Re : VM problème d'affichage de la page produit

          J'utilise CONTEXT, mais je ne trouve pas l'encodage. Je vais chercher !
          Merci pour l'info et je reviendrai, si çà ne donne rien.

          Merci bien

          Nathalie

          Commentaire


          • #6
            Re : VM problème d'affichage de la page produit

            Bon du coup j'ai installé Notepad ++, mon fichier était bien en UTF-8 sans BOM et aucun petit "1" se baladant. J'ai carrément fait une recherche pour voir où étaient les 1 et rien ne m'a semblé anormal.
            Auparavant j'ai travaillé sur l'affichage de la catégorie, j'ai également parcouru ma page mais de "1" suspect.

            Si quelqu'un a une suggestion...

            Merci à vous

            Nathalie

            Commentaire


            • #7
              Re : VM problème d'affichage de la page produit

              Remettre le fichier d'origine.
              Besoin de debugguer votre site, pensez à Firebug : http://www.grafikart.fr/tutoriels/ht...ion-firefox-76
              Vous avez trouvé une solution, mettez votre discussion en [Réglé] ? http://forum.joomla.fr/announcement.php?f=58
              Je ne donne pas suite aux messages privés (MP) non sollicités !

              Commentaire


              • #8
                Re : VM problème d'affichage de la page produit

                Bonjour,

                avez-vous un lien vers le site ?
                sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                http://virtuemart.fr

                Commentaire


                • #9
                  Re : VM problème d'affichage de la page produit

                  Bonjour,

                  Je fais un petit "up", car je n'ai toujours aucune explication à mon problème.
                  Du coup, pour répondre à PATSXM971, j'ai carrément mis le site sur mon hébergement, puisque jusqu'à là, je travaillais en local.
                  Là, on va dire que je l'ai mis en semi-production en le mettant dans un sous-répertoire.

                  Le lien vers le site est http://www.teclean.fr/testngST33920/index.php

                  Pour répondre également à XdiZ, j'ai remis le fichier d'origine et çà ne change rien !

                  Si quelqu'un avait une "révélation"...

                  Merci d'avance à vous

                  Nathalie

                  Commentaire


                  • #10
                    Re : VM problème d'affichage de la page produit

                    Bonjour,

                    essayez avec un template de base livré avec joomla et sans gantry

                    Où avez-vous téléchargé votre package Joomla ?

                    est-ce une bundle ?

                    A partir de quand avez-vous observé ce "1" ?

                    vous souvenez-vous des modifications que vous auriez apportées ?
                    sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                    http://virtuemart.fr

                    Commentaire


                    • #11
                      Re : VM problème d'affichage de la page produit

                      Testez ceci également :

                      dans la configuration de virtuemart, onglet boutique frontale, décochez les 3 premiers paramètres principaux et enregistrez
                      sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                      http://virtuemart.fr

                      Commentaire


                      • #12
                        Re : VM problème d'affichage de la page produit

                        Envoyé par PATSXM971 Voir le message
                        Bonjour,

                        essayez avec un template de base livré avec joomla et sans gantry

                        Où avez-vous téléchargé votre package Joomla ?

                        est-ce une bundle ?

                        A partir de quand avez-vous observé ce "1" ?

                        vous souvenez-vous des modifications que vous auriez apportées ?
                        J'ai essayé avec Beez, j'ai désactivé le plugin Gantry, et malheureusement j'ai toujours le 1.
                        J'ai téléchargé le package Joomla en même temps que mon template, directement depuis la plate-forme Rocketheme. Il s'agit d'une version "Rocketlauncher", c'est-à-dire une version comprenant la même configuration que la démo.

                        Je ne sais plus à partir de quand j'ai remarqué ce "1". A-t-il toujours été là et je ne m'en serais pas aperçue ? Je suis incapable de m'en souvenir.

                        Merci pour votre aide

                        Nathalie

                        Commentaire


                        • #13
                          Re : VM problème d'affichage de la page produit

                          et à propos de ceci ?

                          Envoyé par PATSXM971 Voir le message
                          Testez ceci également :

                          dans la configuration de virtuemart, onglet boutique frontale, décochez les 3 premiers paramètres principaux et enregistrez
                          sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                          http://virtuemart.fr

                          Commentaire


                          • #14
                            Re : VM problème d'affichage de la page produit

                            Bonjour,

                            Avec Firebug j'ai trouvé qu'il est dans le fichier productdetails-view productdetails, essayez peu etre
                            Fichiers joints
                            Novice à Joomla 2.5.14 - template beez5 - VM 2.0.22c avec ses composants, modules et plugings

                            Commentaire


                            • #15
                              Re : VM problème d'affichage de la page produit

                              Envoyé par hujing Voir le message
                              Bonjour,

                              Avec Firebug j'ai trouvé qu'il est dans le fichier productdetails-view productdetails, essayez peu etre
                              productdetails-view et productdetails sont des class CSS, ce ne sont pas des fichiers ...

                              Mais en effet, il faudrait rechercher ces 2 classes dans tous les fichiers de VM pour voir d'où ce 1 peut provenir.

                              Je mise une pièce pour un 1 tapé en dur .
                              Besoin de debugguer votre site, pensez à Firebug : http://www.grafikart.fr/tutoriels/ht...ion-firefox-76
                              Vous avez trouvé une solution, mettez votre discussion en [Réglé] ? http://forum.joomla.fr/announcement.php?f=58
                              Je ne donne pas suite aux messages privés (MP) non sollicités !

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X