image noire dans l'affichage Slideshow

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] image noire dans l'affichage Slideshow

    bonjour

    J'ai 1 problème avec l'affichage du slideschow (JA Slideshow Module) sur un template droid, voir sur le site :

    www.decoratrice-lille.fr/

    Il y a 6 images dans le dossier et il affiche parfois une image noire et bloque certaines images. C'est d'autant plus "tordu" que ce n'est pas systématique, parfois ca fonctionne.Quand ca ne fonctionne ça donne cela :

    Cliquez sur l'image pour l'afficher en taille normale

Nom : image noire.jpg 
Affichages : 1 
Taille : 58,7 Ko 
ID : 1815391

    Si quelqu'un à une idée, merci d'avance
    Fichiers joints
    Dernière édition par marc59160 à 15/04/2012, 11h05

  • #2
    Re : image noire dans l'affichage Slideshow

    Effectivement, j'ai le problème sous FF.
    As-tu tenté de retirer l'image qui ne veut pas s'afficher pour voir ? Y'a t'il un problème au niveau du nom de fichier ? De l'encodage du fichier lui même ?
    Essaye de réengistrer l'image qui peut potentiellement poser problème : http://www.decoratrice-lille.fr/imag...0_1200_280.jpg
    Cette image fait 40 Ko alors que toutes les autres images du slide font autour de 70 Ko...
    Peut-être un souci lors de l'enregistrement de l'image...
    Cordialement,
    Chabi01 - http://www.xlformation.com

    Commentaire


    • #3
      Re : image noire dans l'affichage Slideshow

      merci, je vais encore faire des essais mais j'ai l'impression d'avoir déjà tout testé.

      Commentaire


      • #4
        Re : image noire dans l'affichage Slideshow

        Bonjour,

        En comparant le header des images, celle qui vire au noir aléatoirement sous FF a un en-tête JPG cassé.
        Il faudrait la reprendre par exemple avec Gimp, et la réenregistrer, ça devrait résoudre le problème.

        FF est maintenant extrêmement pointilleux avec les images.
        Pas de demande de support par MP.
        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

        Commentaire


        • #5
          Re : image noire dans l'affichage Slideshow

          Je viens de les réenregistrer les images sous gimp au lieu de photophiltre, pour l'instant c'est ok. (c'est quoi un jpg cassé ?).Encore merci pour votre aide.
          Dernière édition par marc59160 à 15/04/2012, 18h58

          Commentaire


          • #6
            Re : image noire dans l'affichage Slideshow

            Les fichiers JPG ont un en-tête avec une description (appelée informations JFIF). Il arrive que certaines photos aient un en-tête incohérent, ce qui n'empêche pas leur affichage, sauf en cas de navigateur ultra pointilleux et considérant tout en-tête cassé comme une faille potentielle de sécurité).
            Pas de demande de support par MP.
            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

            Commentaire


            • #7
              Re : image noire dans l'affichage Slideshow

              J'ai pas tout compris mais en tout cas pour l'instant ça fonctionne. Juste pour ne plus avoir ce genre de problème, comment vérifier l' en-tête d' un jpg .

              bonne soirée

              Commentaire


              • #8
                Re : image noire dans l'affichage Slideshow

                Le plus simple, quand tu as une image noire ou mal affichée, la retraiter avec Gimp, qui lui réécrit proprement les en-têtes.

                Sinon, techniquement, il faut savoir analyser les premiers blocs d el'image (je le fais en hexadécimal par habitude).
                Pas de demande de support par MP.
                S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                Commentaire


                • #9
                  Re : image noire dans l'affichage Slideshow

                  Bon, le problème n'est résolu et ce matin l'image noire est toujours la. Apparemment c'est seulement sur firefox.

                  Commentaire


                  • #10
                    Re : image noire dans l'affichage Slideshow

                    je viens de tester ton site avec FF 11.0-2.23.1 64 bits Linux, et aucun problème, pas d'image noire.
                    Pas de demande de support par MP.
                    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                    Commentaire


                    • #11
                      Re : image noire dans l'affichage Slideshow

                      Pense à vider ton cache navigateur !
                      Cordialement,
                      Chabi01 - http://www.xlformation.com

                      Commentaire


                      • #12
                        Re : image noire dans l'affichage Slideshow

                        c'est normal, je pense avoir trouvé une autre solution. je viens juste de changer l'image qui bloquait en faisant un imp.écran coller ds photo philtre recadrer et enregistrer sous et apparemment ca marche.
                        merci pour votre aide et bonne journée.

                        Commentaire


                        • #13
                          Re : image noire dans l'affichage Slideshow

                          Passe ton sujet en réglé alors
                          Cordialement,
                          Chabi01 - http://www.xlformation.com

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X