Impossible de me connecter à l'administration

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Impossible de me connecter à l'administration

    Bonjour
    j'ai installé hier le composant Community Builder
    juste le lien "connexion" et ensuite j'ai tout fermé (site et administration)
    et ce matin impossible d'ouvrir l'administration
    (je présente le projet dans 1h ...)

    comment faire ?

    par ailleurs après avoir configuré le lien connexion avec CB
    je vois ceci
    Notice: Undefined index: view in C:\wamp\www\mon-site\components\com_content\router.php on line 49
    qu'est-ce donc ?

    merci pour votre aide
    (c'est mon premier site Joomla)

  • #2
    Re : Impossible de me connecter à l'administration

    Je viens de fouiller dans la base de données
    et je vois ceci :
    Base de données > table :users > id, name .... usertype : "deprecated"
    est ce que si j'écris "Super Utilisateur" à la place je pourrai à nouveau entrer dans l'administration ?
    je cherche mais j'ai peur de faire une bêtise,
    merci

    Commentaire


    • #3
      Re : Impossible de me connecter à l'administration

      Bonjour,
      Base de données > table :users > id, name .... usertype : "deprecated"
      est ce que si j'écris "Super Utilisateur" à la place je pourrai à nouveau entrer dans l'administration ?
      Non aucune chance. Déjà en 1.5 cette colonne ne servait pas à grand chose mais en 2.5 on se demande même pourquoi elle a été conservée (juste pour que la table users ne soit pas modifiée ?).

      Il se passe quoi quand tu essayes de te connecter ? Normalement une install CB même ratée ne devrait pas avoir d'impact sur la connexion à l'admin.

      par ailleurs après avoir configuré le lien connexion avec CB
      je vois ceci : Notice: Undefined index: view in C:\wamp\www\mon-site\components\com_content\router.php on line 49
      Qu'est-ce que tu appelles "configurer le lien avec CB" ? Surtout sans accès à l'admin...
      Schtroumpfe toi le Schtroumpf t'aidera.
      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

      Commentaire


      • #4
        Re : Impossible de me connecter à l'administration

        je viens de ré-essayer
        et je vois en rouge ceci :
        "JAuthentication::__construct : impossible de charger les librairies d'authentification.
        Le nom d'utilisateur et le mot de passe ne correspondent pas"


        j'en suis au point de me dire je vais refaire le site pour la 3è fois
        pas faute de chercher pourtant
        désolée

        Commentaire


        • #5
          Re : Impossible de me connecter à l'administration

          Re,
          tu es allé jouer dans la gestion des plugins après ton installation CB ?
          Schtroumpfe toi le Schtroumpf t'aidera.
          Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

          Commentaire


          • #6
            Re : Impossible de me connecter à l'administration

            en fait hier soir tout était parfait
            plus aucun souci nulle part
            j'ai voulu installer CB, et comme il est conseillé j'ai désactivé le module (je crois) de connexion Joomla
            j'ai suivi le début de l'installation CB avec l'onglet connexion et le lien "logout action"
            vu l'heure (environ 1h30 du mat) j'ai tout fermé
            et ce matin en ouvrant j'ai trouvé cette fameuse phrase en rouge.

            Voilà pourquoi j'ai cherché dans la base de données, en me disant que peut etre on pourrait forcer quelque chose
            mais c'est mon premier site Joomla et je n'y connais rien en base de données
            (j'espère avoir été précise dans ma réponse)

            Commentaire


            • #7
              Re : Impossible de me connecter à l'administration

              Bonjour,
              Envoyé par JCASF Voir le message
              en fait hier soir tout était parfait
              plus aucun souci nulle part
              j'ai voulu installer CB, et comme il est conseillé j'ai désactivé le module (je crois) de connexion Joomla
              N'aurais-tu pas par hasard désactivé le plugin authentification Joomla! (dans les plugins), au lieu du module mod_login de Joomla!

              Vu le message d'erreur, c'est bien le plugin qui a été désactivé. Avec PhpMyAdmin, vas dans ta base Joomla, ouvres la table #__extensions, recherche l'ID 401 (ou environs) de name 'plg_authentication_joomla" et si 'enable' est à 0, édites l'enregistrement et repasses enable à 1. ça résoudra ton problème. Tu devras ensuite, une fois l'accès revenu, passer en Extensions, gestion des modules, rechercher mod_login de Joomla!, le désactiver et activer mod_cblogin à sa place.
              Pas de demande de support par MP.
              S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

              Commentaire


              • #8
                Re : Impossible de me connecter à l'administration

                merci pour ta réponse
                je suis bien bans la base de données "e6cu5_extensions", mais pas de id 401 (ou environs) ni de plg_authentication
                j'ai regardé la colonne "enable" tout est avec un 1
                (bien sur j'ai tout regardé, une seule page)

                Commentaire


                • #9
                  Re : Impossible de me connecter à l'administration

                  Envoyé par JCASF Voir le message
                  merci pour ta réponse
                  je suis bien bans la base de données "e6cu5_extensions", mais pas de id 401 (ou environs) ni de plg_authentication
                  j'ai regardé la colonne "enable" tout est avec un 1
                  (bien sur j'ai tout regardé, une seule page)
                  Fais une recherche dans la table #__extensions. Il y a obligatoirement une ligne avec en name 'plg_authentication_joomla' quelque part.
                  Ce plugin est standard et installé avec Joomla! lui-même. Son absence serait plus que suspecte.
                  Pas de demande de support par MP.
                  S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                  Commentaire


                  • #10
                    Re : Impossible de me connecter à l'administration

                    non rien de rien
                    voici la liste de ce que j'ai
                    com_mailto
                    com_wrapper
                    com_admin
                    com_banners
                    com_cache
                    com_categories
                    com_checkin
                    com_contact
                    com_cpanel
                    com_installer
                    com_languages
                    com_login
                    com_media
                    com_menus
                    com_messages
                    com_modules
                    com_newsfeeds
                    com_plugins
                    com_search
                    com_templates
                    com_weblinks
                    com_content
                    com_config
                    com_redirect
                    com_users
                    PHPMailer
                    SimplePie
                    phputf8
                    Joomla! Web Application Framework
                    mod_articles_archive

                    Commentaire


                    • #11
                      Re : Impossible de me connecter à l'administration

                      Bonjour,
                      c'est la première page, demande les 30 suivants (2 fois)
                      Schtroumpfe toi le Schtroumpf t'aidera.
                      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                      Commentaire


                      • #12
                        Re : Impossible de me connecter à l'administration

                        la liste fait plusieurs pages...
                        cliques sur la colonne id pour trier par id, et navigues entre les pages
                        Pas de demande de support par MP.
                        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                        Commentaire


                        • #13
                          Re : Impossible de me connecter à l'administration

                          yes genial merci tout plein ça marche.
                          parcontre tu me disais ceci

                          Envoyé par jisse03 Voir le message
                          u devras ensuite, une fois l'accès revenu, passer en Extensions, gestion des modules, rechercher mod_login de Joomla!, le désactiver et activer mod_cblogin à sa place.
                          et là je ne vois rien quand administration - extensions - gestion des modules

                          Commentaire


                          • #14
                            Re : Impossible de me connecter à l'administration

                            Dans l'administration / Gestion des modules, ce que je t'ai donné est le Type du module, pas le libellé, puisqu'on change souvent les linellés pour avoir des titres de modules qui nous conviennent.

                            Dans le type tu dois trouver quelque part un CB Login que tu dois activer, et un d etype Connexion que tu désactives.
                            Pas de demande de support par MP.
                            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                            Commentaire


                            • #15
                              Re : Impossible de me connecter à l'administration

                              dans "Gestion des Extensions : Gestion", oui CB login est activé
                              dans gestion des modules - administration, le module "mod_login" (Formulaire de connexion) activé
                              donc c'est ok ?
                              (un énorme merci pour votre aide et votre patience)

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X