Probleme avec une bannière JS dans template sous version 2.5 d joomla

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Probleme avec une bannière JS dans template sous version 2.5 d joomla

    Bonjour,

    J'ai voulu testé ce matin la dernière version de joomla 2.5.
    J'ai téléchargé un template que j'ai l'habitude de travaillé : http://a4joomla.com/joomla-templates/dealer/

    Tout s'est bien passé pour le chargement de celui-ci.
    Seulement, je m'aperçois qu'il y a un problème sur la bannière. Elle utilise du JS.

    Seul la première image apparait, après plus rien c'est vide.
    Tout le reste est super ****l sinon. Comment puis-je remédier à ce problème sachant que je possède en plus un site qui tourne avec ce template et que je compte faire passer ce dernier en en version 2.5 (il est actuellement en 1.7.3).

    Comment faire pour que le fichier JS fonctionne correctement sous cette nouvelle version ?

    Par avance, je vous remercie.

  • #2
    Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

    Ton template n as pas encore été porté sous Joomla 2.5 ..Il est seulement pour J1.7 ..j ai le meme disfonctionnement en test chez moi....
    Ce n est pas un probleme de javascript mais de droits sur l image.
    pour le résoudre j ai fait un chmod 777 sur les fichiers du template..... Il doit y avoir ta seconde image qui ne peut etre accedée par joomla......
    Dans tous les cas ca as débloqué la seconde image....donc regardes ton dossier images et images/sampledatas et verifies les droits dessus.

    Et je soupconnes que c est l image dealer2.jpg qui ne doit pas avoir les bons droits.
    Dernière édition par lefabdu51 à 30/01/2012, 21h22
    Mon site en cours de construction avec de nouvelles catégories de documents...
    https://informaticien51.fr

    Commentaire


    • #3
      Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

      Bonjour,

      Merci pour ta suggestion mais celle-ci ne fonctionne pas chez moi
      Faudrait-il sinon adapté ce template pour la version 2.5 ? Si oui, est-ce la même méthode que pour la version 1.7 ?

      Commentaire


      • #4
        Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

        Salut,
        pourrais-tu utiliser Firefox et Firebug et indiquer l'erreur - s'il y en a une indiquée - ainsi que le nom du fichier coupable.

        Faudrait-il sinon adapter ce template pour la version 2.5 ? Si oui, est-ce la même méthode que pour la version 1.7 ?
        Entre J 1.7 et J 2.5, on est passé à une version plus récente de la librairie Mootools.
        “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

        Commentaire


        • #5
          Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

          Est-ce cela ?


          <div id="slideshow-allwrap">
          <div id="slideshow-container" style="width:980px;">
          <img alt="dealer1.jpg" src="/joomla25/templates/a4joomla-dealer-free/images/sampledata/dealer1.jpg" style="opacity: 0;">
          <img alt="dealer2.jpg" src="/joomla25/templates/a4joomla-dealer-free/images/sampledata/dealer2.jpg" style="opacity: 1; visibility: hidden;">
          <div id="slcontrol" style="z-index: 2;">
          <a id="slnext" href="#"></a>
          <a id="slprev" href="#"></a>
          </div>
          </div>
          </div>

          Commentaire


          • #6
            Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

            salut,
            non, ca, c'est l'HTML.
            A gauche de l'onglet HTML, dans Firebug, il y a "console".
            Y-a-t-il un message dedans ?
            “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

            Commentaire


            • #7
              Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

              Voici ce que j'ai pu trouver dans la console :

              L'utilisation de getAttributeNode() est obsolète. Utilisez getAttribute() à la place.
              L'utilisation de getAttributeNodeNS() est obsolète. Utilisez getAttributeNS() à la place.
              L'utilisation de xmlVersion est obsolète.
              L'utilisation de getAttributeNode() est obsolète. Utilisez getAttribute() à la place.
              L'utilisation de getAttributeNodeNS() est obsolète. Utilisez getAttributeNS() à la place.
              L'utilisation de xmlVersion est obsolète.
              L'utilisation de getAttributeNode() est obsolète. Utilisez getAttribute() à la place.
              L'utilisation de getAttributeNodeNS() est obsolète. Utilisez getAttributeNS() à la place.
              L'utilisation de xmlVersion est obsolète.

              Commentaire


              • #8
                Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

                Bonjour,

                Voilà, grâce à FireBug j'ai réussi à trouvé d'où vient à priori le souci.

                Voici les lignes de codes correspondants aux images :

                <img alt="dealer1.jpg" src="/joomla25/templates/a4joomla-dealer-free/images/sampledata/dealer1.jpg" style="opacity: 1;">

                <img alt="dealer2.jpg" src="/joomla25/templates/a4joomla-dealer-free/images/sampledata/dealer2.jpg" style="opacity: 0; visibility: hidden;">


                En supprimant depuis FireBug " visibility: hidden; " dans l'image dealer2.jpg
                J'arrive au résultat souhaité mais depuis Firebug seulement.

                Impossible de faire mémoriser la modification en question.
                J'avoue débuter aussi avec Firebug mais ça vous l'aurez certainement comprit.

                Comment je peux faire pour que cette modification soit effective et reste en mémoire pour le site ?
                Car impossible de retrouver ces lignes de codes dans mon template.

                Je vous remercie par avance pour votre aide, il ne me reste plus qu'à rendre celle-ci effective. et c'est bon ;-)
                Dernière édition par webgraphiste à 01/02/2012, 12h07

                Commentaire


                • #9
                  Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

                  Sorry, sorry,
                  plein de trucs à faire ce matin.

                  Tu ne peux pas changer visibility:hidden, c'est paramétré dans le JavaScript.
                  --> element.style
                  Comme tu indiques qu'il n'y a pas d'erreur JS, c'est un peu compliqué à debbugger.

                  Le script JS qui gère cet effet est verysimpleslideshow.js dans le dossier js de ton template.

                  A priori, je ne vois pas d'erreur flagrante dans ce script (par rapport à la nouvelle version de Mootools).

                  Tu peux toujours essayer 2 choses (copie/colle exactement), mais pas sur que ca marche :
                  1 * au milieu du script tu as :
                  stop: function() {
                  $clear(this.interval);
                  },
                  remplace par
                  stop: function() {
                  clearInterval(this.interval);
                  },
                  2 * il faudrait que je voies l'index.php du template
                  tu peux me l'envoyer ici en .zip ?
                  OU
                  si tu as ceci dans l'index.php:
                  <script type="text/javascript">
                  window.addEvent('domready',function() {
                  var slideshow = new VerySimpleSlideshow({
                  container: 'slideshow-container',
                  elements: '#slideshow-container img',
                  showControls: true,
                  transDelay: 4000,
                  transDuration: 800 });
                  slideshow.start();
                  });
                  </script>
                  Vire le # dans
                  elements: '#slideshow-container img',
                  et ... donne des nouvelles.

                  PS : les telechargements du site annoncent des templates 2.5 alors que les demos sont encore 1.7.
                  PPS : informe les devs des templates de ce pb
                  “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

                  Commentaire


                  • #10
                    Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

                    Bonjour,

                    Merci pour tes explications que j'ai appliqué à la lettre.
                    Malheureusement, c'est l'effet inverse qui se produit à présent : c'est à dire que l'image n°2 apparaît et la 1° ne s'affiche à son tour. Par ailleurs, la bannière se fige. Donc plus de mouvement, c'est statique.

                    Pour rappel des faits : initialement la bannière fonctionne ainsi que le reste du site mais c'est l'image numéro 2 qui reste bloquée. Donc au moment du passage de l'image 2 c'est blanc (l'affichage de l'image 2 ne s'effectue pas).

                    En réalisant tes procédures, la bannière ne semble plus fonctionner en plus ... c'est à dire que seul l'image 2 cette fois ci se fige à l'écran comme si la bannière était statique et non animée.

                    Et c'est uniquement sous la dernière version de joomla ...

                    Commentaire


                    • #11
                      Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

                      Re-bonsoir,

                      Après une rapide prise de contact avec le développeur, voici tout d'abord le lien comportant la solution au problème d'affichage du diaporama de haut entre autre :

                      http://a4joomla.com/blog/item/114-joomla-25.html

                      Merci à toutes personnes qui on néanmoins pris le temps de m'aider à trouver une solution.

                      Je confirme avoir effectuer la manipulation et que le diapo fonctionne selon mes souhaits.

                      Commentaire


                      • #12
                        Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

                        Super et tant mieux pour toi.
                        Mais j'avoue que j'aurais du voir cette erreur.
                        Bon ... j'ai appris qq chose.
                        “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

                        Commentaire


                        • #13
                          Re : Probleme avec une bannière JS dans template sous version 2.5 d joomla

                          Pas de souci ... parfois nos yeux peuvent aussi être un peu fatigués ou surmenés !!
                          Mais encore merci pour ton aide.

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X