Menu Haut, classe active… ne s'active pas !

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Menu Haut, classe active… ne s'active pas !

    Bonsoir.
    J'ai donc réalisé mon template.
    Lors de mes tests en local, les liens vers les catégories prennent la classe active lorsque la catégorie pointée par le lien est affichée. Normal donc.
    J'ai passé mon joomla en ligne et installé mon template, mais bizarrement les liens vers les catégories ne prennent pas la classe active.

    Donc en local j'ai :
    Code HTML:
    <ul>
    <li class="active">item de catégorie 1</li> <!-- p.ex si la page de la catégorie 1 est active -->
    <li>item de catégorie 2</li>
    <li></ul>
    En ligne j'ai :
    Code HTML:
    <ul>
    <li>item de catégorie 1</li>
    <li>item de catégorie 2</li>
    <li></ul>
    Le menu en question est celui du haut, horizontal : JS…
    Ave-vous une idée de la raison de cette différence et ou je peux gérer ce fait afin que ma classe "active" me revienne ?

    Je vous remercie par avance de toute idée !

    URL en ligne temporairement pour test : http://www.joomla.scriptopedia.org
    Cordialement.
    __
    Eddy !!!
    Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

  • #2
    Re : Menu Haut, classe active… ne s'active pas !

    elle apparais bien... surement un probleme de navigateur chez toi
    Mon site en cours de construction avec de nouvelles catégories de documents...
    https://informaticien51.fr

    Commentaire


    • #3
      Re : Menu Haut, classe active… ne s'active pas !

      Bonjour.
      Sur tous mes navigateurs alors !!! Et sur deux machines différentes !!!
      Testé sur Firefox, opera, safari et Chrome, la classe n'apparait nulle part. On parle bien du menu haut, celui dans la barre grise.
      La classe :hover apparait et fonctionne bien mais une fois la page affichée, la classe .active est absente…
      Cordialement.
      __
      Eddy !!!
      Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

      Commentaire


      • #4
        Re : Menu Haut, classe active… ne s'active pas !

        Bonjour,

        J'utilise Joomla 2.5.4, et je crois que j'ai eu le même problème aujourd'hui.
        Essayez de publier un module de login, et les classes actives remarchent...

        L'astuce m'a été donnée par le développeur du module maxi menu, (module avec lequel je pensait avoir un problème à la base, mais il n'en est rien, les classes ne s'appliquent pas non plus sur un menu classique).
        Merci de me faire un retour icic si possible ou si vous avez trouver la solution.

        Bonne journée,

        Jonathan
        Dernière édition par jodafatass à 13/04/2012, 14h31

        Commentaire


        • #5
          Re : Menu Haut, classe active… ne s'active pas !

          salut
          il semble que tu n'utilises pas le mod_menu, mais le module de catégories. Du coup je ne crois pas que tu puisses avoir la classe active.
          publies un véritable module de menu dans ta position de template et regardes ce que ça donne
          CEd
          Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
          http://www.template-creator.com Outil de création de templates
          Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

          Commentaire


          • #6
            Re : Menu Haut, classe active… ne s'active pas !

            Si j'ai fait les test avec un mod menu ce matin a la place du maxi menu en haut, mais j'ai retrouvé le même problème que toi.

            Je le re-publie si tu veux vérifier (il est publié, rien ne change).
            La solution de mettre un module login dans une position cachée ne me plait pas trop, j'aimerai comprendre l'origine du probleme.
            Dernière édition par jodafatass à 13/04/2012, 14h42

            Commentaire


            • #7
              Re : Menu Haut, classe active… ne s'active pas !

              Bonjour à vous deux.
              @jodafatass : J'ai déjà un module de login publié !
              @ced1870 : Comment puis-je publier une liste des catégories dans un mod-menu ?

              En tous cas c'est louche, j'ai la même config en local et en ligne !
              Cordialement.
              __
              Eddy !!!
              Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

              Commentaire


              • #8
                Re : Menu Haut, classe active… ne s'active pas !

                @jodafatass : ton souci est différent, ouvres un nouveau fil stp et rappelles ton url. Ce qui est bizarre chez toi c'est que normalement ça doit fonctionner avec les composants natifs, essaies de voir ce que tu as installé qui pourrait jouer

                @eddy : déjà tu crées un menu de lien, et tu publies un module de menu qui pointe sur ce menu. Regardes si les liens actifs fonctionnent. Ensuite on verra
                Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
                http://www.template-creator.com Outil de création de templates
                Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

                Commentaire


                • #9
                  Re : Menu Haut, classe active… ne s'active pas !

                  Oui, ça fonctionne mais ce n'est pas le comportement voulu, si je crée un tel menu, au clic, j'obtiens un page qui liste les articles d'une catégorie sous forme de liste, pas sous forme de blog comme le mod_articles_categories.

                  Ce que je ne comprends pas c'est pourquoi ça fonctionne en local et pas en ligne sous une même configuration…

                  Mais le "ensuite on verra" me dit que tu aurais peut-être une idée derrière la tête.
                  Dernière édition par Eddy.vh à 13/04/2012, 18h16
                  Cordialement.
                  __
                  Eddy !!!
                  Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                  Commentaire


                  • #10
                    Re : Menu Haut, classe active… ne s'active pas !

                    je voulais déjà vérifier que ça fonctionne avec un menu normal, donc c'est bon.
                    ta config en local fonctionne ? ça ne serait pas un souci de sef ? es-tu sur d'avoir exactement la mem config ?
                    cela dit en passant tu peux configurer tes liens de menu comme tu veux pour avoir un affichage blog ou pas
                    Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
                    http://www.template-creator.com Outil de création de templates
                    Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

                    Commentaire


                    • #11
                      Re : Menu Haut, classe active… ne s'active pas !

                      Bonjour Cédric.
                      Merci de cette réponse.
                      En fait la seule différence est la réécriture au vol des URL mais dans les deux config (local et en ligne), j'ai bien le SEF actif.

                      Tu as donc presque mis le doigt dessus !!!
                      Je viens vite fait de tenter une désactivation de cette réécriture des URL et mon menu haut prend la classe active.
                      Ma nouvelle question est donc qu'est-ce qui est mieux ? La réécriture activée ou non ? Le SEF est-il suffisant ?

                      Je teste le menu normal, ça résoudra peut-être un autre soucis du à ce menu, à savoir, si je suis sur une page de contact ou de téléchargement de fichier Phoca Download, ce menu prend une URL de forme …/index.php/fr/component/content/….html au lieu de …/index.php/fr/accueil/….html et donne une erreur 404.
                      Ah si tout était simple !!!!


                      EDITION :

                      Cédric, je suis enfin arrivé à mes fins et ai pu, grâce à toi, résoudre deux problèmes d'un coup.
                      Les catégories inaccessibles depuis certaines pages ne sont plus que du passé ainsi qu le manque de la classe active.
                      Je te remercie infiniment pour ton aide.
                      Dernière édition par Eddy.vh à 14/04/2012, 13h39 Raison: Ajout d'informations
                      Cordialement.
                      __
                      Eddy !!!
                      Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X