Migration sitegroundj15 53 1.5 à 2.5 corp vide

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Migration sitegroundj15 53 1.5 à 2.5 corp vide

    Bonjour à tous,

    Après plusieurs heures à chercher sur le net les différentes erreur, je me retrouve avec un site "sans erreur" mais surtout vide ! * rire nerveux imaginez *

    Dans mon administration, je me suis dis "il faut mettre les modules dans les bonnes positions" et là j'ai remarqué qu'il n'y a "rien" de déclarer comme position sur mon thème : O_O

    Alors : Help !

    N'ayant pas de message d'erreur, je suis à coup d'idée et d'indice...

    Qui se sent l'âme d'un chevalier servant venant au secours d'une "relative" jeune princesse ?
    Allez les gars, pitié XD

    wewewe.yvyleewoods.comeu (pour visualiser)

    biz
    yvy

  • #2
    Re : Migration sitegroundj15 53 1.5 à 2.5 corp vide

    bon j'ai identifié le problème
    dans mon templatedetail.xml je n'ai pas de position déclaré dans mon template. C'était déjà le cas dans la version 1.5
    Tout semble être dans mon css
    La question est : comment faire pour intégrer les positions du template.
    Est ce que la simple balise <position></position> va suffire ?

    Commentaire


    • #3
      Re : Migration sitegroundj15 53 1.5 à 2.5 corp vide

      Bonjour,

      Avez vous suivi un tuto pour convertir votre template 1.5 en 2.5 comme celui là http://www.nosyweb.fr/astuce-joomla/...oomla-2-5.html ?
      Besoin de debugguer votre site, pensez à Firebug : http://www.grafikart.fr/tutoriels/ht...ion-firefox-76
      Vous avez trouvé une solution, mettez votre discussion en [Réglé] ? http://forum.joomla.fr/announcement.php?f=58
      Je ne donne pas suite aux messages privés (MP) non sollicités !

      Commentaire


      • #4
        Re : Migration sitegroundj15 53 1.5 à 2.5 corp vide

        Oui et je l'ai suivi à la lettre
        J'ai trouvé certaine choses mais pas le principal ...
        J'ai tapé en dure la position au niveau des modules au lieu de le sélection. Ca marche.
        Le hic c'est le "content" la page principal... Rien ne s'affiche et là, je sèche.
        Le template utilisé est siteground1553 et il n'y a aucune position déclarée dans templatedetail.xml
        Je ne sais pas où joomla2.5 récupère l'info de la position du content principal et la lui donner...

        Help !

        Commentaire


        • #5
          Re : Migration sitegroundj15 53 1.5 à 2.5 corp vide

          Ben le content ne correspond pas à une position. Les positions du template sont uniquement fait pour les modules.
          Donc dans ton index.php du template tu dois avoir un appel du content en "dur".
          Besoin de debugguer votre site, pensez à Firebug : http://www.grafikart.fr/tutoriels/ht...ion-firefox-76
          Vous avez trouvé une solution, mettez votre discussion en [Réglé] ? http://forum.joomla.fr/announcement.php?f=58
          Je ne donne pas suite aux messages privés (MP) non sollicités !

          Commentaire


          • #6
            Re : Migration sitegroundj15 53 1.5 à 2.5 corp vide

            Voilà ce que j'ai dans mon index

            <body id="page_bg">
            <?php if($this->countModules('user4') and JRequest::getCmd('layout') != 'form') : ?>
            <div id="top_with_search">
            <div class="pathway">
            <jdoc:include type="module" name="breadcrumbs" />
            <jdoc:include type="modules" name="user4" />
            </div>
            </div>
            <?php else: ?>
            <div id="top_without_search">
            <div class="pathway">
            <jdoc:include type="module" name="breadcrumbs" />
            </div>
            </div>
            <?php endif; ?>
            <div id="headertop"></div>
            <div id="header">
            <div id="image">

            </div>
            </div>
            <div id="headerbottom"></div>

            <div class="center">
            <div id="wrapper">
            <div id="content">
            <?php if($this->countModules('left') and JRequest::getCmd('layout') != 'form') : ?>
            <div id="leftcolumn">
            <jdoc:include type="modules" name="left" style="rounded" />
            <?php $sg = 'banner'; include "templates.php"; ?>
            </div>
            <?php endif; ?>

            <?php if($this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
            <div id="maincolumn">
            <?php else: ?>
            <div id="maincolumn_full">
            <?php endif; ?>
            <div class="nopad">
            <jdoc:include type="message" />
            <?php if($this->params->get('showComponent')) : ?>
            <jdoc:include type="component" />
            <?php endif; ?>
            </div>
            </div>
            <?php if($this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
            <div id="rightcolumn" style="float:right;">
            <jdoc:include type="modules" name="right" style="rounded" />
            </div>
            <?php endif; ?>
            <div class="clr"></div>
            </div>
            </div>
            <div id="content_bottom"></div>
            <jdoc:include type="modules" name="debug" />
            </div>
            <div id="validation">
            <div id="footer">
            <div id="sgf">
            <?php $sg = ''; include "templates.php"; ?>
            </div>
            </div>
            </div>

            </body>
            </html>

            Commentaire


            • #7
              Re : Migration sitegroundj15 53 1.5 à 2.5 corp vide

              Petit UP.
              Je pense que mon problème se situe dans cette partie de mon index mais je trouve toujours pas la solution. Help please ...

              <div class="center">
              <div id="wrapper">
              <div id="content">
              <?php if($this->countModules('left') and JRequest::getCmd('layout') != 'form') : ?>
              <div id="leftcolumn">
              <jdoc:include type="modules" name="left" style="rounded" />
              <?php $sg = 'banner'; include "templates.php"; ?>
              </div>
              <?php endif; ?>

              <?php if($this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
              <div id="maincolumn">
              <?php else: ?>
              <div id="maincolumn_full">
              <?php endif; ?>
              <div class="nopad">
              <jdoc:include type="message" />
              <?php if($this->params->get('showComponent')) : ?>
              <jdoc:include type="component" />
              <?php endif; ?>
              </div>
              </div>
              <?php if($this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
              <div id="rightcolumn" style="float:right;">
              <jdoc:include type="modules" name="right" style="rounded" />
              </div>
              <?php endif; ?>
              <div class="clr"></div>
              </div>
              </div>
              <div id="content_bottom"></div>
              <jdoc:include type="modules" name="debug" />
              </div>

              Commentaire


              • #8
                Re : Migration sitegroundj15 53 1.5 à 2.5 corp vide

                Bon j'ai mis <jdoc:include type="component" /> juste devant <jdoc:include type="message" />; je vois à nouveau mon contenu mais plus la colonne de droite... Je tourne en rond... Help !

                Commentaire


                • #9
                  Re : Migration sitegroundj15 53 1.5 à 2.5 corp vide

                  Envoyé par yvyleewoods Voir le message
                  Bon j'ai mis juste devant ; je vois à nouveau mon contenu mais plus la colonne de droite... Je tourne en rond... Help !
                  Cela indiques qu il y as un paramètres dans l administration du template qui geres l affichage du composant.Generalement, c est pour le desactiver sur la page d acceuil.Regardes dans extensions > gestion des templates > clic sur ton template, si tu n as pas un paramètre du type show component on site home....
                  Mon site de documentation sur Joomla et le CCK K2 : http://documentation.informaticien51.fr
                  Une notice pour le CCK K2 ( mise à jour le 01/06/2015) :
                  http://documentation.informaticien51...couverte-de-k2

                  Commentaire


                  • #10
                    Re : Migration sitegroundj15 53 1.5 à 2.5 corp vide

                    Non, je n'ai aucun paramètre dans ma gestion de template.
                    J'ai fais encore quelques changements et maintenant, j'ai un léger décalage de ma colonne droite qui se mets en dessous de mon ilot centrale, uniquement sur la page d'accueil.

                    Voilà tout mon index...
                    Merci de votre réponse en tout cas, je me sens moins seule dans ma galère...

                    <?php
                    defined( '_JEXEC' ) or die( 'Restricted access' );
                    JHtml::_('behavior.framework', true);
                    JPlugin::loadLanguage( 'tpl_SG1' );
                    ?>
                    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
                    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php echo $this->language; ?>" lang="<?php echo $this->language; ?>" >
                    <head>
                    <jdoc:include type="head" />

                    <link rel="stylesheet" href="templates/system/css/system.css" type="text/css" />
                    <link rel="stylesheet" href="templates/<?php echo $this->template ?>/css/template.css" type="text/css" />
                    <script type="text/javascript">

                    var _gaq = _gaq || [];
                    _gaq.push(['_setAccount', 'UA-22024302-1']);
                    _gaq.push(['_trackPageview']);

                    (function() {
                    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
                    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
                    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
                    })();

                    </script>
                    </head>
                    <body id="page_bg">
                    <?php if($this->countModules('user4') and JRequest::getCmd('layout') != 'form') : ?>
                    <div id="top_with_search">
                    <div class="pathway">
                    <jdoc:include type="module" name="breadcrumbs" />
                    <jdoc:include type="modules" name="user4" />
                    </div>
                    </div>
                    <?php else: ?>
                    <div id="top_without_search">
                    <div class="pathway">
                    <jdoc:include type="module" name="breadcrumbs" />
                    </div>
                    </div>
                    <?php endif; ?>
                    <div id="headertop"></div>
                    <div id="header">
                    <div id="image">

                    </div>
                    </div>
                    <div id="headerbottom"></div>

                    <div class="center">
                    <div id="wrapper">
                    <div id="content">
                    <?php if($this->countModules('left') and JRequest::getCmd('layout') != 'form') : ?>
                    <div id="leftcolumn">
                    <jdoc:include type="modules" name="left" style="rounded" />
                    <?php $sg = 'banner'; include "templates.php"; ?>
                    </div>
                    <?php endif; ?>

                    <?php if($this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
                    <div id="maincolumn">
                    <?php else: ?>
                    <div id="maincolumn_full">
                    <?php endif; ?>
                    <div class="nopad">
                    <jdoc:include type="component" />
                    <jdoc:include type="message" />
                    <?php if($this->params->get('showComponent')) : ?>
                    <jdoc:include type="component" />
                    <?php endif; ?>
                    </div>
                    </div>
                    <?php if($this->countModules('right') and JRequest::getCmd('layout') != 'form') : ?>
                    <div id="rightcolumn" style="float:right;">
                    <jdoc:include type="modules" name="right" style="rounded" />
                    </div>
                    <?php endif; ?>
                    <div class="clr"></div>
                    </div>
                    </div>
                    <div id="content_bottom"></div>
                    <jdoc:include type="modules" name="debug" />
                    </div>
                    <div id="validation">
                    <div id="footer">
                    <div id="sgf">
                    <?php $sg = ''; include "templates.php"; ?>
                    </div>
                    </div>
                    </div>

                    </body>
                    </html>

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X