Image du header qui ne s'affiche plus après migration sur serveur distant.

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Image du header qui ne s'affiche plus après migration sur serveur distant.

    Bonjour à tous,

    Je développe un site depuis de nombreux mois et je viens (enfin) de prendre un hébergement chez OVH et migrer mon site. N'ayant aucune connaissance de base dans la créa de site, je suis partis de zéro et réussi à toujours trouver des solutions mais là je bloque sur un truc qui me semble pourtant simple.

    Sur mon serveur local de développement (serveur2go) tout marchais bien, utilisant le template Gantry, j'avais créer un fichier css-modified avec uniquement mes changements comme le fait d'avoir une bannière sur mon Header. Le code était :
    #rt-header {background:url(http://127.0.0.1:4001/Simrace-in/ima...niere/logo.png) no-repeat center;}

    Après avoir migrer le site, mes différentes bannière ne s'affiche plus, c'est donc l'adresse qui n'est pas bonne mais que mettre, j'ai fait milles essais mais sans succès.

    Je vous remercie d'avance de vos aides précieuses.

  • #2
    Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

    Salut

    Ton url http://127.0.0.1 fait référence ... à ton serveur local. Absolument normal que cela ne fonctionne pas en prod.

    Ce que tu dois mettre, c'est une url en relatif et donc "/images/banner/... "
    Christophe (cavo789)
    Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

    Commentaire


    • #3
      Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

      On ne met jamais une adresse complète dans un site, il faut toujours qu'elle soit relative.
      L'exemple que tu donnes demande au site d'aller chercher l'image sur 127.0.0.1, ce qui lui sera impossible.
      L'adresse doit être du type
      background: #eee url(../images/header_outer.jpg) repeat-x ;
      le début de l'url variant selon que tu vas chercher l'image dans le template ou dans le dossier images de Joomla!
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

      Commentaire


      • #4
        Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

        Merci à vous pour vos réponse, j'ai effectivement remplacer la ligne par :
        #rt-header {background:url(images/banners/banniere/logo.png) no-repeat center;} mais rien n'y fait, même en vidant les caches

        Commentaire


        • #5
          Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

          Fais un clic droit sur l'emplacement de l'image pour l'afficher seule, tu récupéreras ainsi son adresse et pourras voir quelle erreur est présente dans cette adresse.
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

            En fait il n'y a pas réellement d'emplacement image puisque je la rajoute sur le header du site. Ce qui est incompréhensible c'est que tout fonctionnant en local et je n'arrive pas à faire en sorte de faire la même chose en distant alors que presque rien ne change mis à part effectivement l'emplacement de départ, le fameux http://127...

            Commentaire


            • #7
              Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

              Bon, simple question : est-ce que l'image est effectivement présente sur ton serveur de production et si oui, où ?

              Donne-nous l'url de l'image (cela sera quelque chose comme http://tonsite/dossier/sousdossier/image.png).

              De là, donc, l'url relative est /dossier/sousdossier/image.png et c'est elle qu'il faut renseigner dans ton css.

              Bye
              Christophe (cavo789)
              Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
              Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

              Commentaire


              • #8
                Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

                Si l'image doit se trouver en background du header, elle a bien un emplacement dans ta page.
                Que se passe-t-il si tu fais un clic droit sur cette zone ?
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

                  J'ai le menu windows qui s'affiche. En allant sur "afficher le code source" je remarque par exemple que mon logo (qui s'implante via l'interface de Gantry) est présent avec le code suivant :
                  #rt-logo {background: url(/images/banners/Logo_Simrace-in/Logo_Site.png) 50% 0 no-repeat !important;}
                  Par contre rien concernant ma bannière.

                  Commentaire


                  • #10
                    Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

                    Tu dois avoir aussi "afficher l'image", non ?
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                    Commentaire


                    • #11
                      Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

                      Non, en fait, je pense que le css-modified qui prend le pas sur le css de base n'est pas pris en compte. je vais relire les tutos pour voir.

                      Commentaire


                      • #12
                        Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

                        Toujours pas de solution après milles essais, je ne sais pas vraiment pas ce qui bloque

                        Commentaire


                        • #13
                          Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

                          Que ce soit une feuille de style ou une autre qui soit utilisée pour afficher le fond de ton header, il y a un moyen de savoir dans le code-source de la page ou avec des outils comme Firebug sous Firefox quelle est l'adresse de l'image et trouver ainsi pourquoi elle ne s'affiche pas.
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                          Commentaire


                          • #14
                            Re : Image du header qui ne s'affiche plus après migration sur serveur distant.

                            Je développe un site depuis de nombreux mois et je viens (enfin) de prendre un hébergement chez OVH
                            Ce serait beaucoup plus simple de donner l'URL pour être aidé
                            Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
                            ---
                            UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
                            bgMax
                            , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X