Rien ne se passe après la mise en ligne de mon site

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Rien ne se passe après la mise en ligne de mon site

    Bonjour à tous et merci à ceux qui prendront le temps de m'aider.
    J'ai construit mon site en local avec wamp. Aujourd'hui j'ai voulu le mettre en ligne sur mon hébergement chez OVH.
    J'ai fais le transfert de mes dossiers sur le www de mon site.
    J'ai importé ma base de données dans le phpmyadmin de mon hébergeur.
    J'ai installé joomla sur mon hébergement par le naviguateur.
    Mais quand je vais sur la page d'accueil j'ai toujours la page d'ovh "site en construction". De même dans mon interface joomla en ligne, je ne retrouve rien de ce que j'avais créer précédemment. J'ai du louper quelque chose!
    Quelqu'un pourrait-il me donner un coup de main? Merci!
    Dernière édition par audrey38 à 15/04/2011, 16h44

  • #2
    Re : Rien ne se passe après la mise en ligne de mon site

    Tu as deux choses différentes à gérer :
    - un fichier index.html qu'OVH a placé pour toi à la racine du site, et qu'il faut renommer ou supprimer
    - une base de données que tu as écrasée en l'important avant de réinstaller : vide la base et importe de nouveau ta sauvegarde
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Re : Rien ne se passe après la mise en ligne de mon site

      Merci Robert! ça marche effectivement pour la page d'accueil, mais lorsque je clique sur les liens de menu pour aller sur les autres pages, ça me met url not found on this server. Tu aurais une idée ?
      Merci!

      Commentaire


      • #4
        Re : Rien ne se passe après la mise en ligne de mon site

        Entre dans l'administration, puis la configuration générale, et désactive la réécriture d'URL (tous les paramètres SEO à "Non"), ça devrait mieux fonctionner.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Re : Rien ne se passe après la mise en ligne de mon site

          Effectivement ça marche, mais du coup comment faire pour avoir des url propres et que ça marche?
          Merci!

          Commentaire


          • #6
            Re : Rien ne se passe après la mise en ligne de mon site

            Il faudra que tu utilises le .htaccess adapté pour OVH, avant de remettre à Oui les deux ou trois premiers paramètres SEO.
            Il te suffit de coller le texte du "htaccess.txt" de Joomla! dans le ".htaccess" qu'OVH a placé dans ton répertoire "www" pour que ça fonctionne.
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              Re : Rien ne se passe après la mise en ligne de mon site

              J'ai fait ce que tu m'as proposé et j'obtiens à présent une erreur 404 quand j'active la réécriture d'url en clair et que je tente d'aller vers d'autres pages de mon site depuis la page d'accueil.
              Sinon dois-je supprimer le fichier htacces.txt à la racine de mon site distant?
              Merci!

              Correction: en activant aussi le mod rewrite, ça marche!
              Merci beaucoup de ton aide.
              Bonne soirée
              Dernière édition par audrey38 à 15/04/2011, 20h32

              Commentaire


              • #8
                Re : Rien ne se passe après la mise en ligne de mon site

                Tu as bien activé les deux premiers paramètres SEO ?
                Le fichier htaccess.txt peut rester à sa place.
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Re : Rien ne se passe après la mise en ligne de mon site

                  oui mon erreur était de n'avoir activé que le premier, en activant les deux premiers, ça marche!

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X