mp201_usergroups

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] mp201_usergroups

    Bonjour,

    J'ai développé un site joomla 1.7 en local avec WAMP qui marche bien. Je désire maintenant le mettre sur EasyHebergement car FREE ne supporte pas le 1.7.

    Mon problème est que je n'arrive pas à importer correctement ma base de données, j'ai 40 tables en local et je ne peux importer que 39 tables sur Easyhebergement.

    J'ai un problème avec la table mp201_usergroups que j'arrive à exporter mais pas à importer. phpMyAdmin me donne comme erreur lors de l'importation de ma table :

    Erreur
    Requête SQL:

    --
    -- Base de données: `joomla17`
    --
    -- --------------------------------------------------------
    --
    -- Structure de la table `mp201_usergroups`
    --
    CREATE TABLE IF NOT EXISTS `mp201_usergroups` (

    `id` INT( 10 ) UNSIGNED NOT NULL AUTO_INCREMENT COMMENT 'Primary Key',
    `parent_id` INT( 10 ) UNSIGNED NOT NULL DEFAULT '0' COMMENT 'Adjacency List Reference Id',
    `lft` INT( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set lft.',
    `rgt` INT( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set rgt.',
    `title` VARCHAR( 100 ) NOT NULL DEFAULT '',
    PRIMARY KEY ( `id` ) ,
    UNIQUE KEY `idx_usergroup_parent_title_lookup` ( `parent_id` , `title` ) ,
    KEY `idx_usergroup_title_lookup` ( `title` ) ,
    KEY `idx_usergroup_adjacency_lookup` ( `parent_id` ) ,
    KEY `idx_usergroup_nested_set_lookup` ( `lft` , `rgt` ) USING BTREE
    ) ENGINE = INNODB DEFAULT CHARSET = utf8 AUTO_INCREMENT =9;

    MySQL a répondu:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'USING BTREE
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8 AUTO_INCREMENT=9' at line 21



    Je n'ai pas d'utilisateur pour mon site et je ne souhaite pas en créer pour l'instant. Que puis-je faire ? S'il me manque cette table, cela peut créer des désordres sur le site ? Dois je la créer manuellement ?

    J'en suis à la partie de transférer tout mon site via ftp et modifier le configuration.php pour remettre les bons liens vers les bases sql et les logins etc...

    Merci d'avance de vos éclaircissements sur ce problème.

    Cordialement

  • #2
    Re : mp201_usergroups

    Bonjour,

    Le message d'erreur est clair:
    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'USING BTREE
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8 AUTO_INCREMENT=9' at line 21
    La plupart des hébergements de bas de gamme ne fournissent pas le stockage InnoDB pour MySQL. Tu peux modifier le code en enlevant "USING BTREE et ENGINE = INNODB
    ça devrait fonctionner au prix d'une baisse d eperformances sur certaines actions.
    Pas de demande de support par MP.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

    Commentaire


    • #3
      Re : mp201_usergroups

      Re,

      Je viens de finir d'uploader le site et le configuration.php et le site marche.

      Je serais quand même intéressé de trouver une solution pour cette table manquante au cas ou je voudrais créer des groupes d’utilisateurs.

      Merci d'avance des idées que vous pourriez me fournir.

      Commentaire


      • #4
        Re : mp201_usergroups

        Envoyé par jisse03 Voir le message
        Bonjour,

        Le message d'erreur est clair:
        #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'USING BTREE
        ) ENGINE=InnoDB DEFAULT CHARSET=utf8 AUTO_INCREMENT=9' at line 21
        La plupart des hébergements de bas de gamme ne fournissent pas le stockage InnoDB pour MySQL. Tu peux modifier le code en enlevant "USING BTREE et ENGINE = INNODB
        ça devrait fonctionner au prix d'une baisse d eperformances sur certaines actions.
        Merci de ta réponse, j'avais essayé d'enlevé cette partie sans vraiment savoir ce que ça pouvait faire mais ça ne passait quand même pas. Je vais re-essayer pour voir.

        Merci encore

        P.S : Le site marche mais je n'arrive pas à accéder à l'administration , je vais voir ce qui peut poser ce soucis.

        Commentaire


        • #5
          Re : mp201_usergroups

          Bonjour,
          Je serais quand même intéressé de trouver une solution pour cette table manquante au cas ou je voudrais créer des groupes d’utilisateurs.
          Tu n'as pas le choix... la table des groupes est un des piliers de la gestion des droits de Joomla 2.5.

          Le site marche mais je n'arrive pas à accéder à l'administration
          Tu as relancé tout le script ou uniquement le create table ? Parce que juste après il doit y avoir des insert dans la table qui doivent faire cruellement défaut, illustrant le point précédent...
          Schtroumpfe toi le Schtroumpf t'aidera.
          Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

          Commentaire


          • #6
            Re : mp201_usergroups

            Merci à vous pour l'aide.

            Le blocage de la partie admin était bien du au manque de la table "usergroups".

            J'ai modifié le "mp201_usergroups" dans notepad++ et j'ai supprimé la partie "USING BTREE" seulement et ça marche. Si on supprime quelque chose d'autres, ça ne marche plus du tout, il faut juste supprimer "USING BTREE".

            Je peux désormais accéder à la partie "administration".


            DROP TABLE IF EXISTS `mp201_usergroups`;
            CREATE TABLE IF NOT EXISTS `mp201_usergroups` (
            `id` int(10) unsigned NOT NULL AUTO_INCREMENT COMMENT 'Primary Key',
            `parent_id` int(10) unsigned NOT NULL DEFAULT '0' COMMENT 'Adjacency List Reference Id',
            `lft` int(11) NOT NULL DEFAULT '0' COMMENT 'Nested set lft.',
            `rgt` int(11) NOT NULL DEFAULT '0' COMMENT 'Nested set rgt.',
            `title` varchar(100) NOT NULL DEFAULT '',
            PRIMARY KEY (`id`),
            UNIQUE KEY `idx_usergroup_parent_title_lookup` (`parent_id`,`title`),
            KEY `idx_usergroup_title_lookup` (`title`),
            KEY `idx_usergroup_adjacency_lookup` (`parent_id`),
            KEY `idx_usergroup_nested_set_lookup` (`lft`,`rgt`)
            ) ENGINE=InnoDB DEFAULT CHARSET=utf8 AUTO_INCREMENT=9 ;



            Si ça peut aider quelqu'un d'autre, je suis hébergé chez EasyHebergement.

            Cordialement

            P.S : Topic passé en résolu

            Commentaire


            • #7
              Re : mp201_usergroups

              Bonjour,

              Je reprends mon ancien post car je pense que ma MAJ vers Joomla 2.5 a eu un petit problème à cause de cette table de base de donnée user_group.

              J'ai lancé la MAJ vers Joomla 2.5 depuis Joomla 1.7, la mise a jour ne s'est pas déroulé complètement et j'ai eu un écran d'erreur avant la fin. Pourtant, dans mes informations du site, je suis bien en : Version de Joomla : Joomla! 2.5.4 Stable [ Ember ] 2-April-2012 14:00 GMT

              J'ai quand même quelques erreurs dans la partie administration du site. Je vous mets les copies d'écran dessous des erreurs que ça m'affiche. Je n'ai pas de "nom commun" mais le nom des tables de la bases de données qui s'affichent.

              On voit ci dessous le problème dans la partie "gestion des extensions" :
              Cliquez sur l'image pour l'afficher en taille normale

Nom : 1.jpg 
Affichages : 1 
Taille : 23,2 Ko 
ID : 1801018

              On voit ci dessous le menu "utilisateurs" et une partie de la "configuration site" :
              Cliquez sur l'image pour l'afficher en taille normale

Nom : 2.jpg 
Affichages : 1 
Taille : 31,9 Ko 
ID : 1801019

              Je ne sais pas si ça risque quelques choses de rester comme ça et si ça va s'empirer au fur et à mesures des MAJ futures.
              Est ce que je peux faire quelques choses sur cette table de donnée mp201_usergroups, est ce que mes erreurs dans la partie admin viennent de là ?


              Suite au passage en 2.5, j'ai eu un problème de template et de JCE que j'ai pu les résoudre seul, mais là pour la bdd, je coince un peu...

              En vous remerciant par avance si vous arrivez à m'aider sur ce problème.

              Cordialement

              Commentaire


              • #8
                Re : mp201_usergroups

                Au vue des captures il manque la mise à jour des fichiers langues fr. A installer comme n'importe quelle extension.

                Commentaire


                • #9
                  Re : mp201_usergroups

                  Envoyé par zepelin57 Voir le message
                  Au vue des captures il manque la mise à jour des fichiers langues fr. A installer comme n'importe quelle extension.
                  Salut, que dire à part un immense merci. Tu as encore aidé un débutant. Je me suis trop focalisé sur mon bug de base de donnée et n'ai pas vu le plus facile peut être. Bref, merci à toi d'avoir pris le temps de me répondre et de m'aider.

                  P.S : Passé en résolu

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X