Probleme insttallation/MAJ joomla 1.7/2.5

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Probleme insttallation/MAJ joomla 1.7/2.5

    Bonjour

    Utilisateur de Joomla depuis de très nombreuses années, avec un hébergement chez OVH en mutualisé, la mise à jour de la version 1.7.3 vers la version 2.5 est impossible avec le message suivant :

    Parse error: syntax error, unexpected '=', expecting '(' in /xxxxxx/xxxxxx/www/installation/index.php on line 66

    Le problème est le même si je souhaite installer la version 2.5 de Joomla

    Existe-il une solution, si oui laquelle ?

    Je vous remercie pour votre aide

  • #2
    Re : Probleme insttallation/MAJ joomla 1.7/2.5

    Tu n'es pas en Php 5, il faut passer par une modification du htaccess en rajoutant en haut de page SetEnv PHP_VER 5_3.

    Commentaire


    • #3
      Re : Probleme installation/MAJ joomla 1.7/2.5

      Merci pour la pertinence de la réponse - mon fichier (.htaccess) contenait "SetEnv PHP_VER 5" mais visiblement ce n'était pas suffisant..
      La mise à jour vers la version 2.5 s'est donc déroulée sans problème...

      Avec mes remerciements pour toutes les infos; Joomla est un excellent CMS

      NB : Je ne retrouve + le n° de version dans la partie admin; existe t-il une solution pour connaitre la version installée ?

      Commentaire


      • #4
        Re : Probleme insttallation/MAJ joomla 1.7/2.5

        NB : Je ne retrouve + le n° de version dans la partie admin; existe t-il une solution pour connaitre la version installée ?
        Dans la rubrique Infos Systèmes, en première page.

        Commentaire


        • #5
          Re : Probleme insttallation/MAJ joomla 1.7/2.5

          Envoyé par zepelin57 Voir le message
          Tu n'es pas en Php 5, il faut passer par une modification du htaccess en rajoutant en haut de page SetEnv PHP_VER 5_3.
          Bonjour,

          Voilà longtemps que je n'ai pas installé joomla, mais auparavant j'avais un fichier htaccess "spécial 1and1". Celui-ci ne fonctionne plus et ajouter la fameuse ligne "SetEnv PHP_VER 5_3" ne fonctionne pas pour moi.

          Sur l'installation de joomla 2.5, j'ai l'erreur suivante :
          Code HTML:
          Parse error: syntax error, unexpected '=', expecting '(' in /homepages/21/d266236597/htdocs/2012/includes/framework.php on line 42
          (et j'ai chargé sur deux dossiers différents, pour être sure que ce ne soit pas pb de chargement FTP, même problème)

          Sur l'installation d'un yootheme 1.7, j'ai bien la mention "
          Code HTML:
          Your host needs to use PHP 5.2.4 or higher to run Joomla 1.7.
          " et en mettant le code que vous notez plus haut en haut du htaccess, rien ne change.

          Si quelqu'un a un fichier type "1and1", comme il y a quelques années... ou simplement des conseils sur ce qui doit être changé,...

          A bon entendeur, merci beaucoup et bonne journée à vous !

          Marine

          Commentaire


          • #6
            Re : Probleme insttallation/MAJ joomla 1.7/2.5

            Pour info : chez 1&1, pour passer en PHP 5, on peut depuis quelques mois se passer de la ligne spécifique dans le .htaccess, car le paramétrage se fait depuis l'administration du compte 1&1 !
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              Re : Probleme insttallation/MAJ joomla 1.7/2.5

              Salut RobertG ! ça faisait longtemps ;-)

              Merci, je suis passée en "version globale PHP5" sur 1and1, mais toujours erreurs + J'ai ajouté "SetEnv PHP_VER 5_3" dans le htaccess et toujours erreurs...

              Sur le site joomla 1.1.7, j'ai le message : Your host needs to use PHP 5.2.4 or higher to run Joomla 1.7.
              sur les deux rep ou j'ai mis du jooomla 2.5 : Parse error: syntax error, unexpected '=', expecting '(' in /homepages/21/d266236597/htdocs/2012/includes/framework.php on line 42

              J'ai téléchargé la 2.5 ici : http://aide.joomla.fr/telechargement...tion-et-patchs

              Avez-vous une idée de ce qui se passe ?

              Merci,Marine

              Commentaire


              • #8
                Re : Probleme insttallation/MAJ joomla 1.7/2.5

                ERRATUM ! Mea culpa ! Je n'avais pas pris les bons répertoires donc ok, avec le message "SetEnv PHP_VER 5_3" ça fonctionne ! RobertG, tu me diras si ça fonctionne meme sans préciser la "version 3 de php 5" Merci en tout cas et désolée pour le dernier message. Bonne journée à vous !

                Commentaire


                • #9
                  Re : Probleme insttallation/MAJ joomla 1.7/2.5

                  SetEnv PHP_VER 5_3
                  n'est absolument pas fait pour 1&1 qui doit soit renvoyer une erreur 500 soit ignorer la ligne.
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                  Commentaire


                  • #10
                    Re : Probleme insttallation/MAJ joomla 1.7/2.5

                    Désolée je croyais que le terme était fait pour spécifier à l'hébergeur (1and1 pour mon cas) que l'on voulait utiliser la version 5.3 de PHP. Peu importe, ok JOOMLA 2.5 et 1.7 fonctionnent bien en passant sur option PHP5 sur espace client 1and1 : les messages "Your host needs to use PHP 5.2.4 or higher to run Joomla 1.7." et "Parse error: syntax error, unexpected '=', expecting '(' in /homepages/21/d266236597/htdocs/2012/includes/framework.php on line 42" n'apparaissent plus une fois la version PHP5 mise en place.

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X