Modification du template pas prise en compte

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Modification du template pas prise en compte

    Bonjour,


    Voilà mon problème :

    J'ai utilisé le template Ja_Social où j'ai procédé a des modifications comme l'ajout de nouvelle position (user11;user12,etc..). J'avais jusqu'à maintenant travaillé en local et tout fonctionné parfaitement.

    Or, depuis hier j'ai voulu mettre mon site en ligne pour voir le rendu ( impotation du dossier, bdd etc.. ).
    Mais les modifications faites sur l'ajout des nouvelles positions ne sont pas prise en compte, les modules qui étaient aux positions par défaut du template sont bien présentes, mais les modules aux nouvelles positions ne sont pas présente malgré leur activation .

    J'ai vérifié mes fichiers .css ce sont les bons, dans le panneau de configuration sous Joomla j'ai bien activé la couche FTP.

    PS : Les modifications couleurs, styles etc... ont bien étaient prises en compte. Pourquoi mes ajouts de positions ne fonctionnent pas ?

    Bien cordialement.

  • #2
    Re : Modification du template pas prise en compte

    Tu as un lien vers le site en ligne ?
    Tu peux nous faire une copie écran de ce que tu as en local pour comparer ?
    Cordialement,
    Chabi01 - http://www.xlformation.com

    Commentaire


    • #3
      Re : Modification du template pas prise en compte

      Envoyé par chabi01 Voir le message
      Tu as un lien vers le site en ligne ?
      Tu peux nous faire une copie écran de ce que tu as en local pour comparer ?
      Cordialement,
      Site : http://dublanchesteven.fr/Site1/
      Cliquez sur l'image pour l'afficher en taille normale

Nom : Site.jpg 
Affichages : 1 
Taille : 173,5 Ko 
ID : 1802184

      Commentaire


      • #4
        Re : Modification du template pas prise en compte

        Vérifie les conditions d'appel de tes modules : l'assignation en page d'accueil de modules manquant a t'elle bien suivi ainsi que les menus ?

        Pense à purger le cache également.

        Je pencherai pour la condition d'affichage qui ne marche pas plutôt qu'un problème sur le template...
        Cordialement,
        Chabi01 - http://www.xlformation.com

        Commentaire


        • #5
          Re : Modification du template pas prise en compte

          Oui les modules sont bien assignés à la page d'accueil.
          Je suis devenu un maniaque de "clean cache" (:

          Bon je vais tout effacer et réimporter tout le contenu.
          On verra bien ce que ça donne.
          Je vous tiens au courant.

          Commentaire


          • #6
            Re : Modification du template pas prise en compte

            Envoyé par chabi01 Voir le message
            Vérifie les conditions d'appel de tes modules : l'assignation en page d'accueil de modules manquant a t'elle bien suivi ainsi que les menus ?

            Pense à purger le cache également.

            Je pencherai pour la condition d'affichage qui ne marche pas plutôt qu'un problème sur le template...
            Cordialement,
            Toujours le même problème .
            J'ai essayé de placé un autre module en position 11 assigné à toutes les pages, mais pas d'affichage.
            Est-ce que je dois changer quelque chose d'autre pour que les modifications du template soient prise en compte ? .htaccess , configuration.php etc.. ??

            Commentaire


            • #7
              Re : Modification du template pas prise en compte

              Essaye une chose : désactive le sef et vois ce qui se passe.
              Contrôle également tes menus (reconstruire).
              Vérifie également que tu n'aies pas de conflit d'alias au niveau de tes articles et menus (2 alias identiques).

              Cordialement,
              Chabi01 - http://www.xlformation.com

              Commentaire


              • #8
                Re : Modification du template pas prise en compte

                Envoyé par chabi01 Voir le message
                Essaye une chose : désactive le sef et vois ce qui se passe.
                Contrôle également tes menus (reconstruire).
                Vérifie également que tu n'aies pas de conflit d'alias au niveau de tes articles et menus (2 alias identiques).

                Cordialement,
                J'avais même pas remarqué que le contenu des autres pages ne s'affichait pas, mais cela refonctionne en activant le sef.
                Malheureusement, les modules aux positions 11,12 et 13 ne s'affichent toujours pas.

                Que veux-tu dire par "Contrôle également tes menus (reconstruire)." ???

                Je rappel juste que les positions user11,user12 et user13 n'existaient pas par défaut, mais que j'ai modifié le code pour les créer. (Fonctionne en local)

                Commentaire


                • #9
                  Re : Modification du template pas prise en compte

                  Tu vas dans la gestion des menus, tu coches tous tes menus et tu cliques sur le bouton "reconstruire" en haut à droite de la fenêtre.
                  Cordialement,
                  Chabi01 - http://www.xlformation.com

                  Commentaire


                  • #10
                    Re : Modification du template pas prise en compte

                    Reconstruction : Done

                    Aucun changement à première vue

                    Commentaire


                    • #11
                      Re : Modification du template pas prise en compte

                      Bon.
                      Tu vas télécharger un plugin complémentaire pour ton site qui permet de contrôler quand les modules sont affichés.
                      Ce plugin se trouve ici :
                      http://www.nonumber.nl/extensions/advancedmodulemanager
                      Dès qu'il sera installé, tu verras que dans tes modules tu as plus d'option pour gérer les conditions d'affichage.
                      Tu ouvriras alors un de tes module et dans la partie droite de ton module, tu auras un nouvel "onglet" qui te permettra de régler le module sur "page d'accueil > Oui".
                      Essaye et reviens dire si cela fonctionne.

                      Cordialement,
                      Chabi01 - http://www.xlformation.com

                      Commentaire


                      • #12
                        Re : Modification du template pas prise en compte

                        Envoyé par chabi01 Voir le message
                        Bon.
                        Tu vas télécharger un plugin complémentaire pour ton site qui permet de contrôler quand les modules sont affichés.
                        Ce plugin se trouve ici :
                        http://www.nonumber.nl/extensions/advancedmodulemanager
                        Dès qu'il sera installé, tu verras que dans tes modules tu as plus d'option pour gérer les conditions d'affichage.
                        Tu ouvriras alors un de tes module et dans la partie droite de ton module, tu auras un nouvel "onglet" qui te permettra de régler le module sur "page d'accueil > Oui".
                        Essaye et reviens dire si cela fonctionne.

                        Cordialement,
                        Arf au moment de l'upload j'ai le message :
                        "This extension is not compatible with PHP 5.2.17. You need PHP 5.3 or higher to be able to install and use this extension."

                        Comment je fais pour régler ce problème ?

                        J'ai essayé de rajouter "AddType x-mapp-php5 .php" dans mon .htaccess mais ça doit pas être la bonne solution

                        Commentaire


                        • #13
                          Re : Modification du template pas prise en compte

                          Tu es chez quel hébergeur ?
                          Chabi01 - http://www.xlformation.com

                          Commentaire


                          • #14
                            Re : Modification du template pas prise en compte

                            Envoyé par chabi01 Voir le message
                            Tu es chez quel hébergeur ?
                            Je suis chez ovh

                            Commentaire


                            • #15
                              Re : Modification du template pas prise en compte

                              Dans ton fichier htaccess, à la fin, de celui-ci, tu ajoutes les lignes suivantes :
                              Code:
                              SetEnv PHP_VER 5_3
                              SetEnv REGISTER_GLOBALS 0
                              Ton fichier doit impérativement être renommé en .htaccess si ce n'est pas le cas.
                              Cordialement,
                              Chabi01 - http://www.xlformation.com

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X