Défaut d'affichage pendant le processus d'installation

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Défaut d'affichage pendant le processus d'installation

    Bonjour à tous !

    Je rencontre un problème pendant le processus d'installation de Joomla 2.5.14 sur un Ubuntu Server 12.04 x86, apache2 php5 mysql-server libapache2-mod-php5 php5-mysql fraichement installés.

    J'ai dézippé le contenu de Joomla_2.5.14-Stable-Full_Package_FR.zip dans mon répertoire /var/www/site-joomla (chown & chmod OK), ensuite j'y accède par mon navigateur (Firefox) afin de finaliser l'installation, et voici le résultat :

    Cliquez sur l'image pour l'afficher en taille normale

Nom : joomla.JPG 
Affichages : 1 
Taille : 70,5 Ko 
ID : 1819768

    Quel est le problème ?

    Merci d'avance !

    Cordialement,
    Valentin.

  • #2
    Re : Défaut d'affichage pendant le processus d'installation

    A mon avis tous ces mots_avec_underscore sont des appels pour des lignes de texte du fichier de langue (français dans ton cas, je suppose). En principe, en cas d'absence du français, il devrait au moins y avoir de l'anglais. Peut-être que le choix de la langue est mal configuré dans le config.php ?
    Je cherche toujours la solution moi-même avant de venir vous tanner

    Commentaire


    • #3
      Re : Défaut d'affichage pendant le processus d'installation

      Bonjour,

      et bienvenue sur le forum.

      Problème semblant redondant sur Ubuntu. La session ne s'enregistre pas.

      Quels sont les droits de /var/lib/php5 (où les sessions sont stockées durant l'installation, ensuite, par défaut, Joomla! les gère en base de données) ?

      Quel module apache pour PHP est-il activé ? mod_php, SuExec, SuPHP, PHP-PFM ?
      Suivant les cas, la configuration apache est différente pour une gestion correcte des sessions.

      /var/www/site-joomla est-il le host par défaut ou est-il défini en tant que VHost ?

      Pas de demande de support par MP.
      S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

      Commentaire


      • #4
        Re : Défaut d'affichage pendant le processus d'installation

        Envoyé par boumy Voir le message
        A mon avis tous ces mots_avec_underscore sont des appels pour des lignes de texte du fichier de langue (français dans ton cas, je suppose). En principe, en cas d'absence du français, il devrait au moins y avoir de l'anglais. Peut-être que le choix de la langue est mal configuré dans le config.php ?
        Envoyé par jisse03 Voir le message
        Bonjour,

        et bienvenue sur le forum.

        Problème semblant redondant sur Ubuntu. La session ne s'enregistre pas.

        Quels sont les droits de /var/lib/php5 (où les sessions sont stockées durant l'installation, ensuite, par défaut, Joomla! les gère en base de données) ?

        Quel module apache pour PHP est-il activé ? mod_php, SuExec, SuPHP, PHP-PFM ?
        Suivant les cas, la configuration apache est différente pour une gestion correcte des sessions.

        /var/www/site-joomla est-il le host par défaut ou est-il défini en tant que VHost ?

        Merci pour vos réponses !

        Donc Ubuntu poserait problème si je comprends bien !

        Une installation sur Debian serait plus judicieuse ? J'en ai pas pour longtemps ...

        Commentaire


        • #5
          Re : Défaut d'affichage pendant le processus d'installation

          ça fait longtemps que je n'ai plus trop utilisé de Debian Like

          Testes avec Debian, mais là, Attention, n'utilises PAS le /var/www par défaut, mais crées impérativement un VHost, et si possible avec le moteur SuPHP, PHP-PFM ou FastCGI plutôt que mod_php, qui lui pose systématriquement des problèmes de droits.
          Pas de demande de support par MP.
          S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

          Commentaire


          • #6
            Re : Défaut d'affichage pendant le processus d'installation

            D'accord, merci pour ces précisions !

            Sur quoi faites-vous tourner vos Joomla alors ?

            Commentaire


            • #7
              Re : Défaut d'affichage pendant le processus d'installation

              En général sous CentOS, Fedora et Opensuse.
              Pas de demande de support par MP.
              S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

              Commentaire


              • #8
                Re : Défaut d'affichage pendant le processus d'installation

                Mêmes soucis avec la version full FR 2.5.14
                je suis sur un serveur dédié OVH installé sous debian
                j'ai installé la version 2.5.8 que j'avais en archive update vers 2.5.14 sans soucis

                pour faire avancer
                JP

                Commentaire


                • #9
                  Re : Défaut d'affichage pendant le processus d'installation

                  Le serveur est-il configuré correctement? Voir un tuto http://knzl.de/setting-up-chrooted-p...debian-wheezy/
                  Pas de demande de support par MP.
                  S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                  Commentaire


                  • #10
                    Re : Défaut d'affichage pendant le processus d'installation

                    Bonjour,
                    Pour terminer votre installation, vous avez un problème des droits ...
                    il faut aller dans le répertoire installation dans votre cas
                    cd /var/www/site-joomla/installation
                    après > chmod 777 *
                    et voilà le problème est résolu !!!
                    pour la sécurité vous n'inquiétez pas car à la fin de l'installation on vous demande de supprimer ce répertoire.
                    vous allez finir la configuration en choisissant la langue
                    la page suivant il va vous demander l'utilisateur et le mot de passe et la base de donnée, je vous conseille de créer la base de donnée:
                    root@>mysql
                    mysql> CREATE DATABASE nom_de_la_base;
                    mysql> USE nom_de_la_base
                    vous aurez ce message
                    Database changed
                    Vous pouvez ajouter de nouveaux utilisateurs en utilisant des commandes GRANT :
                    mysql> GRANT ALL PRIVILEGES ON *.* TO 'nom_user'@'locahost' //accès depuis le poste locale
                    -> IDENTIFIED BY 'un_mot_de_passe' WITH GRANT OPTION;
                    ou bien
                    mysql> GRANT ALL PRIVILEGES ON *.* TO 'nom_user'@'%' //depuis n'importe quel autre serveur
                    -> IDENTIFIED BY 'un_mot_de_passe' WITH GRANT OPTION;

                    après si à vous de voir les droits d'accès à la basse ----->>>> voir la commande 'GRANT'
                    Dernière édition par amda à 08/11/2013, 00h18

                    Commentaire


                    • #11
                      Re : Défaut d'affichage pendant le processus d'installation

                      Bonjour,

                      et bienvenue sur le forum.

                      Envoyé par amda Voir le message
                      Pour terminer votre installation, vous avez un problème des droits ...
                      il faut aller dans le répertoire installation dans votre cas
                      cd /var/www/site-joomla/installation
                      après > chmod 777 *
                      et voilà le problème est résolu !!!
                      Le passage en 777 est certainement la pire des choses qui soient. Avec mod_php, à la rigueur, ça fonctionne, mais en créant une faille de sécurité assez énorme au niveau serveur.
                      Sous SuExec, SuPHP ou php-pfm, il s'agit d'une outrepassation des droits générant une SoftInterrupt => erreur 500.

                      Dans ce cas de figure précis, il doit s'agir d'une installation Debian (ou dérivés) brute, donc avec mod_php, et des droits incorrects (owner différent de apache) qui provoquent ce problème d'affichage.
                      Pas de demande de support par MP.
                      S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                      Commentaire


                      • #12
                        Re : Défaut d'affichage pendant le processus d'installation



                        Le passage en 777 est certainement la pire des choses qui soient. Avec mod_php, à la rigueur, ça fonctionne, mais en créant une faille de sécurité assez énorme au niveau serveur.
                        J'avais le même problème avec cette version de joomla sur un SME SERVER 8 !!!
                        le passage en 777 il faut faire attention !!!! dans ce cas je ne vois pas de de problème, pour plus de précision il faut aller dans /var/www/site-joomla/installation et faire chmod 445 language au lieu de faire un chmod 777 installation comme j'ai précisé dans le message précédent.
                        Dernière édition par amda à 09/11/2013, 22h59

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X