Migration de joomla 2.5.19 vers 3,4

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Migration de joomla 2.5.19 vers 3,4

    Bonjour à tous et toutes.

    Voilà, mon site est actuellement en 2.5.19, il est à jour ainsi que ses extensions, je n'ai pas de problèmes particuliers pour le moment.

    Je suis en train de réfléchir, de préparer ma migration vers Joomla 3.4 (date de sortie en juillet 2014 apparemment).

    Je compte tout réinstaller à partir de la dernière version de Joomla 3.

    Je suis en train de tester tout et n'importe quoi en local pour arrivé le jour J, être bien préparer.

    Donc je suis en train de tester :

    • Exporter/Importer ma table content et ma table catégories à partir de phpmyadmin
    • Exporter/importer à partir de j2xml3


    Pour éviter de me taper des copiés-colles de tous mes articles, catégories etc.....

    À noter que j'ai choisi des extensions qui existent pour Joomla 2.5 et Joomla 3, excepté Allevents qui n'est pas dispo pour Joomla 3 sauf en beta.

    Avec plus ou moins de bonheur, quelques bugs, des espoirs et désespoirs, bon c'est pas grave, je me prépare, c'est pour tester.

    Je peux par exemple Exporter/Importer à partir de PhpMyadmin sans soucis ma table content ou ma table categories mais pas les deux, j 'ai des messages d'erreurs .

    Avec J2xml j'ai des messages d'erreurs comme quoi il y a un truc qui est ''depreciated'' à partir de joomla3.

    C'est pour ça, que j'ai l'impression que je vais me taper des copiés-collés à n'en plus finir

    Ma question est la suivante :

    Faut-il que j'attende pour commencer ma migration la sortie de Joomla 3.4 en juillet ou puis-je déjà la commencer pour ne plus qu'à mettre à jour ensuite de la version Joomla 3...... vers la version de juillet 3.4?

    En gros puis-déjà commencer ma migration à partir de la dernière version de Joomla 3 (Joomla 3.23) pour ensuite avoir seulement en juillet 2014, faire une mise à jour vers Joomla 3.4?

    Ou vaut-il mieux commencer ma migration à partir de Joomla 3.4 en juillet.

    Parce que ......je n'ai pas compris grand chose sur les nouvelles versions mineures, les versions majeures

    Merci à vous pour vos réponses.
    Gros débutant sous Joomla et surtout gros galérien.....mais je bosse.

    Mons site en ligne depuis le 1er septembre 2013 : https://escrime-3-frontieres.fr/

  • #2
    Re : Migration de joomla 2.5.19 vers 3,4

    Bonjour,

    si tu souhaites passer ce site en version 3.x, attends quelques jours et la sortie de Joomla 3.3

    Par contre, rien ne dit que Joomla 3.4 sera la dernière version de la branche Joomla 3.x.
    JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

    Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

    Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous
    Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

    Commentaire


    • #3
      Re : Migration de joomla 2.5.19 vers 3,4

      Bonjour et merci de ta réponse.


      Mais à titre perso et techniquement, vous feriez quoi vous?

      Rester sur Joomla 2.5.19 en attendant une version majeur (version 4 attendu pour ??????) ou migrer vers la version 3.3 de suite pour mettre à jour ensuite sur Joomla 3.4 en juillet et ainsi de suite?

      Il vaut quand même mieux migrer vers un Joomla 3.3 ou 3.4, techniquement c'est mieux non, c'est plus sécurisé?

      Merci.
      Gros débutant sous Joomla et surtout gros galérien.....mais je bosse.

      Mons site en ligne depuis le 1er septembre 2013 : https://escrime-3-frontieres.fr/

      Commentaire


      • #4
        Re : Migration de joomla 2.5.19 vers 3,4

        Il vaut quand même mieux migrer vers un Joomla 3.3 ou 3.4, techniquement c'est mieux non, c'est plus sécurisé?
        Pour la sécurité, c'est équivalent, Joomla 2.5 et 3.x sont deux versions supportées. Pour les fonctionnalités, Joomla 3.x apporte beaucoup de nouveautés.
        Il serait nécessaire de connaitre le site et les extensions utilisées, mais dans tous les cas, attendre la sortie de Joomla 3.3, d'ici quelques jours.
        JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

        Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

        Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous
        Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

        Commentaire


        • #5
          Re : Migration de joomla 2.5.19 vers 3,4

          Avec J2xml j'ai des messages d'erreurs comme quoi il y a un truc qui est ''depreciated'' à partir de joomla3.
          Si tu indiquais les messages exacts on pourrait peut-être essayer de comprendre ce qui se passe.
          Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
          C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
          Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

          Commentaire


          • #6
            Re : Migration de joomla 2.5.19 vers 3,4

            Bonjour à tous.

            Merci pour vos réponses. À vrai dire je n'ai pas de soucis particuliers pour le moment, j'essaie de préparer au mieux ma migration pour éviter bêtises et tourments.

            Pour SimonG

            Il serait nécessaire de connaitre le site et les extensions utilisées, mais dans tous les cas, attendre la sortie de Joomla 3.3, d'ici quelques jours.
            J'ai beaucoup d'extensions, voilà la liste complète (c'est un copié-collé) :

            • com_acymailing_starter_4.6.2 → Mise à jour le 31 mars 2014
            • cupdater-2.0
            • plg_tooltipgc_3.0.2_J25
            • com_aicontactsafe_2_0_21c_stable
            • com_allevents_free_full_j25_stable
            • plg_jatypobutton.v2.5.9 → Mise à jour 28 décembre 2013
            • plg_system_jatypo.v2.5.6 → Mise à jour 28 décembre 2013
            • com_phocadownload_v2.1.9
            • fr-FR.com_phocadownload-j25

            plg_content_phocadownload_v2.1.6

            • plg_editors-xtd_phocadownload_v2.1.4
            • Phoca download button plugin
            • com_mijopolls-free
            • lang_fr-FR.com_mijopolls_j25
            • jsecure_joomla 3.0.2
            • plg_maximenuck_params_2.2.3_j25 → Mise à jour le 13 novembre 2013
            • mod_maximenuck_6.2.9_j25 → Mise à jour le 09 avril 2014
            • plg_jw_allvideos-v4.5.0_j1.5-2.5-3.0
            • JCE 2.3..4.4 → Mise à jour le 28 décembre 2013
            • Xmap 2.3.4 → Mise à jour le 20 novembre 2013
            • Plugin JTS Webmaster Verify 1.1.0
            • Plugin Piwik 2.5.1
            • Highslide JS pour Joomla 2.5.3
            • Highslide JS Profils 2.5.0
            • Akkeba back-up : 3.10.2 → Mise à jour le 20 mars 2014
            • Joomla 2.5.17 → Mise à jour le 28 décembre 2013
            • Jsn_Mico_pro 2.0.1 → Mise à jour le 14 février 2014
            • Framework Joomlashine 2.1.7 → Mise à jour le 07 avril 2014

            mod_slideshowck_1.4.1 → Mise à jour le 09 avril 2014


            Je compte rajouter, dès que je peux la version payante de Aesecure.

            De toute façon, j'ai des extensions compatibles en Joomla 2.5 et Joomla 3, mais certaines ne sont compatibles que Joomla 2.5 mais existent tout de même pour la version Joomla 3. Donc pour la migration je suis chocolat, je vais devoir ré-installé un Joomla 3.3 et ré-installé les extensions cmpatbale pour cette version et ensuite.....ben me démerder pour les articles, les catégories, les menus.

            Le site en question est --> http://escrime-3-frontieres.fr/


            Pour Lesoutier

            Si tu indiquais les messages exacts on pourrait peut-être essayer de comprendre ce qui se passe.
            Du coup, j'ai tellement fait d'essais, je ne rappelle plus ce message d'erreurs sont dus à J2xml3 ou mon export/import de ma table TRUC_content, ah si, je crois que c'est avec l'utilisation de j2xml3Bon je donne le message d'erreurs qui apparaît :

            Cliquez sur l'image pour l'afficher en taille normale

Nom : Sélection_002.jpg 
Affichages : 1 
Taille : 26,3 Ko 
ID : 1803407



            Je vous explique comment j'ai effectué ce export/import de cette table TRUC_content, j'ai bidouillé, je ne sais pas si c'est comme ça qu'il fallait faire.

            1°) J'ai exporter ma table TRUC_content à partir de MyPhpAdmin de mon site en Joomla 2.5

            2°) J'ai installé un Joomla 3.23 neuf, sans données d'exemple

            3°) J'ai importé ma table TRUC_content de Joomla 2.5 dans mon Joomla 3.23

            4°) J'ai supprimé ma table MACHIN_content de Joomla 3.23

            5°) J'ai renommé ma table TRUC_machin (de Joomla 2.5) en MACHIN_content (Joomla 3.23)


            Apparemment ça se passe bien sauf que si je fais pareil avec ma table TRUC_categories ça bug et là, j'ai plein de messages d'erreurs, c'est dommage, ça m'aurait éviter les copiés-collés par dizaines.
            Gros débutant sous Joomla et surtout gros galérien.....mais je bosse.

            Mons site en ligne depuis le 1er septembre 2013 : https://escrime-3-frontieres.fr/

            Commentaire


            • #7
              Re : Migration de joomla 2.5.19 vers 3,4

              Bonjour,

              puisque tu testes, sais tu que Akeeba, bien connu pour son logiciel de sauvegarde, a en ce moment une version (beta) appelée Akeeba CMS Update qui aide à passer de la version 2.5.6 et + jusqu’à la version courante de Joomla (3.2.x), et qu'il le fait naturellement en tout sécurité puisqu'il commence par sauvegarder ton environnement.

              https://www.akeebabackup.com/download/cmsupdate.html

              A priori ça a l'air très prometteur
              Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

              Commentaire


              • #8
                Re : Migration de joomla 2.5.19 vers 3,4

                Bonjour.

                En réponse à PieceOfCake.

                Je viens de tester le composant com_cmsupdate-1.0.a3.

                Je l'ai installé, j'ai updaté mon site 2.5.19 (toujours en local) vers Joomla 3.23, tout s'est apparemment bien passé.

                Si je ne pars pas de ma page, j'ai bien mon administration en Joomla 3.23.

                Malheureusement : page blanche sur l'accueil du site, plus de style css, page blanche si je me déconnecte et page blanche sur l'administration du site si je me déconnecte.


                Bon, je ne m'inquiète pas, c'est une version Alpha et en plus je suis sous Ubuntu et j'ai remarqué que lors de cette migration avec ce composant tous mes fichier Joomla avaient un cadenas (en lecteur seule).

                Merci à Toi PieceOfCake.
                Gros débutant sous Joomla et surtout gros galérien.....mais je bosse.

                Mons site en ligne depuis le 1er septembre 2013 : https://escrime-3-frontieres.fr/

                Commentaire


                • #9
                  Re : Migration de joomla 2.5.19 vers 3,4

                  Pas de quoi, c'est moi qui te remercie, je l'essaierai en local pour la migration de la 3.2.3 vers le 3.3 prochaine

                  Cordialement
                  Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                  Commentaire


                  • #10
                    Re : Migration de joomla 2.5.19 vers 3,4

                    Bonsoir

                    Envoyé par Kawawachikamach Voir le message
                    com_allevents_free_full_j25_stable
                    As-tu bien pris note qu'aujourd'hui, AllEvents n'est pas encore dispo pour Joomla 3. Il y a une version Alpha qui est en cours de développement mais rien de stable.

                    Bonne soirée.
                    Christophe (cavo789)
                    Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

                    Commentaire


                    • #11
                      Re : Migration de joomla 2.5.19 vers 3,4

                      Bonjour Cavo789


                      Oui, je sais que Allevents n'est pas encore disponible pour Joomla 3 c'est pour cela que je ne me presse pas et que je réfléchit comment faire ma migration.


                      En fait, toutes mes extensions sont disponibles en Joomla 3 et Joomla 2.5 sauf Allevents mais comme j'apprécie ce composant, je l'ai quand même installé en attendant la sortie de la version pour Joomla 3.

                      Et puis entre Aesecure et Allevents, je suppose que tu as pas mal de boulot.


                      Joyeuses Pâques à vous tous.
                      Gros débutant sous Joomla et surtout gros galérien.....mais je bosse.

                      Mons site en ligne depuis le 1er septembre 2013 : https://escrime-3-frontieres.fr/

                      Commentaire


                      • #12
                        Re : Migration de joomla 2.5.19 vers 3,4

                        Je m'axe sur aeSecure, un ami développeur est sur les charbons pour la migration AllEvents.
                        Christophe (cavo789)
                        Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                        Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X