Problème lors de l'affichage du sélecteur de langues

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème lors de l'affichage du sélecteur de langues

    Bonjour,

    Je suis en 1.7 et j'essaie de construire un site multilingue. Après avoir suivi à la lettre le PDF expliquant comment configurer le sélecteur de langue, le module s'affiche bien dans ma page avec le titre SELECTEUR DE LANGUE, mais la liste des langues est vide. Idem pour les drapeaux qui ne s'affichent pas.

    Comme j'ai lu sur certains forums, cela peut-il venir de mon template, et dans ce cas suis-je condamnée à l'abandonner ou y a-til une autre solution (modification du template ou autre) sachant que j'ai bien suivi les instructions du tutorial ?

    Je suis un peu désespérée, j'espère que vous m'aiderez à trouver une solution...
    Dernière édition par infograf768 à 08/11/2011, 12h22

  • #2
    Re : Problème lors de l'affichage du sélecteur de langues

    Avez-vous suivi précisément les instructions de
    http://multilingual-joomla-demo.clou...ltilangue.html

    Si oui, faites une capture d'écran du module Statut Multilangue et postez ici.
    Jean-Marie Simonet / infograf768
    Joomla co-fondateur. Joomla Production Working Group.
    Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

    Commentaire


    • #3
      Re : Problème lors de l'affichage du sélecteur de langues

      Bonjour j'ai le même souci !

      Je vous ai fait une capture du front et de la config de mon switcher.

      J'ai 3 menus.
      Le premier ne contient que la page par défaut (sans contenu).
      Les deux autres sont les menus de navigation Anglais et Français avec les menu associées.
      Fichiers joints

      Commentaire


      • #4
        Re : Problème lors de l'affichage du sélecteur de langues

        Et même réponse...
        Mettez à jour en 1.7.2.
        Publiez le module administrator Statut Multilangue et postez une capture d'écran du modal affiché par le module.
        Jean-Marie Simonet / infograf768
        Joomla co-fondateur. Joomla Production Working Group.
        Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

        Commentaire


        • #5
          Re : Problème lors de l'affichage du sélecteur de langues

          Merci pour votre réponse.

          Je suis déjà en 1.7.2.

          Voici la capture du module... Si c'est ce que vous appelez le "modal"...
          Cliquez sur l'image pour l'afficher en taille normale

Nom : Capture2.JPG 
Affichages : 1 
Taille : 41,0 Ko 
ID : 1798115
          Fichiers joints

          Commentaire


          • #6
            Re : Problème lors de l'affichage du sélecteur de langues

            Et, comme vous pouvez le voir, il n'y pas de page d'acceuil par défaut pour les langues de contenu.
            Voir les tutoriels.
            http://forum.joomla.fr/showthread.ph...ans-joomla-1.7
            Jean-Marie Simonet / infograf768
            Joomla co-fondateur. Joomla Production Working Group.
            Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

            Commentaire


            • #7
              Re : Problème lors de l'affichage du sélecteur de langues

              Merci pour ces tutoriels que j'ai déjà consulté...

              Le souci est que je n'ai pas de menu (affiché sur mon FO) avec un menu pour la page d'accueil... Le logo sert de retour a la page d'accueil.

              Comment procéder dans un cas tel que le mien.

              Pour rappel 3 menus:
              -HomePage (pas de module "menu" associé)
              ----Un seul menu page pas défaut
              -Main Menu
              ----Menu en anglais
              -Menu Principal
              ----Menu en français.
              Dernière édition par dutom007 à 31/10/2011, 17h43

              Commentaire


              • #8
                Re : Problème lors de l'affichage du sélecteur de langues

                Le tutoriel explique très clairement qu'il vous faut un élément de menu page d'accueil par defaut pour chaque langue de contenu.
                Sans cela, le multingue ne fonctionnera jamais.

                Cela marchera sans afficher de module pour ces menus spécifiques.
                Votre click dans le logo renverra toujours vers la Page d'accueil, quelque soit la langue.

                Créez donc 2 nouveaux menus, un pour l'anglais (DEFAUT-EN), un pour le francais (DEFAUT-FR) ainsi qu'un element de menu Page d'accueil par défaut taggé dans chacun à la langue désirée.

                Supposons que votre page d'accueil afffiche des articles Mis en vedette. Si vous avez suivi le tutoriel, vous aurez sans doute pour chaque langue des articles mis en vedette et taggés à chacune des langues. Ce sont ceux-ci qui seront affichés, ainsi que les articles taggés à langue "Toutes".
                Dans ce cas, l'élément de menu page daccueil par défaut dans DEFAUT-FR ainsi que celui dans DEFAUT-EN seront tous deux du type "Blog des articles en vedette".
                Jean-Marie Simonet / infograf768
                Joomla co-fondateur. Joomla Production Working Group.
                Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                Commentaire


                • #9
                  Re : Problème lors de l'affichage du sélecteur de langues

                  Merci pour c'est explication.

                  Je suis parvenu au résultat. Il m'aura fallu créer 3 menus factices en plus de mes 2 menus (FR et EN).
                  L'un contient un menu par défaut pour toutes les langues, un autre pour la FR et un autre pour la EN... Heureusement que je n'ai pas 5/6/7 langues...

                  Dans mon cas la page d'accueil n'est rien d'autre qu'un slider d'image.. Aucun contenu... C'est pour cela que je trouvais logique d'avoir un seul menu par défaut pour toutes les langues...

                  Commentaire


                  • #10
                    Re : Problème lors de l'affichage du sélecteur de langues

                    Bonjour, moi je suis sur la version 1.7.3 FRv2 est impossible d'afficher le sélecteur de langues... pourtant j'ai respecter la procédure à la lettre... Une idée ?
                    Merci d'avance pour votre aide

                    Commentaire


                    • #11
                      Re : Problème lors de l'affichage du sélecteur de langues

                      Voir ici:
                      http://multilingual-joomla-demo.clou...ltilangue.html

                      Vous pouvez vous logger en back-end pour mieux voir
                      Jean-Marie Simonet / infograf768
                      Joomla co-fondateur. Joomla Production Working Group.
                      Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                      Commentaire


                      • #12
                        Re : Problème lors de l'affichage du sélecteur de langues

                        Bonjour, merci pour votre réponse, j'ai fais comme indiqué, mais si je choisi la liste déroulante, rien ne s'affiche à l'intérieur, et si je choisi les drapeaux ils ne s'affichent pas... Y a t'il quelque chose à installer ou ré installer ?
                        Merci de votre aide.

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X