Est-ce que ça vous le coup ?

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Est-ce que ça vous le coup ?

    Est-ce que ça vous le coup de passer à la version 1.6 au risque de devoir tout réapprendre quand on connait déjà bien la version 1.5 ?
    J'hésite franchement à passer le cap.

    [Modo]Je déplace la discusion, le sujet traité n'a rien à voir avec le développement[/Modo]
    Dernière édition par cavo789 à 05/08/2011, 09h54 Raison: Déplacement

  • #2
    Re : Est-ce que ça vous le coup ?

    La version 1.5 ne sera plus maintenue au milieu du printemps prochain, ce qui veut dire que si des failles de sécurité sur Joomla! et sur ses extensions sont découvertes, elles ne seront plus corrigées et les sites 1.5 seront définitivement vulnérables.
    Maintenant, à toi de voir si les extensions que tu utilises sont disponibles en version 1.6/1.7 pour pouvoir migrer, sachant que tu n'auras certainement pas à "tout réapprendre".
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

    Commentaire


    • #3
      Re : Est-ce que ça vous le coup ?

      oui , il y a pas a tout réapprendre (la majorité des classes restent) , je souligne aussi les nouveautés comme l'ACL et les groupes qui sont essentiels , et qui facilite grandement le développement et augmente beaucoup la productivité .

      en résumé , oui , dés que possible , il faut passer a 1.7
      DesignBoh ( designboh.com ) agence de communication en Tunisie. Experts Joomla et Wordpress.

      Mon blog : http://bouziri-tarak.blogspot.com/

      Commentaire


      • #4
        Re : Est-ce que ça vous le coup ?

        Je resterai plus modéré : la 1.5 devant être maintenue jusqu'en avril 2012, il n'y a pas urgence à migrer en 1.7
        On peut très bien, sauf si on a besoin de cette gestion avancée des groupes de membres et de leurs droits, rester pour l'instant en 1.5 et ne passer à la 1.8.x qu'au printemps prochain.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #5
          Re : Est-ce que ça vous le coup ?

          Bonjour mois je suis passer en version 1.7 et j'en suis content pas de souci a déclarer la migration s'est bien passer j'ai bientôt fini ma migration tous se passe bien et s'est vrais que de passer de la version 1.5 a 1.7 s'est pas mal pour la sécurité mais bon faudra bien un jours passer a la 1.7 pour quoi attendre de toute façon faudra migrer en plus si tu a un souci y a une bonne communauté .

          Commentaire


          • #6
            Re : Est-ce que ça vous le coup ?

            J'apporte mon grain de sel... si ton site est en ligne... ce que je suppose, tu doit savoir que le kit de hack "metasploit" propose de dézinguer toutes les version 15.22 de joomla...

            ce qui devrait répondre a ta question, quand a la version 1.7, c'est pas la mer a boire, (je suis dessus) mais c'est un peut buggé quand même... enfin de toutes façons pas le choix, good luck...

            Commentaire


            • #7
              Re : Est-ce que ça vous le coup ?

              Bonjour à tous,
              Je profites de ce fil pour exprimer mes incompréhensions (j'espère que c'est au bon endroit) par rapport aux cycles ultra rapides de mises à jour de joomla. Je suis un utilisateur "ancien" (venant de mambo au départ et ayant suivi l'équipe joomla ensuite) et j'avoue que je suis perplexe devant toutes ces annonces de patchs et de nouvelles versions.

              J'ai des sites sous 1.00 (et oui) sous 1.5.23, 1.6.5 et bientôt sous 1.7 etc, et je me trouve devant des complications grandissantes devant les changements de versions mysql, php et je ne parle pas des extensions et de leur mises à jour...

              Un exemple tout bête, j'ai fait migrer mon site principal sur 1.6 (perdu tout le site parce que le patch n'était pas au point) et maintenant je ne peux plus installer virtuemart car il n'est pas du tout opérationnel en production (trop de bug encore) et je me lasse de visiter leur site en voyant que la version pour joomla 1.7 ne pointe pas encore le bout de son nez...

              Ceci dit je comprends aussi les mises à jour, à mon avis c'est un gage de qualité et de fiabilité qu'apporte là l'équipe, mais peut-être serait-il intéressant que vous mettiez en place une rubrique "joomla user" par exemple où l'on trouverait La version de joomla la plus récente et la plus compatible avec le maximum d'extensions (les + utilisées comme joomfish, virtuemart, etc) avec un listing court des versions de serveurs mysql et php.
              Et puis toutes les annonces de mises à jour seraient pour les "joomla dev" qui sont en tests ?

              Bon peut-être je n'ai pas compris les cycles de mises à jour mais bon voilà c'est dit, je ne suis pas développeur mais plutôt "designer" de sites, du coup j'ai le sentiment de me transformer de plus en plus en "megatesteur".

              Bonne journée à tous, Lionel.

              Commentaire


              • #8
                Re : Est-ce que ça vous le coup ?

                perdu tout le site parce que le patch n'était pas au point
                Avec l'expérience que tu as, puisqu'ayant commencé avec Mambo, j'ai du mal à comprendre que tu aies pu perdre ton site, à moins que tu aies totalement négligé d'en faire une sauvegarde avant cette tentative de migration.
                Pourquoi avoir migré ce site sans être certain de la compatibilité des extensions ?
                Il est en effet dit et répété que la migration n'a d'intérêt que lorsque les extensions utilisées sur le site 1.5 de production ont leur version 1.6/1.7 fonctionnelle.
                Personnellement, je n'ai à ce jour migré qu'un seul site de 1.0 à 1.6 il y a quelques semaines, parce qu'il n'utilisait aucune extension particulière et qu'on a pu partir sur des améliorations utilisant des extensions spécifiques 1.6, mais les autres sites que je gère attendront que leurs extensions soient disponibles en 1.7 ou 1.8, quitte à attendre, pour migrer, le printemps 2012 que la 1.5 ne soit plus maintenue.

                C'est aux développeurs d'extensions d'annoncer avec quelles versions de Joomla! leurs produits sont compatibles, ce que tu peux voir sur le JED, chaque extension étant estampillée de l'image de sa compatibilité, ou directement sur le site de ces éditeurs.
                Et sur le JED, répondant indirectement à ta question, il y a une section "1.6 compatible" depuis des mois.
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                Commentaire


                • #9
                  Re : Est-ce que ça vous le coup ?

                  Oui bien sur j'avais une sauvegarde
                  Je comprends bien tout ce que tu me dis et je suis d'accord avec toi. Mais il me semble qu'il manque encore une distinction plus claire pour ce qui est du dev et de la prod, mais ce n'est que mon avis perso

                  Commentaire


                  • #10
                    Re : Est-ce que ça vous le coup ?

                    Donc tu n'as pas perdu ton site !

                    Joomla! 1.7, à partir du moment où c'est une version stable, n'a aucune raison de ne pas être utilisé en production. Ce n'est pas une version de développement.
                    C'est un peu comme si tu voulais acheter le dernier modèle de voiture de ta marque préférée et que tu en veuilles au constructeur parce qu'un accessoiriste extérieur à l'entreprise n'a pas encore sorti le jeu de couvre-sièges ou le pommeau de changement de vitesses customisé qui te plairait ! Ce n'est parce que ces accessoires ne sont pas disponibles que la voiture ne vaut pas d'être achetée !
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                    Commentaire


                    • #11
                      Re : Est-ce que ça vous le coup ?

                      Merci pour les réponses, en plus un article sur l'avenir des versions de Joomla éclaircie bien l'ensemble, je crois que cette fois c'est clair pour tout le monde !
                      Merci à l'équipe Joomla
                      Lionel

                      Commentaire


                      • #12
                        Re : Est-ce que ça vous le coup ?

                        Bonjour,

                        Si tui dois dévellopper un nouveau site, pour moi, il n'y a pas photo : il faut partir sur la version 1.7 qui est stable ... sauf si tu ne trouves pas toutes les extensions que tu veux en 1.6
                        Didier L
                        Le webmaster de quelques sites associatifs développés sur Joomla !

                        Commentaire


                        • #13
                          Re : Est-ce que ça vous le coup ?

                          Bonjour.

                          Pour ma part, j'ai deux sites, 1 sous 1.5 et l'autre sous 1.7.
                          Je ne rencontre aucun problème, mise a part quelques problème pour retrouvé certains module compatible avec 1.7, mais sinon, R.A.S!!!

                          Commentaire


                          • #14
                            Re : Est-ce que ça vous le coup ?

                            Envoyé par eliot Voir le message
                            mise a part quelques problème pour retrouvé certains module compatible avec 1.7, mais sinon, R.A.S!!!
                            C'est bien ça le probleme, des composants que j'utilise comme CK forms, communicator, remository n'ont pas encore migré sans parler du template, alors je voudrais bien migrer, j'aime bien être à jour j'attends mais je crains que joomla aille plus vite que les développeurs d'extensions et qu'ils arrivent toujours en retard
                            l'île d'Oléron c'est la mer à la campagne. www.lepecheurresponsable.com

                            Commentaire


                            • #15
                              Re : Est-ce que ça vous le coup ?

                              Je vous renvoie également sur la distinction à faire entre la 1.5 et les suivantes ici :
                              http://joomla.fr/index.php?option=co...ques&Itemid=33

                              Cordialement,
                              Chabi01 - http://www.xlformation.com

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X