Je n'arrive plus à ouvrir mon Fronted !

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Je n'arrive plus à ouvrir mon Fronted !

    Bonjour,

    Je n'arrive plus à ouvrir mon site sur le fronted.

    En backend tout fonctionne.

    J'ai ce message sous Safari " Trop de redirections sont survenues en tentant d’ouvrir « http://www.monptiplat.org/index.php? ». Ceci peut se produire lorsque vous ouvrez une page qui est redirigée vers une autre page laquelle se redirige à son tour vers la page originale".

    Et celui-ci sous Firefox "La page n'est pas redirigée correctement Firefox a détecté que le serveur redirige la demande pour cette adresse d'une manière qui n'aboutira pas.

    Je suis sous Joomla 2.5 .

    Merci d'avance pour votre aide !

    Guy
    Avoir la volonté d'apprendre, c'est prendre le chemin de la connaissance !

  • #2
    Re : Je n'arrive plus à ouvrir mon Fronted !

    Qu'est-ce que tu as bricolé auparavant ? ton .htaccess ?
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Re : Je n'arrive plus à ouvrir mon Fronted !

      Bonjour,

      Ben non, avant de modifier un fichier (si cela avait été le cas) de toute façon je le sauvegarde ou le renomme de façon à le reprendre quand je veux.

      Ce n'est donc pas cela...
      Avoir la volonté d'apprendre, c'est prendre le chemin de la connaissance !

      Commentaire


      • #4
        Re : Je n'arrive plus à ouvrir mon Fronted !

        Bonsoir,

        J'ai du mieux. J'arrive maintenant à accéder a la page identification du fronted vu que mon site n'est pas en ligne.
        Après avoir taper mon identification j'obtenais le même message !
        J'ai donc décidé de me connecter avec un .com et de mettre mon site en ligne.
        Miracle mon fronted est apparu mais avec la terminaison suivante /index.php?lang=en.

        J'ai donc effacé .com pour mettre .org et cela a fonctionné sous Firefox
        Sous Safari tjrs bloqué.

        Il faut dire que j'ai modifié Firefox pour permettre de mettre jusqu'a 500 Redirection... comme ci-dessous
        1. Taper dans la barre d'adresses de Firefox: "about:config", vous aurez alors la liste des variables utilisés par firefox et leur valeurs.
        2. Filtrer en utilisant le mot clé "redirect", vous aurez alors un petit nombre de lignes.
        3. Faire un double clic sur le nom network.http.redirection-limit et saisissez une valeur plus élevée comme 500 par exemple,
        firefox permettra 500 redirections avant d'afficher le message d'erreur au lieu des 20 par défaut.

        J'ai remis mon site Hors Ligne.

        Sous firefox Je tape mon site.com et cela marche et si je tape .org ca ne marche pas.
        Sous safari c'est comme avant rien ne fonctionne...

        Comprenez vous ce qu'il se passe....
        Avoir la volonté d'apprendre, c'est prendre le chemin de la connaissance !

        Commentaire


        • #5
          Re : Je n'arrive plus à ouvrir mon Fronted !

          Si tu as plusieurs noms de domaine (ou le même avec plusieurs extensions) menant au site via des redirections, et que ça se met à tourner en boucle avec le org renvoyant au com et inversement, ta limitation au-delà de 500 va vite saturer.
          Comment as-tu fait ces redirections et n'y a-t-il pas des adresses dans le site qui utilisent précisément une extension plutôt qu'une autre, lançant ainsi la boucle infinie ?
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            Re : Je n'arrive plus à ouvrir mon Fronted !

            Bonjour

            J'ai trouvé et je vais décrire si cela peut aidé....

            Avec tous ces problèmes, j'avais désactivé le composant h404SEF.
            Les personnes de sh404SEF suivant le problème avec moi m'avait demandé de le désactivé.

            1/ J'ai remis sh404SEF en activation en mettant hors .htaccess
            et là plus rien alors ne fonctionnait.

            2/J'ai donc désactivé à nouveau ce composant et remis tout comme avant et j'ai noté que
            sous monsite.info ou monsite.com on avait la terminaison suivante:

            http://monsite.info/index.php?lang=en
            et on arrivait à la page on l'on doit rentrer ces codes vu que le site est hors ligne.

            3/ J'ai donc taper mes code et enlevé la terminaison suivante ( ?lang=en )
            http://monsite.info/index.php
            et j'ai eu l'erreur suivante:

            Fatal error: Call to undefined method JException::setModel() in controller.php on line 112

            4/ Mon site est en en francais et je suis donc allé dans l'administration et mettre le backend en Anglais par défaut et le fronted aussi.

            Et la miracle je tape monsite.org et tout marche normalement, et l'adresse qui apparait est bien avec la terminaison suivante: http://www.monsite.org/index.php?lang=en

            Le problème c'est que mon site apparait en Anglais ((

            Mais déjà il s'affiche en fronted ce qui est positif .

            En fait j'ai noté quela terminaison "?lang=en" était liée à la langue de contenu.

            Comme je ne travaille pas en multilingue je suis allé vérifier le plugin Languagefilter et bien que tout fonctionnait avant car je l'avais désactivé.
            Et là surprise il était réactivé, je l'ai donc à nouveau désactivé.
            Suite à cela j'ai tout remis en Francais backend et fronted et retapé "monsite.org" et là l'adresse reste
            monsite.org et tout fonctionne bien )

            Je pense que là il y a du avoir un truc.

            Comme je suis en 2.5 que seulement depuis 1 ou 2 jours, que j'utilise deux composants pour l'instant YooRecipe et sh404SEF , donc pas de grande modif que le site, je ne vois pas ce qui a fait réactivé le plugin.

            Mais tout marche bien c'est le principal. ( je n'ai pas encore réactivé sh404SEF toutefois mais je vais testé )

            Donc si vous avez dans votre URL "?lang=en", aller voir du côté du multilingue, langue de contenu et pluging...

            Cordialement,
            Avoir la volonté d'apprendre, c'est prendre le chemin de la connaissance !

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins
            Travaille ...
            X