Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

    Bonsoir,

    Novice , je tatonne mon site marchand en local depuis 1 an : joomla1.5 +virtuemart+template gantry+css customisé.
    Tout comme j'ai pu, grace à vos précieux conseils. hében ça marche. Pas peu fier, enfin décidé à le mettre en ligne pour fin mars, je viens d'apprendre la nécessaire migration. Car c'est ça! y'a pas d'autres choix ?!

    Alors ma question est, gentle joomla people, pour un novice - vers laquelle svp ? et quelles conséquences ?
    Merci pour vos réponses.

  • #2
    Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

    Bonsoir et bienvenue sur le forum,

    Si j'ai bien compris votre problème ??

    Pas d'autre alternative que 2.5.X

    Cordialement,
    Joël

    Commentaire


    • #3
      Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

      merci Joël,
      Ben là ça devient un problème. car au vu des sujets parcourus avant de poster, ça avait pas l'air immédiat. Dans ma question y'avait l'indice - novice . pour espérer qu'en 1.6.x voir 1.7.3 ça puisse le faire - versions qui tournent aujourd'hui non? et pour combien de temps encore. la révolution 2.5 n'est pas une alternative, c'est la torture après la galère... jusque là passionnante .
      Je vois votre expérience et vous remercie de m'éclairer.
      Salutations.

      Commentaire


      • #4
        Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

        pour espérer qu'en 1.6.x voir 1.7.3 ça puisse le faire - versions qui tournent aujourd'hui non?
        Oui elles tournent
        Non ce n'est pas une solution

        Les 1.6 sont déjà (non maintenu). Pour les 1.7, si ce n'est pas encore le cas, c'est une question de jours

        Donc 2.5.x (en lts) impératif

        Commentaire


        • #5
          Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

          Ca a l'air aussi dur que ça l'est ?

          Juste pour savoir de quoi sera rempli le vide dans lequel je sauterais... si j'arrive à lire l'infographie:

          A la première question? mon site est pas encore en ligne !!
          la deuz - une boutique en ligne ça se protège fort?!?
          la suite OK, à part un peu de bidouille-design css.php , j'ai le coeur de la boutique
          réapprendre les nouveautés du joom ok, mais quant aux résultats de la migration ...

          ma config semble ok : wamp-PHP5.3-SQL5.136-apache 2.2.11.

          2.5.x (en lts) ... ? mst IIS7 ?? c'est quoi ?

          et la classique : quelles conséquences et incompatibilités assurées avec les extensions et contenu du site selon vous... à la louche. genre ça va faire mal docteur?

          Sans vouloir vous monopoliser.

          Commentaire


          • #6
            Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

            2.5.x (en lts) ... ? mst IIS7 ?? c'est quoi ?
            Avec la 2.5.x, vous êtes ok pour 2 ans sans migration (uniquement les maj de sécurité)

            IIS et joomla (why not) !!!

            C'est quand même plus conçu pour tourner sous apache

            Commentaire


            • #7
              Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

              merci pour l'info. ça tombe bien, je suis plutot indien.

              C'est pas que je réfléchisse longtemps et pas vite, mais doucement et sur plusieurs sujets.
              depuis le temps que je voulais vous écrire pour de la déco... voilà qu'on cause perso. je vous remercie et espère que ça profite à d'autres. donc en court : sauvegarder une copie de mon wamp et trouver la meilleure façon d'y passer : +1,

              - replatrer le 2.5.x - je recherche le tuto en même temps. avec jupgraden éventuellement ??!
              - je recherche et mets à jour extensions compatibles 2.5 - et autres plugins dont j'ai fait la liste quelquepart
              - t'encastres le tout et tu lances ton adresse - la même d'ailleurs?!

              La suite à boir. mais si vous pensez à un ou deux conseils tellement évidents que non postés, je suis preneur.
              Je recherche tout ça.
              merci encore

              Cordialement
              julien

              Commentaire


              • #8
                Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

                La première chose à faire sera de passer en version 2 de Virtuemart car la 1.1.9 ne fonctionne pas sous Joomla! 2.5 et si tu tentes une migration 1.5->2.5 avec un VM 1.1.9, tu vas droit au mur.

                Cette version 2 n'est pas encore suffisamment avancée au niveau de ses compléments pour t'y lancer aujourd'hui, je pense.
                Donc pas de précipitation ! Continue à peaufiner ton site, et surveille l'évolution de VM et celle des extensions que tu auras besoin de migrer en version 2.5 : quand tout sera stabilisé, tu pourras donc d'abord passer VM en version 2 sur ton site 1.5 puis bien vérifier son fonctionnement, avant de te lancer dans la migration de Joomla!, avant ou après la mise en ligne du site (sachant que si c'est après, il te faudra mettre le site hors-ligne pendant cette migration pour éviter que des clients s'enregistrent et passent des commandes entre le moment où tu feras ta sauvegarde du site 1.5 et celui où ils pourront disposer de la version 2.5)
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

                  Ca a le mérite de temporiser. et d'être franc.
                  Merci de votre intervention.

                  Dois-je déjà charger les mises à jour des plugins et extensions sur la version 1.5 ?

                  Commentaire


                  • #10
                    Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

                    Tu as en effet intérêt à faire régulièrement les mises à jour de toutes tes extensions : c'est d'abord prendre une bonne habitude, et ça te permettra, pour celles qui ont une version compatible 2.5, de récupérer plus facilement les données lorsque tu migreras.
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                    Commentaire


                    • #11
                      Re : Et je croyais avoir fini ... Migrer oui mais pour qui ??? 1.6 - 7 - ...>2.5

                      c'est d'abord prendre une bonne habitude,

                      Ca fait longtemps que je pense à tous rebalayer, ça doit être l'occasion!
                      Comme ça pour éviter d'être brouillon dans cette aventure au dela des mises à jour;
                      existe t'il dans l'info web, des méthodo, check-list pour organiser son projet et maitriser ses données ?

                      Je fais le tour des crèmeries.
                      Merci encore

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X