Problème d'envoi de mail

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème d'envoi de mail

    Bonjour à tous,

    Je rencontre actuellement un problème lors de l'utilisation du composant com_mailto par l'intermédiaire de la fonctionnalité "Envoyer à un ami".

    En effet, lorsque je rempli le formulaire et que je clique sur "Envoyer", j'ai systématiquement le message d'erreur suivant :

    L'e-mail ne peut pas être envoyé


    Cela m'a tout d'abord permis d'identifier un problème de configuration du serveur SMTP dans la partie administration. Une fois réglé, je suis confronté à un comportement très étrange.
    • Lorsque j'ouvre la popup, que je rempli le formulaire et que je valide, j'ai toujours la même erreur.
    • JE laisse ma fenêtre ouverte et je valide plusieurs fois sans succès
    • J'attends un temps aléatoire et je valide à nouveau le formulaire et la ça passe, ce qui m'a fait penser à une temporisation du serveur.

    La ou ça ne colle pas, c'est que je peux attendre longtemps entre deux envois, j'ai toujours l'erreur au premier essai. Impossible de comprendre le truc

    Et le message d'erreur est tellement générique que ce n'est pas fait pour m'aider. C'est vraiment frustrant car inutilisable. J'ai déjà moi même mis du temps à comprendre que ça ne venait pas de la configuration (enfin je ne pense pas...)

    Chose qui a sans doute son importance, l'assoc pour qui je réalise le site est hébergée chez OVH en 60gp (oui ça date...).

    Si vous pouviez m'aider à comprendre et peut-être m'accompagner dans la résolution de ce problème...

    Par avance Merci

  • #2
    Re : Problème d'envoi de mail

    Bon et bien je me réponds à moi même :

    En fait ca vient du composant com_mailto (controller.php), c'est le fonctionnement normal :
    Code PHP:
    $timeout $session->get('com_mailto.formtime'0);
    if (
    $timeout == || time() - $timeout 20) {
        
    JError::raiseNotice(500JText:: ('COM_MAILTO_EMAIL_NOT_SENT'));
        return 
    $this->mailto();

    Dès que la fenêtre d'envoi du message est ouverte, il faut attendre 20 secondes avant de cliquer sur valider.
    Si on clique avant les 20 secondes, il faut attendre de nouveau 20 secondes, etc...

    Dommage que le message ne soit pas plus claire, car du point de vue d'un utilisateur, la conclusion, est que ça ne fonctionne tout simplement pas, et donc qu'on ne l'utilise plus.

    En supprimant ce test, je n'ai plus le problème. Donc sans modifier le contrôleur (car c'est pas propre) j'ai modifié la vue pour afficher un message d'avertissement avec compte à rebours javascript de 20s qui active le bouton expédier à la fin du décompte.
    Dernière édition par Boumbo44 à 19/02/2012, 13h07

    Commentaire


    • #3
      Re : Problème d'envoi de mail

      Envoyé par Boumbo44 Voir le message
      j'ai modifié la vue pour afficher un message d'avertissement avec compte à rebours javascript de 20s qui active le bouton expédier à la fin du décompte.
      Alleluia !

      Merci beaucoup pour ton dépannage. J'ai eu exactement le même problème.

      Par contre ta solution m'interresse beaucoup. Penses-tu pouvoir la mettre en ligne ?

      Merci d'avance.

      Commentaire


      • #4
        Re : Problème d'envoi de mail

        Oui bien sûr. C'est du brut de fonderie (j'ai pas les sources sur moi). En gros j'ai surchargé la vue du composant com_mailto :

        Le fichier javascript qui contrôle la validation du formulaire :
        // global time to wait before form validation
        var eTime = 20;

        // submit form
        Joomla.submitbutton = function(pressbutton) {
        var form = document.getElementById('mailtoForm');
        // do field validation
        if (eTime > 0) {
        alert('Vous devez patienter encore '+eTime+' secondes avant de valider le formulaire');
        return false;
        }
        else if (form.mailto.value == "" || form.from.value == "") {
        alert('Veuillez saisir une adresse e-mail valide.');
        return false;
        }
        form.submit();
        }
        Le formulaire :
        <form action="http://www.savate44.fr/index.php" id="mailtoForm" method="post">
        ...
        <p style="text-align: center;">
        <button class="button" onclick="return Joomla.submitbutton('send');">Expédier</button>
        <button class="button" onclick="window.close();return false;">Annuler</button>
        </p>
        ...
        </form>
        Le petit texte que j'affiche par défaut :
        <div class="info">
        Merci de patienter encore <input type="text" name="counter" id="counter" value="20"></input>secondes avant de cliquer sur le bouton "Exp&eacute;dier" <span style="font-size: 9px;font-style: italic;">(protection anti-spam)</span>
        </div>
        Et le javascript pour la décrémentation du compteur :
        var eCounterId='counter'
        function counterRefresh() {
        document.getElementById(eCounterId).value=eTime;
        if (eTime > 0) {
        eTime--;
        setTimeout("counterRefresh();",1000);
        }
        }
        function counter(){
        if (eTime>0){
        setTimeout("counterRefresh();",0);
        }
        }
        counter();

        Commentaire

        Annonce

        Réduire
        1 sur 2 < >

        C'est [Réglé] et on n'en parle plus ?

        A quoi ça sert ?
        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
        Comment ajouter la mention [Réglé] à votre discussion ?
        1 - Aller sur votre discussion et éditer votre premier message :


        2 - Cliquer sur la liste déroulante Préfixe.

        3 - Choisir le préfixe [Réglé].


        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

        2 sur 2 < >

        Assistance au forum - Outil de publication d'infos de votre site

        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

        UTILISER À VOS PROPRES RISQUES :
        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

        Problèmes connus :
        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

        Installation :

        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

        Archive zip : https://github.com/AFUJ/FPA/zipball/master

        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
        et remplacer www. votresite .com par votre nom de domaine


        Exemples:
        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/
        Pour executer le script: http://www..com/fpa-fr.php

        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/cms/
        Pour executer le script: http://www..com/cms/fpa-fr.php

        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
        Voir plus
        Voir moins
        Travaille ...
        X